summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-14 19:19:57 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-14 19:19:57 +0000
commitdbddada7de5f6dc8fc592a29b7e2d6b44c95e72e (patch)
tree46a87889975f1bfa6c63fd92c159b211b3fc1bae /media-video/oxine/oxine-0.1.ebuild
parentversion bump (diff)
downloadgentoo-2-dbddada7de5f6dc8fc592a29b7e2d6b44c95e72e.tar.gz
gentoo-2-dbddada7de5f6dc8fc592a29b7e2d6b44c95e72e.tar.bz2
gentoo-2-dbddada7de5f6dc8fc592a29b7e2d6b44c95e72e.zip
Initial version. Closes #17447.
Diffstat (limited to 'media-video/oxine/oxine-0.1.ebuild')
-rw-r--r--media-video/oxine/oxine-0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/oxine/oxine-0.1.ebuild b/media-video/oxine/oxine-0.1.ebuild
new file mode 100644
index 000000000000..9e3263a76e51
--- /dev/null
+++ b/media-video/oxine/oxine-0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2003 Fridtjof Busse <fridtjof@fbunet.de>.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/oxine/oxine-0.1.ebuild,v 1.1 2003/03/14 19:19:57 agenkin Exp $
+
+DESCRIPTION="OSD frontend for xine"
+HOMEPAGE="http://oxine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=media-libs/xine-lib-1_beta8
+ lirc? ( app-misc/lirc )
+ nls? ( sys-devel/gettext )
+ virtual/x11"
+
+IUSE="nls lirc"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/oxine/${P}.tar.gz"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use lirc || myconf="${myconf} --disable-lirc"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README TODO
+}