summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-15 13:53:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-15 13:53:12 +0000
commit2d0d8fd12fdf633b5086c05851b4d68830d7c097 (patch)
tree49e5c94bd0a07c7d20d62711f9f02d29f435ae3f /media-video/piave/piave-0.2.4-r1.ebuild
parentUpdated description (diff)
downloadgentoo-2-2d0d8fd12fdf633b5086c05851b4d68830d7c097.tar.gz
gentoo-2-2d0d8fd12fdf633b5086c05851b4d68830d7c097.tar.bz2
gentoo-2-2d0d8fd12fdf633b5086c05851b4d68830d7c097.zip
Cleaned up ebuild to not use gcc eclass. Moved patches in src_unpack. Moved pkgconfig to DEPEND.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'media-video/piave/piave-0.2.4-r1.ebuild')
-rw-r--r--media-video/piave/piave-0.2.4-r1.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/media-video/piave/piave-0.2.4-r1.ebuild b/media-video/piave/piave-0.2.4-r1.ebuild
index ce882beb0e04..a8bd8909e252 100644
--- a/media-video/piave/piave-0.2.4-r1.ebuild
+++ b/media-video/piave/piave-0.2.4-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/piave/piave-0.2.4-r1.ebuild,v 1.6 2005/03/03 16:02:05 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/piave/piave-0.2.4-r1.ebuild,v 1.7 2005/05/15 13:53:12 flameeyes Exp $
-inherit eutils gcc
+inherit eutils
DESCRIPTION="PIAVE - Piave Is A Video Editor"
HOMEPAGE="http://modesto.sourceforge.net/piave/index.html"
@@ -13,8 +13,7 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-DEPEND="virtual/x11
- >=dev-util/pkgconfig-0.15.0
+RDEPEND="virtual/x11
>=dev-libs/libxml2-2.5.11
>=dev-cpp/libxmlpp-0.21.0
>=media-libs/gdk-pixbuf-0.22.0
@@ -27,16 +26,22 @@ DEPEND="virtual/x11
>=sys-libs/libavc1394-0.4.1
media-libs/nas"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15.0"
-src_compile() {
+src_unpack() {
+ unpack ${A}
cd ${S}
+
epatch ${FILESDIR}/piave-0.2.4-include-arts.diff
- if [ "`gcc-minor-version`" -eq "4" ]
- then
epatch ${FILESDIR}/piave-0.2.4-gcc34.patch
- fi
- myconf=${myconf}" --with-gnu-ld `use_enable nls`"
- econf ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "configure failed"
+
emake || die
}