summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-24 21:10:09 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-24 21:10:09 +0000
commite57834383b223f371d157ac26907c9ed43984e0b (patch)
treef9d12709d1022a82a4d10853d07c29a32c8731e4 /media-video/pitivi
parentfix python eclass use, bug #207667 (diff)
downloadgentoo-2-e57834383b223f371d157ac26907c9ed43984e0b.tar.gz
gentoo-2-e57834383b223f371d157ac26907c9ed43984e0b.tar.bz2
gentoo-2-e57834383b223f371d157ac26907c9ed43984e0b.zip
fix python eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video/pitivi')
-rw-r--r--media-video/pitivi/ChangeLog7
-rw-r--r--media-video/pitivi/pitivi-0.11.1.ebuild24
2 files changed, 26 insertions, 5 deletions
diff --git a/media-video/pitivi/ChangeLog b/media-video/pitivi/ChangeLog
index a7c2bb224ac2..feb56c2e38fc 100644
--- a/media-video/pitivi/ChangeLog
+++ b/media-video/pitivi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/pitivi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.10 2007/12/01 16:57:50 hanno Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.11 2008/02/24 21:10:09 eva Exp $
+
+ 24 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org> pitivi-0.11.1.ebuild:
+ fix python eclass use, bug #207667
*pitivi-0.11.1 (01 Dec 2007)
diff --git a/media-video/pitivi/pitivi-0.11.1.ebuild b/media-video/pitivi/pitivi-0.11.1.ebuild
index cc7639a31837..a0eee0a33e26 100644
--- a/media-video/pitivi/pitivi-0.11.1.ebuild
+++ b/media-video/pitivi/pitivi-0.11.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.11.1.ebuild,v 1.1 2007/12/01 16:57:50 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.11.1.ebuild,v 1.2 2008/02/24 21:10:09 eva Exp $
-inherit gnome2
+inherit gnome2 python
DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
HOMEPAGE="http://www.pitivi.org"
@@ -30,9 +30,27 @@ RDEPEND="${DEPEND}
DOCS="AUTHORS ChangeLog NEWS RELEASE"
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
src_compile() {
addpredict $(unset HOME; echo ~)/.gconf
addpredict $(unset HOME; echo ~)/.gconfd
addpredict $(unset HOME; echo ~)/.gstreamer-0.10
gnome2_src_compile
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize "/usr/$(get_libdir)/${PN}/python/${PN}"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "/usr/$(get_libdir)/${PN}/python/${PN}"
+}