summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-02-13 13:33:15 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-02-13 13:33:15 +0000
commit016a6dc493a6952bf3b64580020ae71060afce33 (patch)
tree2c933cb5d4c6bad92f8574d78769cbdb60885cf6 /media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
parentMake maildrop use courier-authlib and clean the ebuild. Re-Closes #81391. (diff)
downloadgentoo-2-016a6dc493a6952bf3b64580020ae71060afce33.tar.gz
gentoo-2-016a6dc493a6952bf3b64580020ae71060afce33.tar.bz2
gentoo-2-016a6dc493a6952bf3b64580020ae71060afce33.zip
Initial ebuild as per bug #81826
(Portage version: 2.0.51.16)
Diffstat (limited to 'media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild')
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild b/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
new file mode 100644
index 000000000000..364e0c04d3f2
--- /dev/null
+++ b/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild,v 1.1 2005/02/13 13:33:15 dragonheart Exp $
+
+inherit kde-functions
+
+DESCRIPTION="QDVDAuthor, the GUI frontend for dvdauthor and other related tools."
+HOMEPAGE="http://qdvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qdvdauthor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=media-video/dvdauthor-0.6.10
+ >=media-gfx/imagemagick-5.5.7.11
+ >=media-video/mjpegtools-1.6.2
+ >=media-libs/xine-lib-1_rc5
+ >=media-video/dvd-slideshow-0.6.0
+ media-sound/sox
+ media-sound/lame
+ media-libs/libogg"
+
+# xine-libs or mplayer libs or media-video/vlc - mplayer use flags?
+
+need-qt 3.2
+
+# >=media-video/dvd-slideshow-0.6.0 -> optional
+
+src_compile() {
+
+ ./configure --with-xine-support || die "config fault"
+ #export IMAGE_LIB="imagemagicklib" # QTDIR="$QTDIR" QT_LIB="$QT_LIB"
+ # fixing defaults from /usr/local/bin to gentoo default /usr/bin
+ #export VIDEO_LIB="xine"
+ #export QT_LIB="$QTDIR"
+ sed -i "s|/usr/local/bin|/usr/bin|g" qdvdauthor/qdvdauthor.cpp qdvdauthor/dialogexecute.cpp doc/sound.txt
+ cd qdvdauthor
+ qmake qdvdauthor.pro
+
+ # fixing Makefile, so that we can use our CFLAGS
+ sed -i -e "s|^CFLAGS.*-O2|CFLAGS = ${CFLAGS} |g" -e "s|^CXXFLAGS.*-O2|CXXFLAGS = ${CXXFLAGS} |g" Makefile
+ emake || die "emake qdvdauthor failed"
+
+ cd qslideshow
+ qmake qslideshow.pro
+ # fixing Makefile, so that we can use our CFLAGS
+ sed -i -e "s|^CFLAGS.*-O2|CFLAGS = ${CFLAGS} |g" -e "s|^CXXFLAGS.*-O2|CXXFLAGS = ${CXXFLAGS} |g" Makefile
+ emake || die "emake qslideshow failed"
+}
+
+src_install() {
+ make -C qdvdauthor INSTALL_ROOT=${D} install || die "qdvdauthor install failed"
+ make -C qdvdauthor/qslideshow INSTALL_ROOT=${D} install || die "qslideshow install failed"
+
+ #had to prevent it from trying to install dvdproject link
+ dobin bin/q*
+ dodoc CHANGELOG COPYING INSTALL README TODO doc/*
+ insinto "/usr/share/applications"
+ doins qdvdauthor.desktop
+ insinto "/usr/share/pixmaps"
+ doins qdvdauthor.png
+}