summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-10-25 19:28:41 +0000
committerMichał Górny <mgorny@gentoo.org>2010-10-25 19:28:41 +0000
commit53cc5e65945e7135f096896b174a84123c661699 (patch)
treefbba4bdba3c11a88c18f1321f985646d6f770dc4 /media-video/stk11xx
parentDrop ia64/sparc keywords (diff)
downloadgentoo-2-53cc5e65945e7135f096896b174a84123c661699.tar.gz
gentoo-2-53cc5e65945e7135f096896b174a84123c661699.tar.bz2
gentoo-2-53cc5e65945e7135f096896b174a84123c661699.zip
Import from the Sunrise overlay per bug #178946. Thanks to Krzysztof Magusiak for his effort.
(Portage version: 2.2.0_alpha1_p12/cvs/Linux x86_64)
Diffstat (limited to 'media-video/stk11xx')
-rw-r--r--media-video/stk11xx/ChangeLog11
-rw-r--r--media-video/stk11xx/files/stk11xx-v4l_compat_ioctl32.diff15
-rw-r--r--media-video/stk11xx/metadata.xml9
-rw-r--r--media-video/stk11xx/stk11xx-2.1.0.ebuild29
4 files changed, 64 insertions, 0 deletions
diff --git a/media-video/stk11xx/ChangeLog b/media-video/stk11xx/ChangeLog
new file mode 100644
index 000000000000..1cc0cf5d88f6
--- /dev/null
+++ b/media-video/stk11xx/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-video/stk11xx
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/stk11xx/ChangeLog,v 1.1 2010/10/25 19:28:41 mgorny Exp $
+
+*stk11xx-2.1.0 (25 Oct 2010)
+
+ 25 Oct 2010; Michał Górny <mgorny@gentoo.org>
+ +files/stk11xx-v4l_compat_ioctl32.diff, +stk11xx-2.1.0.ebuild, +metadata.xml:
+ Import from the Sunrise overlay per bug #178946. Thanks to Krzysztof Magusiak
+ for his effort.
+
diff --git a/media-video/stk11xx/files/stk11xx-v4l_compat_ioctl32.diff b/media-video/stk11xx/files/stk11xx-v4l_compat_ioctl32.diff
new file mode 100644
index 000000000000..1f9e77b14a58
--- /dev/null
+++ b/media-video/stk11xx/files/stk11xx-v4l_compat_ioctl32.diff
@@ -0,0 +1,15 @@
+Patch fixing compilation on amd64, thanks to Krzysztof Magusiak.
+Upstream accepted and applied into r95:
+ http://syntekdriver.svn.sourceforge.net/viewvc/syntekdriver?view=rev&revision=95
+
+--- stk11xx-2.1.0/stk11xx-v4l.c.old 2009-07-03 19:27:15.882898391 +0200
++++ stk11xx-2.1.0/stk11xx-v4l.c 2009-07-03 19:27:40.246883049 +0200
+@@ -1733,7 +1733,7 @@
+ .poll = v4l_stk11xx_poll,
+ .mmap = v4l_stk11xx_mmap,
+ .ioctl = v4l_stk11xx_ioctl,
+-#ifdef CONFIG_COMPAT
++#if defined(CONFIG_COMPAT) && defined(v4l_compat_ioctl32)
+ .compat_ioctl = v4l_compat_ioctl32,
+ #endif
+ };
diff --git a/media-video/stk11xx/metadata.xml b/media-video/stk11xx/metadata.xml
new file mode 100644
index 000000000000..af81389004c1
--- /dev/null
+++ b/media-video/stk11xx/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-video/stk11xx/stk11xx-2.1.0.ebuild b/media-video/stk11xx/stk11xx-2.1.0.ebuild
new file mode 100644
index 000000000000..73daae79f779
--- /dev/null
+++ b/media-video/stk11xx/stk11xx-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/stk11xx/stk11xx-2.1.0.ebuild,v 1.1 2010/10/25 19:28:41 mgorny Exp $
+
+EAPI=2
+
+inherit base linux-mod
+
+DESCRIPTION="A driver for Syntek webcams often found in Asus notebooks"
+HOMEPAGE="http://syntekdriver.sourceforge.net/"
+SRC_URI="mirror://sourceforge/syntekdriver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+MODULE_NAMES="${PN}(media/video:)"
+CONFIG_CHECK="VIDEO_DEV VIDEO_V4L1_COMPAT"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="${PN}.ko"
+ BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
+
+ PATCHES=( "${FILESDIR}"/${PN}-v4l_compat_ioctl32.diff )
+ MODULESD_STK11XX_DOCS=( README )
+}