summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-07 02:26:12 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-07 02:26:12 +0000
commit22890a2540290cfc15e7640b96b249d46ae0a54b (patch)
treefe5513615c23de22de8d4bbfb12fe37a84ae7f69 /media-video/transcode
parentmultilib fixes. (Manifest recommit) (diff)
downloadgentoo-2-22890a2540290cfc15e7640b96b249d46ae0a54b.tar.gz
gentoo-2-22890a2540290cfc15e7640b96b249d46ae0a54b.tar.bz2
gentoo-2-22890a2540290cfc15e7640b96b249d46ae0a54b.zip
get_libdir fixes.
Diffstat (limited to 'media-video/transcode')
-rw-r--r--media-video/transcode/ChangeLog6
-rw-r--r--media-video/transcode/transcode-0.6.12-r1.ebuild6
-rw-r--r--media-video/transcode/transcode-0.6.12-r2.ebuild12
3 files changed, 14 insertions, 10 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index c0a9775ce74c..42347747fb88 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/transcode
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.72 2004/09/30 01:37:41 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.73 2004/10/07 02:26:12 eradicator Exp $
+
+ 06 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ transcode-0.6.12-r1.ebuild, transcode-0.6.12-r2.ebuild:
+ get_libdir fixes
*transcode-0.6.12-r2 (29 Sep 2004)
diff --git a/media-video/transcode/transcode-0.6.12-r1.ebuild b/media-video/transcode/transcode-0.6.12-r1.ebuild
index a392193f9238..46e0fd91efcb 100644
--- a/media-video/transcode/transcode-0.6.12-r1.ebuild
+++ b/media-video/transcode/transcode-0.6.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.12-r1.ebuild,v 1.13 2004/06/28 06:24:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.12-r1.ebuild,v 1.14 2004/10/07 02:26:12 eradicator Exp $
inherit libtool flag-o-matic eutils gcc
@@ -81,9 +81,9 @@ src_compile() {
fi
# Use the MPlayer libpostproc if present
- [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/$(get_libdir)/libpostproc.a ] && \
[ -f ${ROOT}/usr/include/postproc/postprocess.h ] && \
- myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/$(get_libdir)"
econf \
CFLAGS="${CFLAGS} -DDCT_YUV_PRECISION=1" \
diff --git a/media-video/transcode/transcode-0.6.12-r2.ebuild b/media-video/transcode/transcode-0.6.12-r2.ebuild
index edd63c2b4395..c0d469eac52b 100644
--- a/media-video/transcode/transcode-0.6.12-r2.ebuild
+++ b/media-video/transcode/transcode-0.6.12-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.12-r2.ebuild,v 1.1 2004/09/30 01:07:00 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.12-r2.ebuild,v 1.2 2004/10/07 02:26:12 eradicator Exp $
-inherit libtool flag-o-matic gcc
+inherit libtool flag-o-matic eutils gcc
# dont strip binarys causes missing symbol problems
# with pvm compiles
@@ -16,7 +16,7 @@ SRC_URI="http://www.zebra.fh-weingarten.de/~transcode/pre/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc -sparc -amd64"
+KEYWORDS="~x86 ~ppc -sparc ~amd64"
IUSE="sdl static mpeg mmx sse 3dnow encode X quicktime avi altivec oggvorbis theora pvm"
DEPEND=">=media-libs/a52dec-0.7.4
@@ -111,9 +111,9 @@ src_compile() {
--with-pvm3-include=/usr/local/pvm3/include"
# Use the MPlayer libpostproc if present
- [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/$(get_libdir)/libpostproc.a ] && \
[ -f ${ROOT}/usr/include/postproc/postprocess.h ] && \
- myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/$(get_libdir)"
append-flags -DDCT_YUV_PRECISION=1
@@ -150,7 +150,7 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README TODO