summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2011-10-23 15:50:05 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2011-10-23 15:50:05 +0000
commit74ea33a777bf540a1c00140268b6861de3d8dc40 (patch)
treeed1fabe9c76746ce120caf0ff5f5b4fae9840d02 /media-video/vdr/files/vdr-1.6.0-shared-tinyxml.diff
parentalpha/ia64/sh/sparc stable wrt #385789 (diff)
downloadgentoo-2-74ea33a777bf540a1c00140268b6861de3d8dc40.tar.gz
gentoo-2-74ea33a777bf540a1c00140268b6861de3d8dc40.tar.bz2
gentoo-2-74ea33a777bf540a1c00140268b6861de3d8dc40.zip
eapi=4; removed tinyxml bundle, use now externel tinyxml lib; keyword ~arm droped; removed dxr3 patch, updated vdr-dxr3 dont need the patch anymore
(Portage version: 2.1.10.11/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'media-video/vdr/files/vdr-1.6.0-shared-tinyxml.diff')
-rw-r--r--media-video/vdr/files/vdr-1.6.0-shared-tinyxml.diff39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-video/vdr/files/vdr-1.6.0-shared-tinyxml.diff b/media-video/vdr/files/vdr-1.6.0-shared-tinyxml.diff
new file mode 100644
index 000000000000..2f33b2693275
--- /dev/null
+++ b/media-video/vdr/files/vdr-1.6.0-shared-tinyxml.diff
@@ -0,0 +1,39 @@
+diff -Naur vdr-1.6.0.orig/Makefile vdr-1.6.0/Makefile
+--- vdr-1.6.0.orig/Makefile 2010-12-29 14:58:18.000000000 +0100
++++ vdr-1.6.0/Makefile 2010-12-29 14:59:26.000000000 +0100
+@@ -53,7 +53,8 @@
+ endif
+
+ ifdef SETUP
+-OBJS += tinystr.o tinyxml.o tinyxmlerror.o tinyxmlparser.o submenu.o
++OBJS += submenu.o
++LIBS += -ltinyxml
+ endif
+
+ ifdef TTXTSUBS
+diff -Naur vdr-1.6.0.orig/submenu.c vdr-1.6.0/submenu.c
+--- vdr-1.6.0.orig/submenu.c 2010-12-29 14:58:18.000000000 +0100
++++ vdr-1.6.0/submenu.c 2010-12-29 15:00:29.000000000 +0100
+@@ -39,7 +39,7 @@
+ _currentMenu = currentMenu;
+ _level = level;
+
+- if (xml != NULL && xml->Type() == TiXmlNode::ELEMENT) {
++ if (xml != NULL && xml->Type() == TiXmlNode::TINYXML_ELEMENT) {
+ const char *tag = xml->Value();
+
+ if (cSubMenuNode::IsType(tag) != cSubMenuNode::UNDEFINED) {
+diff -Naur vdr-1.6.0.orig/submenu.h vdr-1.6.0/submenu.h
+--- vdr-1.6.0.orig/submenu.h 2010-12-29 14:58:18.000000000 +0100
++++ vdr-1.6.0/submenu.h 2010-12-29 15:01:50.000000000 +0100
+@@ -17,7 +17,9 @@
+
+ #include "thread.h"
+ #include "tools.h"
+-#include "tinystr.h"
++#define TIXML_USE_STL
++#include <tinystr.h>
++#include <tinyxml.h>
+
+ class cSubMenuNode;
+ class cSubMenuNodes;