summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-22 12:38:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-22 12:38:38 +0000
commit6fc9dad00a4e7126cffa65243a13c21cd3f16773 (patch)
tree3356bcc353bc6aaf436f5be678b4f7163955fc1d /media-video/vlc
parentfix the cachegen patch (diff)
downloadgentoo-2-6fc9dad00a4e7126cffa65243a13c21cd3f16773.tar.gz
gentoo-2-6fc9dad00a4e7126cffa65243a13c21cd3f16773.tar.bz2
gentoo-2-6fc9dad00a4e7126cffa65243a13c21cd3f16773.zip
aalib and sdl require X, bug #366815
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/ChangeLog6
-rw-r--r--media-video/vlc/vlc-1.1.10.ebuild12
-rw-r--r--media-video/vlc/vlc-1.1.9999.ebuild12
3 files changed, 21 insertions, 9 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index e10e0addfa9e..45184f5e5b36 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/vlc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.729 2011/06/22 12:27:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.730 2011/06/22 12:38:38 aballier Exp $
+
+ 22 Jun 2011; Alexis Ballier <aballier@gentoo.org> vlc-1.1.10.ebuild,
+ vlc-1.1.9999.ebuild:
+ aalib and sdl require X, bug #366815
22 Jun 2011; Alexis Ballier <aballier@gentoo.org> vlc-9999.ebuild:
fix the cachegen patch
diff --git a/media-video/vlc/vlc-1.1.10.ebuild b/media-video/vlc/vlc-1.1.10.ebuild
index 3d22bcefc516..6ae8317ba40f 100644
--- a/media-video/vlc/vlc-1.1.10.ebuild
+++ b/media-video/vlc/vlc-1.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.1.10.ebuild,v 1.5 2011/06/12 11:46:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.1.10.ebuild,v 1.6 2011/06/22 12:38:38 aballier Exp $
EAPI="3"
@@ -63,7 +63,7 @@ RDEPEND="
sys-libs/zlib
>=media-libs/libdvbpsi-0.1.6
a52? ( >=media-libs/a52dec-0.7.4-r3 )
- aalib? ( media-libs/aalib )
+ aalib? ( media-libs/aalib x11-libs/libX11 )
aac? ( >=media-libs/faad2-2.6.1 )
alsa? ( >=media-libs/alsa-lib-1.0.23 )
avahi? ( >=net-dns/avahi-0.6[dbus] )
@@ -115,7 +115,7 @@ RDEPEND="
remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
samba? ( || ( >=net-fs/samba-3.4.6[smbclient] <net-fs/samba-3.4 ) )
schroedinger? ( >=media-libs/schroedinger-1.0.10 )
- sdl? ( >=media-libs/libsdl-1.2.8
+ sdl? ( >=media-libs/libsdl-1.2.8 x11-libs/libX11
sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
shout? ( media-libs/libshout )
skins? (
@@ -185,6 +185,8 @@ pkg_setup() {
vlc_use_force vaapi ffmpeg
vlc_use_force nsplugin xcb
has_version '<media-sound/pulseaudio-0.9.22' && vlc_use_force pulseaudio X
+ vlc_use_force sdl X
+ vlc_use_force aalib X
# Useflags that will be automagically discarded if deps are not met
vlc_use_needs bidi truetype
@@ -340,7 +342,9 @@ src_configure() {
$(vlc_use_enable_force gnutls libgcrypt) \
$(vlc_use_enable_force vaapi avcodec) \
$(vlc_use_enable_force nsplugin xcb) \
- $(has_version '<media-sound/pulseaudio-0.9.22' && use pulseaudio && echo '--with-x')
+ $(has_version '<media-sound/pulseaudio-0.9.22' && use pulseaudio && echo '--with-x') \
+ $(use sdl && echo '--with-x') \
+ $(use aalib && echo '--with-x')
}
src_install() {
diff --git a/media-video/vlc/vlc-1.1.9999.ebuild b/media-video/vlc/vlc-1.1.9999.ebuild
index afdc93acb25b..2cf6b5ba5a7f 100644
--- a/media-video/vlc/vlc-1.1.9999.ebuild
+++ b/media-video/vlc/vlc-1.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.1.9999.ebuild,v 1.30 2011/06/06 16:23:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.1.9999.ebuild,v 1.31 2011/06/22 12:38:38 aballier Exp $
EAPI="3"
@@ -63,7 +63,7 @@ RDEPEND="
sys-libs/zlib
>=media-libs/libdvbpsi-0.1.6
a52? ( >=media-libs/a52dec-0.7.4-r3 )
- aalib? ( media-libs/aalib )
+ aalib? ( media-libs/aalib x11-libs/libX11 )
aac? ( >=media-libs/faad2-2.6.1 )
alsa? ( >=media-libs/alsa-lib-1.0.23 )
avahi? ( >=net-dns/avahi-0.6[dbus] )
@@ -115,7 +115,7 @@ RDEPEND="
remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
samba? ( || ( >=net-fs/samba-3.4.6[smbclient] <net-fs/samba-3.4 ) )
schroedinger? ( >=media-libs/schroedinger-1.0.10 )
- sdl? ( >=media-libs/libsdl-1.2.8
+ sdl? ( >=media-libs/libsdl-1.2.8 x11-libs/libX11
sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
shout? ( media-libs/libshout )
skins? (
@@ -185,6 +185,8 @@ pkg_setup() {
vlc_use_force vaapi ffmpeg
vlc_use_force nsplugin xcb
has_version '<media-sound/pulseaudio-0.9.22' && vlc_use_force pulseaudio X
+ vlc_use_force sdl X
+ vlc_use_force aalib X
# Useflags that will be automagically discarded if deps are not met
vlc_use_needs bidi truetype
@@ -340,7 +342,9 @@ src_configure() {
$(vlc_use_enable_force gnutls libgcrypt) \
$(vlc_use_enable_force vaapi avcodec) \
$(vlc_use_enable_force nsplugin xcb) \
- $(has_version '<media-sound/pulseaudio-0.9.22' && use pulseaudio && echo '--with-x')
+ $(has_version '<media-sound/pulseaudio-0.9.22' && use pulseaudio && echo '--with-x') \
+ $(use sdl && echo '--with-x') \
+ $(use aalib && echo '--with-x')
}
src_install() {