summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-03-28 00:01:53 +0000
committerChris White <chriswhite@gentoo.org>2005-03-28 00:01:53 +0000
commitb1e8698c733b6c44b8e606e26f47f2dcae14c08a (patch)
tree7ecdb136f07336a1114c9dbc1f95617626439807 /media-video/vstrip/vstrip-0.8f.ebuild
parentadded ~amd64 to KEYWORDS wrt #86882 (diff)
downloadgentoo-2-b1e8698c733b6c44b8e606e26f47f2dcae14c08a.tar.gz
gentoo-2-b1e8698c733b6c44b8e606e26f47f2dcae14c08a.tar.bz2
gentoo-2-b1e8698c733b6c44b8e606e26f47f2dcae14c08a.zip
Initial import into the tree. Closes bug #31519. Thanks to swegner for the ebuild!
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/vstrip/vstrip-0.8f.ebuild')
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
new file mode 100644
index 000000000000..ef210d82076e
--- /dev/null
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/vstrip-0.8f.ebuild,v 1.1 2005/03/28 00:01:53 chriswhite Exp $
+
+inherit eutils
+
+DESCRIPTION="A program to split non-css dvd vobs into individual chapters"
+HOMEPAGE="http://www.maven.de/code"
+SRC_URI="http://files.digital-digest.com/downloads/files/encode/vStrip_${PV/./}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="app-text/dos2unix"
+RDEPEND="virtual/libc"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/vstrip-0.8f-gentoo.patch
+ dos2unix -q -o *.c *.h
+
+ for file in *.c *.h ; do
+ echo >>$file
+ done
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin vstrip
+}