summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-16 14:56:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-16 14:56:39 +0000
commit2b0ff03dbecf22757526841437b0b9afc2bfacfa (patch)
tree06fdf01331cf794537a08a747eb12d98daaaba6e /media-video/xine-ui
parentConvert to EAPI-4, make use of REQUIRED_USE, simplify and remove useless ecla... (diff)
downloadgentoo-2-2b0ff03dbecf22757526841437b0b9afc2bfacfa.tar.gz
gentoo-2-2b0ff03dbecf22757526841437b0b9afc2bfacfa.tar.bz2
gentoo-2-2b0ff03dbecf22757526841437b0b9afc2bfacfa.zip
fix build with libpng 1.5
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog8
-rw-r--r--media-video/xine-ui/files/xine-ui-0.99.6-libpng15.patch13
-rw-r--r--media-video/xine-ui/xine-ui-0.99.6.ebuild9
3 files changed, 24 insertions, 6 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index ea242d4acb0f..277961cff3ef 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/xine-ui
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.173 2010/05/30 18:41:54 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.174 2011/02/16 14:56:39 aballier Exp $
+
+ 16 Feb 2011; Alexis Ballier <aballier@gentoo.org> xine-ui-0.99.6.ebuild,
+ +files/xine-ui-0.99.6-libpng15.patch:
+ fix build with libpng 1.5
30 May 2010; Raúl Porcel <armin76@gentoo.org> xine-ui-0.99.6.ebuild:
alpha/sparc stable wrt #317143
diff --git a/media-video/xine-ui/files/xine-ui-0.99.6-libpng15.patch b/media-video/xine-ui/files/xine-ui-0.99.6-libpng15.patch
new file mode 100644
index 000000000000..6a5fb5522bd7
--- /dev/null
+++ b/media-video/xine-ui/files/xine-ui-0.99.6-libpng15.patch
@@ -0,0 +1,13 @@
+Index: xine-ui-0.99.6/src/xitk/Imlib-light/load.c
+===================================================================
+--- xine-ui-0.99.6.orig/src/xitk/Imlib-light/load.c
++++ xine-ui-0.99.6/src/xitk/Imlib-light/load.c
+@@ -61,7 +61,7 @@ unsigned char *_LoadPNG(ImlibData * id,
+ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return NULL;
+ }
+- if (info_ptr->color_type == PNG_COLOR_TYPE_RGB_ALPHA)
++ if (png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_RGB_ALPHA)
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return NULL;
diff --git a/media-video/xine-ui/xine-ui-0.99.6.ebuild b/media-video/xine-ui/xine-ui-0.99.6.ebuild
index 478857810ba6..06251da64a4e 100644
--- a/media-video/xine-ui/xine-ui-0.99.6.ebuild
+++ b/media-video/xine-ui/xine-ui-0.99.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.99.6.ebuild,v 1.11 2010/05/30 18:41:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.99.6.ebuild,v 1.12 2011/02/16 14:56:39 aballier Exp $
EAPI=3
-inherit fdo-mime gnome2-utils
+inherit fdo-mime gnome2-utils eutils
DESCRIPTION="Xine movie player"
HOMEPAGE="http://xine.sourceforge.net/"
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="aalib curl debug libcaca lirc nls readline vdr X xinerama"
-RDEPEND=">=media-libs/libpng-1.2.40
+RDEPEND=">=media-libs/libpng-1.4
>=media-libs/xine-lib-1.1.17[aalib?,libcaca?]
aalib? ( media-libs/aalib )
curl? ( >=net-misc/curl-7.10.2 )
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
src_prepare() {
rm -f misc/xine-bugreport
+ epatch "${FILESDIR}/${P}-libpng15.patch"
}
src_configure() {