summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-15 11:51:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-15 11:51:46 +0000
commit322b3ce1d08589132ed2eb90a5b13a14454cf8f6 (patch)
tree72b164bb17f1ed7e1655207af310f6aa9b7cd6e1 /media-video/xine-ui
parentRespect CFLAGS, LDFLAGS and CC properly. Avoid sed on the Makefile to set pre... (diff)
downloadgentoo-2-322b3ce1d08589132ed2eb90a5b13a14454cf8f6.tar.gz
gentoo-2-322b3ce1d08589132ed2eb90a5b13a14454cf8f6.tar.bz2
gentoo-2-322b3ce1d08589132ed2eb90a5b13a14454cf8f6.zip
Add an EAPI=2 revision with USE deps on xine-lib support for aalib and libcaca.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog9
-rw-r--r--media-video/xine-ui/xine-ui-0.99.5-r2.ebuild81
2 files changed, 89 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 30810f2be1d2..57042b226210 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.163 2008/08/17 14:03:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.164 2008/10/15 11:51:46 flameeyes Exp $
+
+*xine-ui-0.99.5-r2 (15 Oct 2008)
+
+ 15 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +xine-ui-0.99.5-r2.ebuild:
+ Add an EAPI=2 revision with USE deps on xine-lib support for aalib and
+ libcaca.
17 Aug 2008; Alexis Ballier <aballier@gentoo.org> -xine-ui-0.99.5.ebuild:
remove old
diff --git a/media-video/xine-ui/xine-ui-0.99.5-r2.ebuild b/media-video/xine-ui/xine-ui-0.99.5-r2.ebuild
new file mode 100644
index 000000000000..2248576dea0e
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.99.5-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.99.5-r2.ebuild,v 1.1 2008/10/15 11:51:46 flameeyes Exp $
+
+EAPI=2
+
+# WANT_AUTOCONF=latest
+# WANT_AUTOMAKE=latest
+
+inherit eutils toolchain-funcs flag-o-matic autotools
+
+#PATCHLEVEL="11"
+DESCRIPTION="Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+# mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="X nls lirc aalib libcaca readline curl vdr xinerama debug"
+
+RDEPEND=">=media-libs/libpng-1.2.8
+ >=media-libs/xine-lib-1.1.0[aalib?,libcaca?]
+ lirc? ( app-misc/lirc )
+ aalib? ( media-libs/aalib )
+ libcaca? ( media-libs/libcaca )
+ curl? ( >=net-misc/curl-7.10.2 )
+ X? ( x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libXv
+ x11-libs/libXtst
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama ) )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ X? ( x11-libs/libXt
+ x11-proto/xf86vidmodeproto
+ x11-proto/inputproto
+ xinerama? ( x11-proto/xineramaproto ) )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-new_libcaca_api.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ rm misc/xine-bugreport
+
+ econf \
+ $(use_enable lirc) \
+ $(use_enable nls) \
+ $(use_enable vdr vdr-keys) \
+ $(use_enable xinerama) \
+ $(use_enable debug) \
+ $(use_with X x) \
+ $(use_with aalib) \
+ $(use_with libcaca caca) \
+ $(use_with curl) \
+ $(use_with readline) \
+ --without-ncurses \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" docsdir="/usr/share/doc/${PF}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Remove on next snapshot (after 20070303)
+ dodir /usr/share/applications
+ mv "${D}/usr/share/xine/desktop/xine.desktop" "${D}/usr/share/applications"
+}