summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-02 09:45:49 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-02 09:45:49 +0000
commit0aff652f78fdbfcdf4744c610bfc10885401e3ad (patch)
treea21dd2d4cc2d52066605bd93608e9b3bb81403e7 /media-video
parentVersion bump, fixes bugs #348803 #381535 and #389135. Add myself to maintaine... (diff)
downloadgentoo-2-0aff652f78fdbfcdf4744c610bfc10885401e3ad.tar.gz
gentoo-2-0aff652f78fdbfcdf4744c610bfc10885401e3ad.tar.bz2
gentoo-2-0aff652f78fdbfcdf4744c610bfc10885401e3ad.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/kmplayer/ChangeLog9
-rw-r--r--media-video/kmplayer/kmplayer-0.11.3b.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/media-video/kmplayer/ChangeLog b/media-video/kmplayer/ChangeLog
index a9e4e20880e7..4b656bfd43b6 100644
--- a/media-video/kmplayer/ChangeLog
+++ b/media-video/kmplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/kmplayer
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/ChangeLog,v 1.144 2011/10/29 20:44:53 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/ChangeLog,v 1.145 2012/02/02 09:45:49 johu Exp $
+
+*kmplayer-0.11.3b (02 Feb 2012)
+
+ 02 Feb 2012; Johannes Huber <johu@gentoo.org> +kmplayer-0.11.3b.ebuild:
+ Version bump.
*kmplayer-0.11.3a (29 Oct 2011)
diff --git a/media-video/kmplayer/kmplayer-0.11.3b.ebuild b/media-video/kmplayer/kmplayer-0.11.3b.ebuild
new file mode 100644
index 000000000000..6e3004fa339a
--- /dev/null
+++ b/media-video/kmplayer/kmplayer-0.11.3b.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/kmplayer-0.11.3b.ebuild,v 1.1 2012/02/02 09:45:49 johu Exp $
+
+EAPI=4
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fr ga gl hr hu it
+ja km ku lt lv mai nb nds nl nn pl pt pt_BR ro ru sk sr sr@latin sv th tr ug uk
+zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KMPlayer is a Video player plugin for Konqueror and basic MPlayer/Xine/ffmpeg/ffserver/VDR frontend."
+HOMEPAGE="http://kmplayer.kde.org/"
+SRC_URI="http://kmplayer.kde.org/pkgs/${P}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.2 LGPL-2.1"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo debug expat handbook npp"
+
+DEPEND="media-libs/phonon
+ expat? ( >=dev-libs/expat-2.0.1 )
+ cairo? (
+ x11-libs/cairo
+ x11-libs/pango
+ )
+ npp? (
+ dev-libs/dbus-glib
+ >=x11-libs/gtk+-2.10.14:2
+ )"
+RDEPEND="${DEPEND}
+ media-video/mplayer"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+src_prepare() {
+ sed -i \
+ -e '/add_subdirectory(icons)/d' \
+ CMakeLists.txt || die
+
+ # upstream comments doc and po folders...
+ sed -i \
+ -e 's:^#::g' \
+ CMakeLists.txt || die
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ $(cmake-utils_use cairo KMPLAYER_BUILT_WITH_CAIRO)
+ $(cmake-utils_use expat KMPLAYER_BUILT_WITH_EXPAT)
+ $(cmake-utils_use npp KMPLAYER_BUILT_WITH_NPP)
+ )
+
+ kde4-base_src_configure
+}