summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-09 09:24:15 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-09 09:24:15 +0000
commit12a551fd1fe00052a69535efee6497e97510cfcd (patch)
tree3f8022068127252d7215a3c58c7057966125e027 /media-video
parentversion bump (diff)
downloadgentoo-2-12a551fd1fe00052a69535efee6497e97510cfcd.tar.gz
gentoo-2-12a551fd1fe00052a69535efee6497e97510cfcd.tar.bz2
gentoo-2-12a551fd1fe00052a69535efee6497e97510cfcd.zip
Fix for gcc-4.3, bug #229063. Thanks to Bert Karwatzki <spasswolf@web.de>.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/streamdvd/ChangeLog8
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-gcc43.patch44
-rw-r--r--media-video/streamdvd/streamdvd-0.4-r1.ebuild5
3 files changed, 53 insertions, 4 deletions
diff --git a/media-video/streamdvd/ChangeLog b/media-video/streamdvd/ChangeLog
index bd282d73cf44..7b4f0fd735e4 100644
--- a/media-video/streamdvd/ChangeLog
+++ b/media-video/streamdvd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/streamdvd
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/streamdvd/ChangeLog,v 1.19 2007/11/27 12:10:09 zzam Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/streamdvd/ChangeLog,v 1.20 2008/07/09 09:24:15 loki_val Exp $
+
+ 09 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/streamdvd-0.4-gcc43.patch, streamdvd-0.4-r1.ebuild:
+ Fix for gcc-4.3, bug #229063. Thanks to Bert Karwatzki <spasswolf@web.de>.
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org>
streamdvd-0.4-r1.ebuild:
diff --git a/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch b/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch
new file mode 100644
index 000000000000..89e33f58db4b
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch
@@ -0,0 +1,44 @@
+diff -aur mplex.old/inputstrm.cpp mplex/inputstrm.cpp
+--- mplex.old/inputstrm.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/inputstrm.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -23,6 +23,7 @@
+
+ #include "config.h"
+ #include <assert.h>
++#include <climits>
+
+ #include "mjpeg_types.h"
+ #include "fastintfns.h"
+diff -aur mplex.old/multiplexor.cpp mplex/multiplexor.cpp
+--- mplex.old/multiplexor.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/multiplexor.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include "config.h"
+ #include <math.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ #include "mjpeg_types.h"
+ #include "mjpeg_logging.h"
+diff -aur mplex.old/padstrm.cpp mplex/padstrm.cpp
+--- mplex.old/padstrm.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/padstrm.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -25,6 +25,7 @@
+ #endif
+
+ #include "padstrm.hpp"
++#include <cstring>
+
+
+
+diff -aur mplex.old/zalphastrm_in.cpp mplex/zalphastrm_in.cpp
+--- mplex.old/zalphastrm_in.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/zalphastrm_in.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -23,6 +23,7 @@
+ #include "config.h"
+ #include <math.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ #include "zalphastrm.hpp"
+ #include "interact.hpp"
diff --git a/media-video/streamdvd/streamdvd-0.4-r1.ebuild b/media-video/streamdvd/streamdvd-0.4-r1.ebuild
index ea9348aad6d6..ea98a2436378 100644
--- a/media-video/streamdvd/streamdvd-0.4-r1.ebuild
+++ b/media-video/streamdvd/streamdvd-0.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/streamdvd/streamdvd-0.4-r1.ebuild,v 1.14 2007/11/27 12:10:09 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/streamdvd/streamdvd-0.4-r1.ebuild,v 1.15 2008/07/09 09:24:15 loki_val Exp $
inherit eutils toolchain-funcs
@@ -32,6 +32,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-makefile.patch"
epatch "${FILESDIR}/${P}-gcc41.patch"
epatch "${FILESDIR}/${P}-libdvdread.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
}
src_compile() {