summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-17 09:42:11 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-17 09:42:11 +0000
commit505dea06f5511e202be9c0668c881c488a7f416a (patch)
treec937e97e4c94f8529b38950286aa9a4327c86553 /media-video
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadgentoo-2-505dea06f5511e202be9c0668c881c488a7f416a.tar.gz
gentoo-2-505dea06f5511e202be9c0668c881c488a7f416a.tar.bz2
gentoo-2-505dea06f5511e202be9c0668c881c488a7f416a.zip
Revision bump - this version of transcode should work flawlessy with mplayer.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/ChangeLog12
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.2.200211141
-rw-r--r--media-video/transcode/transcode-0.6.2.20021114.ebuild110
3 files changed, 121 insertions, 2 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index 6726c9d208cb..2e20276477f7 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,11 +1,19 @@
# ChangeLog for media-video/transcode
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.16 2002/11/15 20:56:13 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.17 2002/11/17 09:42:11 phoenix Exp $
+
+*transcode-0.6.2.20021114 (17 Nov 2002)
+
+ 17 Nov 2002; phoen][x <phoenix@gentoo.org> ChangeLog, transcode-0.6.2.20021114.ebuild,
+ files/digest-transcode-0.6.2.20021114 :
+ Bumped to new version and made it DEPEND on the newest mplayer - this should
+ fix the GET_PP_QUALITY_MAX issue. Thanks to Tony Clark <tclark@telia.com>
+ for the contribution.
*transcode-0.6.1-r1 (29 Oct 2002)
29 Oct 2002; phoen][x <phoenix@gentoo.org> ChangeLog, transcode-0.6.1-r1.ebuild,
- files/digest-transcode-0.6.1-1, transcode-0.6.1-PP_QUALITY_MAX.patch :
+ files/digest-transcode-0.6.1-r1, transcode-0.6.1-PP_QUALITY_MAX.patch :
Added a workaround for the GET_PP_QUALITY_MAX compile problem. This fixes bugs
#9351, #10788 and #10790. Thanks for your help, guys.
diff --git a/media-video/transcode/files/digest-transcode-0.6.2.20021114 b/media-video/transcode/files/digest-transcode-0.6.2.20021114
new file mode 100644
index 000000000000..8345788e2c6a
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.2.20021114
@@ -0,0 +1 @@
+MD5 d1602005a058cbcca131cf7b52dd93a1 transcode-0.6.2.20021114.tar.gz 2386103
diff --git a/media-video/transcode/transcode-0.6.2.20021114.ebuild b/media-video/transcode/transcode-0.6.2.20021114.ebuild
new file mode 100644
index 000000000000..7866697aba21
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.2.20021114.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.2.20021114.ebuild,v 1.1 2002/11/17 09:38:03 phoenix Exp $
+
+IUSE="sdl mmx mpeg sse dvd encode X quicktime avi"
+
+inherit libtool
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/${MY_P}.tar.gz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/a52dec-0.7.3
+ >=media-libs/libdv-0.9.5
+ x86? ( dev-lang/nasm )
+ X? ( virtual/x11 )
+ avi? ( >=media-video/avifile-0.7.4 )
+ dvd? ( media-libs/libdvdread )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ sdl? ( media-libs/libsdl )
+ quicktime? ( media-libs/quicktime4linux )
+ >=media-video/avifile-0.7.4
+ media-libs/libdvdread
+ >=media-video/mplayer-0.90_pre10"
+
+# >=media-video/mplayer-0.90_pre10
+# Most people will want to view their video so
+# I have made mplayer the default as that is what
+# many will use anyway. Due to API changes transcode will
+# now fail to build if an earlier version of mplayer is
+# installed.
+
+# Dont want to build without these currently
+# avi? ( >=media-video/avifile-0.7.4 )
+# dvd? ( media-libs/libdvdread )"
+
+src_compile() {
+
+ # fix invalid paths in .la files of plugins
+ elibtoolize
+
+ local myconf=""
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+# use avi \
+# && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
+# || myconf="${myconf} --without-avifile-mods --disable-avifile6"
+#
+# use dvd \
+# && myconf="${myconf} --with-dvdread" \
+# || myconf="${myconf} --without-dvdread"
+#
+# Dont currently want to build without these
+ myconf="${myconf} --with-dvdread --with-avifile-mods --enable-avifile6"
+
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ # Use the MPlayer libpostproc if present
+ [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/include/postprocess.h ] && \
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+
+ econf ${myconf} || die
+
+ # Do not use emake !!
+ make all || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+}
+