summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-11-18 01:38:48 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-11-18 01:38:48 +0000
commit51fe5a9423de43fcecdf6ed0dbcb3568b4187885 (patch)
tree7fbb4ac2f36caea8a463c5bbe283239567d2257f /media-video
parentversion bump from upstream (diff)
downloadgentoo-2-51fe5a9423de43fcecdf6ed0dbcb3568b4187885.tar.gz
gentoo-2-51fe5a9423de43fcecdf6ed0dbcb3568b4187885.tar.bz2
gentoo-2-51fe5a9423de43fcecdf6ed0dbcb3568b4187885.zip
version bump, solving bug #195267.
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/qdvdauthor/ChangeLog8
-rw-r--r--media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc23
-rw-r--r--media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild87
3 files changed, 97 insertions, 1 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
index 97baec1056e8..915755b69220 100644
--- a/media-video/qdvdauthor/ChangeLog
+++ b/media-video/qdvdauthor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/qdvdauthor
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.16 2007/05/16 06:15:15 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.17 2007/11/18 01:38:47 sbriesen Exp $
+
+*qdvdauthor-1.0.0_rc2 (18 Nov 2007)
+
+ 18 Nov 2007; Stefan Briesenick <sbriesen@gentoo.org>
+ +qdvdauthor-1.0.0_rc2.ebuild:
+ version bump, solving bug #195267.
16 May 2007; Stefan Briesenick <sbriesen@gentoo.org>
-qdvdauthor-0.1.2-r1.ebuild, -qdvdauthor-0.1.4.ebuild:
diff --git a/media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc2 b/media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc2
new file mode 100644
index 000000000000..f8099fb3a800
--- /dev/null
+++ b/media-video/qdvdauthor/files/digest-qdvdauthor-1.0.0_rc2
@@ -0,0 +1,3 @@
+MD5 b2c03dd42408e1cfc1d72f195e6bcb01 qdvdauthor-1.0.0-2.tar.gz 4078842
+RMD160 243f94e8a72e38b69f2625ff99c39d768434f5d9 qdvdauthor-1.0.0-2.tar.gz 4078842
+SHA256 572b6cd4a02457c927b6637a6b3b2ceff5c347d12dd42820fad2877fe6c3af0a qdvdauthor-1.0.0-2.tar.gz 4078842
diff --git a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild b/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild
new file mode 100644
index 000000000000..0833441fae68
--- /dev/null
+++ b/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild,v 1.1 2007/11/18 01:38:47 sbriesen Exp $
+
+inherit eutils flag-o-matic qt3
+
+DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
+HOMEPAGE="http://qdvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qdvdauthor/${P/_rc/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="xine mplayer"
+
+DEPEND=">=media-video/dvdauthor-0.6.11
+ >=media-gfx/imagemagick-6.1.8.8
+ >=media-video/mjpegtools-1.6.2
+ >=media-video/dvd-slideshow-0.7.2
+ xine? ( >=media-libs/xine-lib-1.1.0 )
+ mplayer? ( media-video/mplayer )
+ !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
+ $(qt_min_version 3.2)"
+
+RDEPEND="${DEPEND}
+ media-libs/netpbm
+ media-video/videotrans
+ media-sound/toolame
+ media-sound/lame
+ media-sound/sox"
+
+S="${WORKDIR}/${P/_rc*/}"
+
+# TODO:
+# media-video/dvd-slideshow -> optional
+# installing further tools -> needs evaluation
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # do not over-optimize (see bug #147250)
+ replace-flags -O? -O2
+ filter-flags -finline-functions
+
+ # set our C(XX)FLAGS
+ for PRO in */*.pro */*/*.pro; do
+ echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> "${PRO}"
+ echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> "${PRO}"
+ done
+
+ # full-qualify qmake in configure and append -nocache (see bug #118697)
+ sed -i -e "s:make;\?[[:space:]]*\$:make ${MAKEOPTS};:g" \
+ -e "s:\(/qmake\):\1 -nocache QMAKE=\$QTDIR/bin/qmake:g" configure
+
+ # fixing defaults from /usr/local/bin to gentoo default /usr/bin
+ sed -i -e "s:/usr/local/bin:/usr/bin:g" doc/sound.txt \
+ qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp
+}
+
+src_compile() {
+ local myconf="--prefix=/usr --build-qplayer --build-qslideshow"
+
+ # select backend (VLC is currently broken)
+ #use vlc && myconf="${myconf} --with-vlc-support"
+ use xine && myconf="${myconf} --with-xine-support"
+ use mplayer && myconf="${myconf} --with-mplayer-support"
+
+ # if no backend selected, use XINE as default
+ if ! use xine && ! use mplayer; then
+ myconf="${myconf} --with-xine-support"
+ fi
+
+ ./configure --qt-dir="${QTDIR}" ${myconf} || die "configure failed"
+}
+
+src_install() {
+ make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
+ make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
+ make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
+
+ dobin bin/{qdvdauthor,qslideshow,qplayer}
+ dodoc CHANGELOG README TODO doc/{ISO*,look*,sound*,todo*,render*}.txt
+
+ domenu qdvdauthor.desktop
+ doicon qdvdauthor.png
+}