summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-25 18:30:50 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-25 18:30:50 +0000
commit799a0559b647b8e3cff730c283d1ab0ecee72a25 (patch)
treef2d7d72ce20ffe8b5e6fe283319f49b5f1cc5343 /media-video
parentdont build tests if they will not be ran (diff)
downloadgentoo-2-799a0559b647b8e3cff730c283d1ab0ecee72a25.tar.gz
gentoo-2-799a0559b647b8e3cff730c283d1ab0ecee72a25.tar.bz2
gentoo-2-799a0559b647b8e3cff730c283d1ab0ecee72a25.zip
Revision bump adds patch by SN (Enlik) <slawomir.nizio@sabayon.org> which fixes build with gold linker and use xine wrt bug #418037.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitlecomposer/ChangeLog10
-rw-r--r--media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gold-xine.patch10
-rw-r--r--media-video/subtitlecomposer/subtitlecomposer-0.5.3-r2.ebuild56
3 files changed, 75 insertions, 1 deletions
diff --git a/media-video/subtitlecomposer/ChangeLog b/media-video/subtitlecomposer/ChangeLog
index 6b27d7b62c0a..63f38183427c 100644
--- a/media-video/subtitlecomposer/ChangeLog
+++ b/media-video/subtitlecomposer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/subtitlecomposer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/ChangeLog,v 1.15 2013/04/06 06:23:34 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/ChangeLog,v 1.16 2013/06/25 18:30:50 johu Exp $
+
+*subtitlecomposer-0.5.3-r2 (25 Jun 2013)
+
+ 25 Jun 2013; Johannes Huber <johu@gentoo.org>
+ +files/subtitlecomposer-0.5.3-gold-xine.patch,
+ +subtitlecomposer-0.5.3-r2.ebuild:
+ Revision bump adds patch by SN (Enlik) <slawomir.nizio@sabayon.org> which
+ fixes build with gold linker and use xine wrt bug #418037.
06 Apr 2013; Michael Palimaka <kensington@gentoo.org>
-subtitlecomposer-0.5.3.ebuild:
diff --git a/media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gold-xine.patch b/media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gold-xine.patch
new file mode 100644
index 000000000000..1ec73e7ce54e
--- /dev/null
+++ b/media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gold-xine.patch
@@ -0,0 +1,10 @@
+--- src/player/xine/CMakeLists.txt
++++ src/player/xine/CMakeLists.txt
+@@ -10,6 +10,7 @@
+
+ SET( players_xine_LIBS
+ ${XINE_LIBRARY}
++ -lX11
+ CACHE INTERNAL EXPORTEDVARIABLE
+ )
+
diff --git a/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r2.ebuild b/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r2.ebuild
new file mode 100644
index 000000000000..e624a761fb00
--- /dev/null
+++ b/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r2.ebuild,v 1.1 2013/06/25 18:30:50 johu Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bg cs de el es fr pl pt_BR sr"
+inherit kde4-base
+
+DESCRIPTION="Text-based subtitles editor"
+HOMEPAGE="http://www.sourceforge.net/projects/subcomposer/"
+SRC_URI="mirror://sourceforge/subcomposer/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug gstreamer xine"
+
+RDEPEND="
+ gstreamer? ( media-libs/gstreamer:0.10 )
+ xine? ( media-libs/xine-lib )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-linkage-patch.patch"
+ "${FILESDIR}/${P}-gcc45.patch"
+ "${FILESDIR}/${P}-gold-xine.patch"
+)
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -e '/ADD_SUBDIRECTORY( api )/s/^/# DISABLED/' \
+ -i src/main/scripting/examples/CMakeLists.txt \
+ || die "failed to disable installation of scripting API"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gstreamer GStreamer)
+ $(cmake-utils_use_with xine)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ echo
+ elog "Some example scripts provided by ${PV} require dev-lang/ruby"
+ elog "or dev-lang/python to be installed."
+ echo
+}