summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-09-16 12:42:29 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-09-16 12:42:29 +0000
commit862613aa738306f7afa8edde1bf2f5dcd704b92c (patch)
tree8227d254ad5d504bba46b902cbdbc46955aea41e /media-video
parentadd USE flag for indexing_suite_v2. (diff)
downloadgentoo-2-862613aa738306f7afa8edde1bf2f5dcd704b92c.tar.gz
gentoo-2-862613aa738306f7afa8edde1bf2f5dcd704b92c.tar.bz2
gentoo-2-862613aa738306f7afa8edde1bf2f5dcd704b92c.zip
Added gmodule to linker command line, fixes bug #482674 reported by Neil. Repaired handbrake-9999-remove-faac-dependency.patch, fixes bug #484234 reported by Piotr Mitas. The live version still fails due to missing ff_cpu_cpuid, likely needs newer (masked) ffmpeg to proceed.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/handbrake/ChangeLog11
-rw-r--r--media-video/handbrake/files/handbrake-0.9.9-add-gmodule-to-gtk-configure.patch11
-rw-r--r--media-video/handbrake/files/handbrake-9999-remove-faac-dependency.patch4
-rw-r--r--media-video/handbrake/handbrake-0.9.9.ebuild15
-rw-r--r--media-video/handbrake/handbrake-9999.ebuild20
5 files changed, 43 insertions, 18 deletions
diff --git a/media-video/handbrake/ChangeLog b/media-video/handbrake/ChangeLog
index 53ef3efe1a78..d2b835b15a17 100644
--- a/media-video/handbrake/ChangeLog
+++ b/media-video/handbrake/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/handbrake
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/ChangeLog,v 1.15 2013/09/05 18:58:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/ChangeLog,v 1.16 2013/09/16 12:42:28 tomwij Exp $
+
+ 16 Sep 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/handbrake-0.9.9-add-gmodule-to-gtk-configure.patch,
+ files/handbrake-9999-remove-faac-dependency.patch, handbrake-0.9.9.ebuild,
+ handbrake-9999.ebuild:
+ Added gmodule to linker command line, fixes bug #482674 reported by Neil.
+ Repaired handbrake-9999-remove-faac-dependency.patch, fixes bug #484234
+ reported by Piotr Mitas. The live version still fails due to missing
+ ff_cpu_cpuid, likely needs newer (masked) ffmpeg to proceed.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> handbrake-0.9.9.ebuild,
handbrake-9999.ebuild:
diff --git a/media-video/handbrake/files/handbrake-0.9.9-add-gmodule-to-gtk-configure.patch b/media-video/handbrake/files/handbrake-0.9.9-add-gmodule-to-gtk-configure.patch
new file mode 100644
index 000000000000..e6f7c44e8517
--- /dev/null
+++ b/media-video/handbrake/files/handbrake-0.9.9-add-gmodule-to-gtk-configure.patch
@@ -0,0 +1,11 @@
+--- HandBrake-0.9.9.orig/gtk/configure.ac 2013-09-01 12:13:06.684612296 +0300
++++ HandBrake-0.9.9/gtk/configure.ac 2013-09-01 20:09:35.446706059 +0300
+@@ -96,7 +96,7 @@ case $host in
+ pkg_gudev="gudev-1.0"
+ ;;
+ esac
+- GHB_PACKAGES="gthread-2.0 gio-2.0 libnotify dbus-glib-1 $pkg_gudev"
++ GHB_PACKAGES="gthread-2.0 gmodule-2.0 gio-2.0 libnotify dbus-glib-1 $pkg_gudev"
+ mingw_flag=no
+ ;;
+ esac
diff --git a/media-video/handbrake/files/handbrake-9999-remove-faac-dependency.patch b/media-video/handbrake/files/handbrake-9999-remove-faac-dependency.patch
index cf3fe45dc077..20a43c5035ce 100644
--- a/media-video/handbrake/files/handbrake-9999-remove-faac-dependency.patch
+++ b/media-video/handbrake/files/handbrake-9999-remove-faac-dependency.patch
@@ -147,8 +147,8 @@
-LIBHB.dll.libs += $(CONTRIB.build/)lib/libfaac.a
-endif
-
- ifeq (1,$(FEATURE.mp4v2))
- LIBHB.dll.libs += $(CONTRIB.build/)lib/libmp4v2.a
+ ifeq (1,$(FEATURE.qsv))
+ LIBHB.dll.libs += $(CONTRIB.build/)lib/libmfx.a
endif
--- a/libhb/muxmkv.c
+++ b/libhb/muxmkv.c
diff --git a/media-video/handbrake/handbrake-0.9.9.ebuild b/media-video/handbrake/handbrake-0.9.9.ebuild
index bfa41ed18bf4..6957c3b963b0 100644
--- a/media-video/handbrake/handbrake-0.9.9.ebuild
+++ b/media-video/handbrake/handbrake-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-0.9.9.ebuild,v 1.10 2013/09/05 18:58:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-0.9.9.ebuild,v 1.11 2013/09/16 12:42:28 tomwij Exp $
EAPI="5"
@@ -80,24 +80,27 @@ src_prepare() {
|| die "Contrib removal failed."
# Instead of adding a #define to libmkv, we expand it in place.
- epatch "${FILESDIR}"/handbrake-9999-expand-MK_SUBTITLE_PGS.patch
+ epatch "${FILESDIR}"/${PN}-9999-expand-MK_SUBTITLE_PGS.patch
# Fix compilation against the released 1.9.1 version of mp4v2.
- epatch "${FILESDIR}"/handbrake-9999-fix-compilation-with-mp4v2-v1.9.1.patch
+ epatch "${FILESDIR}"/${PN}-9999-fix-compilation-with-mp4v2-v1.9.1.patch
# Remove libdvdnav duplication and call it on the original instead.
# It may work this way; if not, we should try to mimic the duplication.
- epatch "${FILESDIR}"/handbrake-9999-remove-dvdnav-dup.patch
+ epatch "${FILESDIR}"/${PN}-9999-remove-dvdnav-dup.patch
# Remove faac dependency until its compilation errors can be resolved.
epatch "${FILESDIR}"/${P}-remove-faac-dependency.patch
sed -i 's/-lfaac//' gtk/configure.ac || die
# Make use of an older version of libmkv.
- epatch "${FILESDIR}"/handbrake-9999-use-older-libmkv.patch
+ epatch "${FILESDIR}"/${PN}-9999-use-older-libmkv.patch
# Make use of an unpatched version of a52 that does not make a private field public.
- epatch "${FILESDIR}"/handbrake-9999-use-unpatched-a52.patch
+ epatch "${FILESDIR}"/${PN}-9999-use-unpatched-a52.patch
+
+ # Add gmodule to the linker command line for bug #482674.
+ epatch "${FILESDIR}"/${P}-add-gmodule-to-gtk-configure.patch
# Fixup configure.ac with newer automake
cd "${S}/gtk"
diff --git a/media-video/handbrake/handbrake-9999.ebuild b/media-video/handbrake/handbrake-9999.ebuild
index 7f5f341d7637..f156fe186912 100644
--- a/media-video/handbrake/handbrake-9999.ebuild
+++ b/media-video/handbrake/handbrake-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-9999.ebuild,v 1.12 2013/09/05 18:58:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/handbrake/handbrake-9999.ebuild,v 1.13 2013/09/16 12:42:28 tomwij Exp $
EAPI="5"
@@ -90,25 +90,28 @@ src_prepare() {
|| die "Contrib removal failed."
# Instead of adding a #define to libmkv, we expand it in place.
- epatch "${FILESDIR}"/handbrake-9999-expand-MK_SUBTITLE_PGS.patch
+ epatch "${FILESDIR}"/${PN}-9999-expand-MK_SUBTITLE_PGS.patch
# Fix compilation against the released 1.9.1 version of mp4v2.
- epatch "${FILESDIR}"/handbrake-9999-fix-compilation-with-mp4v2-v1.9.1.patch
+ epatch "${FILESDIR}"/${PN}-9999-fix-compilation-with-mp4v2-v1.9.1.patch
# Remove libdvdnav duplication and call it on the original instead.
# It may work this way; if not, we should try to mimic the duplication.
- epatch "${FILESDIR}"/handbrake-9999-remove-dvdnav-dup.patch
+ epatch "${FILESDIR}"/${PN}-9999-remove-dvdnav-dup.patch
# Remove faac dependency until its compilation errors can be resolved.
# TODO: If --disable-faac works then this patch can be removed;
# we also need to figure out if this is still needed, maybe things are patched.
- epatch "${FILESDIR}"/handbrake-9999-remove-faac-dependency.patch
+ epatch "${FILESDIR}"/${PN}-9999-remove-faac-dependency.patch
# Make use of an older version of libmkv.
- epatch "${FILESDIR}"/handbrake-9999-use-older-libmkv.patch
+ epatch "${FILESDIR}"/${PN}-9999-use-older-libmkv.patch
# Make use of an unpatched version of a52 that does not make a private field public.
- epatch "${FILESDIR}"/handbrake-9999-use-unpatched-a52.patch
+ epatch "${FILESDIR}"/${PN}-9999-use-unpatched-a52.patch
+
+ # Add gmodule to the linker command line for bug #482674.
+ epatch "${FILESDIR}"/${PN}-0.9.9-add-gmodule-to-gtk-configure.patch
# Fixup configure.ac with newer automake.
# TODO: Would like to see this shorten towards the future;
@@ -147,8 +150,7 @@ src_configure() {
$(use_enable fdk fdk-aac) \
$(use_enable ffmpeg ff-mpeg2) \
$(use_enable gtk) \
- $(use_enable gstreamer gst) \
- ${myconf} || die "Configure failed."
+ $(usex !gstreamer --disable-gst) || die "Configure failed."
}
src_compile() {