summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-03-30 17:00:37 +0000
committerAron Griffis <agriffis@gentoo.org>2002-03-30 17:00:37 +0000
commit8dcd4ed70defd557b7a64567d8872d0ecfaff9ad (patch)
tree3166a5f88fcd120afb1017b19438808588c5da37 /media-video
parentVersion bump. (diff)
downloadgentoo-2-8dcd4ed70defd557b7a64567d8872d0ecfaff9ad.tar.gz
gentoo-2-8dcd4ed70defd557b7a64567d8872d0ecfaff9ad.tar.bz2
gentoo-2-8dcd4ed70defd557b7a64567d8872d0ecfaff9ad.zip
Fixed a couple bugs; now works with sandbox and "use alsa".
Diffstat (limited to 'media-video')
-rw-r--r--media-video/xawtv/ChangeLog25
-rw-r--r--media-video/xawtv/files/digest-xawtv-3.65-r11
-rw-r--r--media-video/xawtv/xawtv-3.65-r1.ebuild71
3 files changed, 89 insertions, 8 deletions
diff --git a/media-video/xawtv/ChangeLog b/media-video/xawtv/ChangeLog
index 9f6adf68f07d..065b7900b203 100644
--- a/media-video/xawtv/ChangeLog
+++ b/media-video/xawtv/ChangeLog
@@ -1,13 +1,22 @@
# ChangeLog for media-video/xawtv
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xawtv/ChangeLog,v 1.1 2002/02/01 21:53:31 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xawtv/ChangeLog,v 1.2 2002/03/30 17:00:37 agriffis Exp $
+
+*xawtv-3.65-r1 (30 Mar 2002)
+
+ 30 Mar 2002; Aron Griffis <agriffis@gentoo.org> xawtv-3.65-r1.ebuild :
+
+ Added "use alsa" and corrected installation of fonts. Now the font
+ installation doesn't violate the sandbox, and mkfontdir is properly run
+ after merge/unmerge.
*xawtv-3.65 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/media-video/xawtv/files/digest-xawtv-3.65-r1 b/media-video/xawtv/files/digest-xawtv-3.65-r1
new file mode 100644
index 000000000000..6899eb5a1e5e
--- /dev/null
+++ b/media-video/xawtv/files/digest-xawtv-3.65-r1
@@ -0,0 +1 @@
+MD5 6695dc3ef1c6ad4caa4b22b5cc0930ca xawtv_3.65.tar.gz 455098
diff --git a/media-video/xawtv/xawtv-3.65-r1.ebuild b/media-video/xawtv/xawtv-3.65-r1.ebuild
new file mode 100644
index 000000000000..3107b5abbd9d
--- /dev/null
+++ b/media-video/xawtv/xawtv-3.65-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/xawtv/xawtv-3.65-r1.ebuild,v 1.1 2002/03/30 17:00:37 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TV application for the bttv driver"
+SRC_URI="http://bytesex.org/xawtv/xawtv_3.65.tar.gz"
+HOMEPAGE="http://bytesex.org/xawtv/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.8
+ >=x11-base/xfree-4.0.1
+ motif? ( x11-libs/openmotif )
+ aalib? ( media-libs/aalib )
+ quicktime? ( media-libs/quicktime4linux )
+ alsa? ( media-libs/alsa-lib )"
+
+
+src_compile() {
+ local myconf
+ use motif && myconf="--enable-motif" \
+ || myconf="--disable-motif"
+ use aalib && myconf="$myconf --enable-aa" \
+ || myconf="$myconf --disable-aa"
+ use quicktime && myconf="$myconf --enable-quicktime" \
+ || myconf="$myconf --disable-quicktime"
+ use alsa && myconf="$myconf --enable-alsa" \
+ || myconf="$myconf --disable-alsa"
+
+ touch src/Xawtv.h src/MoTV.h
+
+ ./configure --prefix=/usr --host=${CHOST} \
+ --disable-lirc \
+ --enable-jpeg \
+ --enable-xfree-ext \
+ --enable-xvideo \
+ --with-x \
+ $myconf
+
+ emake || die
+}
+
+src_install() {
+ fontdir=${D}/usr/X11R6/lib/X11/fonts/misc
+ make install \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ resdir=${D}/etc/X11 \
+ fontdir=$fontdir
+ # remove the bogus fonts.dir so it isn't "owned" by this ebuild
+ rm -f $fontdir/fonts.dir
+
+ dodoc COPYING Changes KNOWN_PROBLEMS Miro_gpio.txt
+ dodoc Programming-FAQ README* Sound-FAQ TODO
+ dodoc Trouble-Shooting UPDATE_TO_v3.0
+
+ insinto /usr/local/httpd/cgi-bin
+ insopts -m 755
+ doins webcam/webcam.cgi
+}
+
+src_postinst() {
+ mkfontdir /usr/X11R6/lib/X11/fonts/misc
+}
+
+src_postrm() {
+ mkfontdir /usr/X11R6/lib/X11/fonts/misc
+}