summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-09-07 15:45:51 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-09-07 15:45:51 +0000
commit9621f43ce9c8a812e56c28c55c6634bd6cada44a (patch)
tree9555ef0bee1b524fa57f8c3223fcfb09f206fdb6 /media-video
parentStable for amd64, wrt bug #434164 (diff)
downloadgentoo-2-9621f43ce9c8a812e56c28c55c6634bd6cada44a.tar.gz
gentoo-2-9621f43ce9c8a812e56c28c55c6634bd6cada44a.tar.bz2
gentoo-2-9621f43ce9c8a812e56c28c55c6634bd6cada44a.zip
Add new snapshot, fix bugs 429538 and 433677
(Portage version: 2.1.11.13/cvs/Linux i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/smplayer2/ChangeLog9
-rw-r--r--media-video/smplayer2/smplayer2-0.7.3_p20120524.ebuild51
-rw-r--r--media-video/smplayer2/smplayer2-9999.ebuild7
3 files changed, 62 insertions, 5 deletions
diff --git a/media-video/smplayer2/ChangeLog b/media-video/smplayer2/ChangeLog
index f7b64c344ddc..cebc8273174e 100644
--- a/media-video/smplayer2/ChangeLog
+++ b/media-video/smplayer2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/smplayer2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer2/ChangeLog,v 1.3 2012/06/17 05:48:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer2/ChangeLog,v 1.4 2012/09/07 15:45:51 maksbotan Exp $
+
+*smplayer2-0.7.3_p20120524 (07 Sep 2012)
+
+ 07 Sep 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +smplayer2-0.7.3_p20120524.ebuild, smplayer2-9999.ebuild:
+ Add new snapshot, fix bugs 429538 and 433677
17 Jun 2012; Ben de Groot <yngwin@gentoo.org>
smplayer2-0.7.0_pre20111120.ebuild, smplayer2-0.7.1_p20120301.ebuild,
@@ -19,4 +25,3 @@
01 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org>
+smplayer2-0.7.0_pre20111120.ebuild, +smplayer2-9999.ebuild, +metadata.xml:
Added smplayer2, bug 391191. Thanks to Nikoli
-
diff --git a/media-video/smplayer2/smplayer2-0.7.3_p20120524.ebuild b/media-video/smplayer2/smplayer2-0.7.3_p20120524.ebuild
new file mode 100644
index 000000000000..64f415aa17b5
--- /dev/null
+++ b/media-video/smplayer2/smplayer2-0.7.3_p20120524.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer2/smplayer2-0.7.3_p20120524.ebuild,v 1.1 2012/09/07 15:45:51 maksbotan Exp $
+
+EAPI="4"
+LANGS="bg ca cs da de en_US es et eu fi fr gl hu it ja ka ko ku lt mk nl pl pt pt_BR sk sr sv tr zh_CN zh_TW"
+LANGSLONG="ar_SY el_GR ro_RO ru_RU sl_SI uk_UA vi_VN"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4 GUI front-end for mplayer2"
+HOMEPAGE="https://github.com/lachs0r/SMPlayer2"
+SRC_URI="http://rion-overlay.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="dbus debug +download-subs"
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+for x in ${LANGSLONG}; do
+ IUSE="${IUSE} linguas_${x%_*}"
+done
+
+DEPEND="
+ x11-libs/qt-gui:4[dbus?]
+ download-subs? ( dev-libs/quazip )
+"
+RDEPEND="${DEPEND}
+ media-video/mplayer2[libass,png]
+"
+
+src_configure() {
+ # linguas
+ local langs x
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+=" ${x}"
+ done
+ for x in ${LANGSLONG}; do
+ use linguas_${x%_*} && langs+=" ${x}"
+ done
+
+ local mycmakeargs=(
+ -DLINGUAS="${langs}"
+ "$(cmake-utils_use dbus ENABLE_DBUS)"
+ "$(cmake-utils_use debug DEBUG_OUTPUT)"
+ "$(cmake-utils_use download-subs ENABLE_DOWNLOAD_SUBS)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-video/smplayer2/smplayer2-9999.ebuild b/media-video/smplayer2/smplayer2-9999.ebuild
index fcbd4c189d55..6ab4ce338b9c 100644
--- a/media-video/smplayer2/smplayer2-9999.ebuild
+++ b/media-video/smplayer2/smplayer2-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer2/smplayer2-9999.ebuild,v 1.2 2012/06/17 05:48:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer2/smplayer2-9999.ebuild,v 1.3 2012/09/07 15:45:51 maksbotan Exp $
EAPI="4"
LANGS="bg ca cs da de en_US es et eu fi fr gl hu it ja ka ko ku lt mk nl pl pt pt_BR sk sr sv tr zh_CN zh_TW"
@@ -15,7 +15,7 @@ EGIT_REPO_URI="git://github.com/lachs0r/SMPlayer2.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug +download-subs"
+IUSE="dbus debug +download-subs"
for x in ${LANGS}; do
IUSE="${IUSE} linguas_${x}"
done
@@ -24,7 +24,7 @@ for x in ${LANGSLONG}; do
done
DEPEND="
- x11-libs/qt-gui:4
+ x11-libs/qt-gui:4[dbus?]
download-subs? ( dev-libs/quazip )
"
RDEPEND="${DEPEND}
@@ -43,6 +43,7 @@ src_configure() {
local mycmakeargs=(
-DLINGUAS="${langs}"
+ "$(cmake-utils_use dbus ENABLE_DBUS)"
"$(cmake-utils_use debug DEBUG_OUTPUT)"
"$(cmake-utils_use download-subs ENABLE_DOWNLOAD_SUBS)"
)