summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-23 12:42:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-23 12:42:07 +0000
commita2019abfcd319f9ea798399127d6d13723c14a43 (patch)
tree0dd92f9c21172c41609cfa76175ec4e8da857c79 /media-video
parentversion bump for the 0.10 branch (diff)
downloadgentoo-2-a2019abfcd319f9ea798399127d6d13723c14a43.tar.gz
gentoo-2-a2019abfcd319f9ea798399127d6d13723c14a43.tar.bz2
gentoo-2-a2019abfcd319f9ea798399127d6d13723c14a43.zip
add opus useflag/support
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 10 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 2f9a08bbb499..d91ad763e0eb 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.569 2012/07/23 12:33:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.570 2012/07/23 12:42:07 aballier Exp $
+
+ 23 Jul 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add opus useflag/support
*ffmpeg-0.10.4 (23 Jul 2012)
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index f522c1a228ba..4460ce6bd41d 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.97 2012/07/06 14:04:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.98 2012/07/23 12:42:07 aballier Exp $
EAPI="4"
@@ -32,7 +32,7 @@ IUSE="
aac aacplus alsa amr avresample bindist bluray +bzip2 cdio celt
cpudetection debug doc +encode faac fontconfig frei0r gnutls gsm
+hardcoded-tables iec61883 ieee1394 jack jpeg2k libass libv4l modplug mp3
- network openal openssl oss pic pulseaudio rtmp schroedinger sdl speex
+ network openal openssl opus oss pic pulseaudio rtmp schroedinger sdl speex
static-libs test theora threads truetype v4l vaapi vdpau vorbis vpx X x264
xvid +zlib
"
@@ -80,6 +80,7 @@ RDEPEND="
libv4l? ( media-libs/libv4l )
modplug? ( media-libs/libmodplug )
openal? ( >=media-libs/openal-1.1 )
+ opus? ( media-libs/opus )
pulseaudio? ( media-sound/pulseaudio )
rtmp? ( >=media-video/rtmpdump-2.2f )
sdl? ( >=media-libs/libsdl-1.2.13-r1[audio,video] )
@@ -188,7 +189,7 @@ src_configure() {
# Decoders
use amr && { myconf="${myconf} --enable-libopencore-amrwb --enable-libopencore-amrnb" ; version3=" --enable-version3" ; }
- for i in bluray celt gsm modplug rtmp schroedinger speex vorbis vpx; do
+ for i in bluray celt gsm modplug opus rtmp schroedinger speex vorbis vpx; do
use ${i} && myconf="${myconf} --enable-lib${i}"
done
use jpeg2k && myconf="${myconf} --enable-libopenjpeg"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 51e8381d02a8..93210884fe9e 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -28,6 +28,7 @@
<flag name="mmxext">Enables mmx2 support</flag>
<flag name="network">Enables network streaming support</flag>
<flag name="openssl">Enables <pkg>dev-libs/openssl</pkg> support. Adds support for encrypted network protocols (TLS/HTTPS).</flag>
+ <flag name="opus">Adds (decoding) support for the Opus codec via <pkg>media-libs/opus</pkg>.</flag>
<flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>
<flag name="rtmp">Enable Real Time Messaging Protocol using librtmp</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>