summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-08 13:46:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-08 13:46:02 +0000
commita7682858389e4dfbca15a92f20a02c12b4709f7c (patch)
treeeaeb3759bdac6b833d4521b22833f8dced315940 /media-video
parentwith-x instead of with-x11. (diff)
downloadgentoo-2-a7682858389e4dfbca15a92f20a02c12b4709f7c.tar.gz
gentoo-2-a7682858389e4dfbca15a92f20a02c12b4709f7c.tar.bz2
gentoo-2-a7682858389e4dfbca15a92f20a02c12b4709f7c.zip
Version bump, ebuild clean up
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/griffith/ChangeLog8
-rw-r--r--media-video/griffith/griffith-0.9.10.ebuild68
-rw-r--r--media-video/griffith/griffith-0.9.9.ebuild6
3 files changed, 77 insertions, 5 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 4e53e43257cc..a18dace9945a 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.29 2009/02/24 18:13:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.30 2009/06/08 13:46:02 hwoarang Exp $
+
+*griffith-0.9.10 (08 Jun 2009)
+
+ 08 Jun 2009; Markos Chandras <hwoarang@gentoo.org> griffith-0.9.9.ebuild,
+ +griffith-0.9.10.ebuild:
+ Version bump, ebuild clean up
24 Feb 2009; Markos Chandras <hwoarang@gentoo.org> griffith-9999:
Dropping keywords from live ebuild
diff --git a/media-video/griffith/griffith-0.9.10.ebuild b/media-video/griffith/griffith-0.9.10.ebuild
new file mode 100644
index 000000000000..79d2bbd85f69
--- /dev/null
+++ b/media-video/griffith/griffith-0.9.10.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.10.ebuild,v 1.1 2009/06/08 13:46:02 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils python multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="mirror://berlios/griffith/${P/_/-}.tar.gz
+ mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="csv doc spell"
+
+RDEPEND="dev-python/imaging
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ dev-python/pysqlite:2
+ >=dev-python/reportlab-1.19
+ csv? ( dev-python/chardet )
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+src_prepare() {
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ lib/gconsole.py || die "sed failed"
+
+ epatch \
+ "${FILESDIR}/0.9.6-moving_share_dir.patch" \
+ "${FILESDIR}/0.9.7.1-fix_spellcheck.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ python_version
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/griffith/griffith-0.9.9.ebuild b/media-video/griffith/griffith-0.9.9.ebuild
index babe50b7187f..fb47bde72605 100644
--- a/media-video/griffith/griffith-0.9.9.ebuild
+++ b/media-video/griffith/griffith-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.9.ebuild,v 1.1 2009/02/24 15:16:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.9.ebuild,v 1.2 2009/06/08 13:46:02 hwoarang Exp $
EAPI="2"
@@ -27,9 +27,7 @@ RDEPEND="dev-python/imaging
DEPEND="${RDEPEND}
doc? ( app-text/docbook2X )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e 's#/pl/#/pl.UTF-8/#' \
docs/pl/Makefile || die "sed failed"