summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2007-02-16 12:13:28 +0000
committerSimon Stelling <blubb@gentoo.org>2007-02-16 12:13:28 +0000
commitcfdcf7d7c7345ba824bcd59f372258495f62cc26 (patch)
treeff7b406211fba0452f057167b79e06394f0fc766 /media-video
parentStable on ppc64; bug #167034 (diff)
downloadgentoo-2-cfdcf7d7c7345ba824bcd59f372258495f62cc26.tar.gz
gentoo-2-cfdcf7d7c7345ba824bcd59f372258495f62cc26.tar.bz2
gentoo-2-cfdcf7d7c7345ba824bcd59f372258495f62cc26.zip
depend on >=portage-2.1.2 on amd64 to make sure the assembler USE flags are unmasked
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/ChangeLog7
-rw-r--r--media-video/transcode/transcode-1.0.2-r2.ebuild21
-rw-r--r--media-video/transcode/transcode-1.0.2-r4.ebuild18
3 files changed, 22 insertions, 24 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index fe8a925db570..23adc8b489a5 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/transcode
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.162 2007/02/01 03:38:26 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.163 2007/02/16 12:13:28 blubb Exp $
+
+ 16 Feb 2007; Simon Stelling <blubb@gentoo.org> transcode-1.0.2-r2.ebuild,
+ transcode-1.0.2-r4.ebuild:
+ depend on >=portage-2.1.2 on amd64 to make sure the assembler USE flags are
+ unmasked
*transcode-1.0.2-r4 (01 Feb 2007)
diff --git a/media-video/transcode/transcode-1.0.2-r2.ebuild b/media-video/transcode/transcode-1.0.2-r2.ebuild
index 006d93ab08c4..fc9f52fb1572 100644
--- a/media-video/transcode/transcode-1.0.2-r2.ebuild
+++ b/media-video/transcode/transcode-1.0.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-1.0.2-r2.ebuild,v 1.16 2006/10/01 17:53:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-1.0.2-r2.ebuild,v 1.17 2007/02/16 12:13:28 blubb Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -51,6 +51,9 @@ RDEPEND="a52? ( >=media-libs/a52dec-0.7.4 )
DEPEND="${RDEPEND}
v4l2? ( >=sys-kernel/linux-headers-2.6.11 )"
+# Make sure the assembler USE flags are unmasked on amd64
+# Remove this once default-linux/amd64/2006.1 is deprecated
+DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
pkg_setup() {
if use X && has_version '<x11-base/xorg-x11-7.0' && ! built_with_use x11-base/xorg-x11 xv; then
@@ -83,16 +86,10 @@ src_compile() {
use xvid \
&& myconf="${myconf} --with-default-xvid=xvid4"
- # Hardenable SIMD extensions on amd64
- if use amd64; then
- myconf="${myconf} --enable-mmx --enable-3dnow \
- --enable-sse --enable-sse2"
- elif use x86; then
- myconf="${myconf} $(use_enable mmx) \
- $(use_enable 3dnow) \
- $(use_enable sse) \
- $(use_enable sse2)"
- fi
+ myconf="${myconf} $(use_enable mmx) \
+ $(use_enable 3dnow) \
+ $(use_enable sse) \
+ $(use_enable sse2)"
append-flags -DDCT_YUV_PRECISION=1
econf \
diff --git a/media-video/transcode/transcode-1.0.2-r4.ebuild b/media-video/transcode/transcode-1.0.2-r4.ebuild
index 4680f7866267..34ef626d7b6a 100644
--- a/media-video/transcode/transcode-1.0.2-r4.ebuild
+++ b/media-video/transcode/transcode-1.0.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-1.0.2-r4.ebuild,v 1.1 2007/02/01 03:38:26 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-1.0.2-r4.ebuild,v 1.2 2007/02/16 12:13:28 blubb Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -50,6 +50,9 @@ RDEPEND="a52? ( >=media-libs/a52dec-0.7.4 )
DEPEND="${RDEPEND}
v4l2? ( >=sys-kernel/linux-headers-2.6.11 )"
+# Make sure the assembler USE flags are unmasked on amd64
+# Remove this once default-linux/amd64/2006.1 is deprecated
+DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
pkg_setup() {
if use X && has_version '<x11-base/xorg-x11-7.0' && ! built_with_use x11-base/xorg-x11 xv; then
@@ -91,16 +94,9 @@ src_compile() {
use xvid \
&& myconf="${myconf} --with-default-xvid=xvid4"
- # Hardenable SIMD extensions on amd64
- if use amd64; then
- myconf="${myconf} --enable-mmx \
- --enable-sse --enable-sse2"
- elif use x86; then
- myconf="${myconf} $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable sse2)"
- fi
- myconf="${myconf} $(use_enable 3dnow)"
+ myconf="${myconf} $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable sse2) $(use_enable 3dnow)"
append-flags -DDCT_YUV_PRECISION=1
econf \