summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-03-26 10:53:02 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-03-26 10:53:02 +0000
commitd38998c8deb00b609244acf376f114b4b17ba5e1 (patch)
treeef622860358cba839fd5ed85274eca5717048c68 /media-video
parentalpha/ia64/sparc stable wrt security #213164 (diff)
downloadgentoo-2-d38998c8deb00b609244acf376f114b4b17ba5e1.tar.gz
gentoo-2-d38998c8deb00b609244acf376f114b4b17ba5e1.tar.bz2
gentoo-2-d38998c8deb00b609244acf376f114b4b17ba5e1.zip
New snapshot, avfilter and new include layout in
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog11
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20050226-r3.ebuild149
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild181
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20070330.ebuild190
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.9_p20080326.ebuild (renamed from media-video/ffmpeg/ffmpeg-0.4.9_p20070525.ebuild)98
-rw-r--r--media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch13
6 files changed, 62 insertions, 580 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 68c9072d51b9..fdc64b18bdb9 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/ffmpeg
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.215 2008/02/28 18:49:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.216 2008/03/26 10:53:01 lu_zero Exp $
+
+*ffmpeg-0.4.9_p20080326 (26 Mar 2008)
+
+ 26 Mar 2008; Luca Barbato <lu_zero@gentoo.org>
+ -files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch,
+ -ffmpeg-0.4.9_p20050226-r3.ebuild, -ffmpeg-0.4.9_p20061016.ebuild,
+ -ffmpeg-0.4.9_p20070330.ebuild, -ffmpeg-0.4.9_p20070525.ebuild,
+ +ffmpeg-0.4.9_p20080326.ebuild:
+ Furter cleanup and new version
28 Feb 2008; Alexis Ballier <aballier@gentoo.org>
ffmpeg-0.4.9_p20080206.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20050226-r3.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20050226-r3.ebuild
deleted file mode 100644
index 53675c56cea2..000000000000
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20050226-r3.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20050226-r3.ebuild,v 1.18 2007/02/12 11:19:58 vapier Exp $
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec."
-HOMEPAGE="http://ffmpeg.org/"
-MY_P=${P/_/-}
-S=${WORKDIR}
-S_BASE=${WORKDIR}/${MY_P}
-S_STATIC=${S_BASE}-static
-S_SHARED=${S_BASE}-shared
-
-SRC_URI="mirror://sourceforge/ffmpeg/${MY_P}.tbz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE="aac altivec debug doc dv dvd encode imlib mmx vorbis oss threads truetype
-v4l xvid sdl"
-
-DEPEND="imlib? ( media-libs/imlib2 )
- truetype? ( >=media-libs/freetype-2 )
- sdl? ( >=media-libs/libsdl-1.2.1 )
- doc? ( app-text/texi2html )
- encode? ( media-sound/lame )
- vorbis? ( media-libs/libvorbis
- media-libs/libogg )
- !alpha? ( aac? ( media-libs/faad2 media-libs/faac ) )
- dvd? ( >=media-libs/a52dec-0.7.4-r4 )
- xvid? ( >=media-libs/xvid-1.0 )
- "
-
-src_unpack() {
- unpack ${A} || die
- cd ${S_BASE}
-
- # for some reason it tries to #include <X11/Xlib.h>, but doesn't use it
- sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
-
- # make a52bin actually compile... adds the needed external lib
- # and makes fprintf -> av_log like it's supposed to be...
- epatch ${FILESDIR}/gentoo-${PN}001.patch
-
- #ffmpeg doesn'g use libtool, so the condition for PIC code
- #is __PIC__, not PIC.
- sed -i -e 's/#if\(\(.*def *\)\|\(.*defined *\)\)PIC/#if\1__PIC__/' \
- libavcodec/i386/dsputil_mmx{.c,_rnd.h} \
- libavcodec/msmpeg4.c \
- || die "sed failed (__PIC__)"
-
- #fixup liba52 to respect the --disable-mmx configure option
- sed -i -e 's/#ifdef ARCH_X86/#ifdef HAVE_MMX/' \
- libavcodec/liba52/resample.c \
- || die "sed failed (HAVE_MMX)"
-
- epatch ${FILESDIR}/${PN}-libdir-pic.patch
-
- sed -i -e "s:\$ldl\ \$extralibs:\$ldl\ -la52\ \$extralibs:" configure || die "Unable to patch in -la52"
-
- cd ${S}
- cp -R ${S_BASE} ${S_STATIC}
- mv ${S_BASE} ${S_SHARED}
-}
-
-src_compile() {
- #Note; library makefiles don't propogate flags from config.mak so
- #use specified CFLAGS are only used in executables
- filter-flags -fforce-addr -momit-leaf-frame-pointer
-
- local myconf=""
-
- #disable mmx accelerated code if not requirested, or if PIC is required
- # as the provided asm decidedly isn't PIC.
- if has_pic || use !mmx; then
- myconf="${myconf} --disable-mmx"
- else
- myconf="${myconf} --enable-mmx"
- fi
-
- use encode && use aac && myconf="${myconf} --enable-faac"
-
- if use vorbis ; then
- myconf="${myconf} --enable-ogg --enable-vorbis"
- else
- myconf="${myconf} --disable-ogg --disable-theora"
- fi
-
- use !alpha && myconf="${myconf} $(use_enable aac faad) $(use_enable aac faac) $(use_enable aac faadbin)"
-
- myconf="${myconf}
- $(use_enable altivec) \
- $(use_enable debug) \
- $(use_enable encode mp3lame) \
- $(use_enable dvd a52) $(use_enable dvd a52bin) \
- $(use_enable oss audio-oss) \
- $(use_enable v4l) \
- $(use_enable dv dv1394) \
- $(use_enable threads pthreads) \
- $(use_enable xvid) \
- --enable-gpl \
- --enable-pp \
- --disable-optimize"
-
- cd ${S_STATIC}
- econf --disable-shared-pp --disable-shared --enable-static ${myconf} || die "Configure failed"
- emake CC="$(tc-getCC)" || die
-
- cd ${S_SHARED}
- econf --enable-shared-pp --enable-shared --disable-static ${myconf} || die "Configure failed"
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- for d in ${S_STATIC} ${S_SHARED}; do
- cd ${d}
-
- use doc && make documentation
- make DESTDIR=${D} \
- prefix=${D}/usr \
- libdir=${D}/usr/$(get_libdir) \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- bindir=${D}/usr/bin \
- install installlib || die "Install Failed"
- done
-
- cd ${S_SHARED}
- dodoc Changelog README INSTALL
- dodoc doc/*
-
- cd ${S_STATIC}/libavcodec/libpostproc
- make prefix=${D}/usr libdir=${D}/usr/$(get_libdir) \
- install || die "Failed to install libpostproc.a!"
-
- cd ${S_SHARED}/libavcodec/libpostproc
- make prefix=${D}/usr libdir=${D}/usr/$(get_libdir) \
- SHARED_PP="yes" \
- install || die "Failed to install libpostproc.so!"
-
- # Some stuff like transcode can use this one.
- dolib ${S_STATIC}/libavcodec/libpostproc/libpostproc.a
-
- preplib /usr
-}
-
-# FEATURES=maketest breakes the compile
-src_test() { :; }
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild
deleted file mode 100644
index f05cda1fa1d4..000000000000
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild,v 1.16 2008/02/14 15:17:09 drac Exp $
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec."
-HOMEPAGE="http://ffmpeg.org/"
-MY_P=${P/_/-}
-S=${WORKDIR}/ffmpeg
-
-SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
- amr? ( http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/26104-510.zip
- http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/26204-510.zip )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="aac altivec amr debug doc ieee1394 a52 encode imlib mmx ogg vorbis oss
- test theora threads truetype v4l x264 xvid network zlib sdl"
-
-RDEPEND="imlib? ( media-libs/imlib2 )
- truetype? ( >=media-libs/freetype-2 )
- sdl? ( >=media-libs/libsdl-1.2.10 )
- encode? ( media-sound/lame )
- ogg? ( media-libs/libogg )
- vorbis? ( media-libs/libvorbis )
- aac? ( media-libs/faad2 media-libs/faac )
- a52? ( >=media-libs/a52dec-0.7.4-r4 )
- xvid? ( >=media-libs/xvid-1.1.0 )
- zlib? ( sys-libs/zlib )
- ieee1394? ( =media-libs/libdc1394-1*
- sys-libs/libraw1394 )
- x264? ( >=media-libs/x264-svn-20061014 )"
-
-DEPEND="${RDEPEND}
- doc? ( app-text/texi2html )
- test? ( net-misc/wget )
- amr? ( app-arch/unzip )"
-# Make sure the mmx USE flag is unmasked
-# Remove this once default-linux/amd64/2006.1 is deprecated
-DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
-
-src_unpack() {
- unpack ${A} || die
- cd ${S}
-
- # amr (float) support
- if use amr; then
- einfo "Including amr wide and narrow band (float) support ... "
-
- # narrow band codec
- mkdir ${S}/libavcodec/amr_float
- cd ${S}/libavcodec/amr_float
- unzip -q ${WORKDIR}/26104-510_ANSI_C_source_code.zip
-
- # wide band codec
- mkdir ${S}/libavcodec/amrwb_float
- cd ${S}/libavcodec/amrwb_float
- unzip -q ${WORKDIR}/26204-510_ANSI-C_source_code.zip
-
- # Patch if we're on 64-bit
- if useq alpha || useq amd64 || useq ia64 || useq ppc64; then
- cd ${S}
- epatch "${FILESDIR}/ffmpeg-0.4.9_p20060302-amr-64bit.patch"
- fi
- fi
-
- cd ${S}
-
- #Append -fomit-frame-pointer to avoid some common issues
- use debug || append-flags "-fomit-frame-pointer"
-
- # for some reason it tries to #include <X11/Xlib.h>, but doesn't use it
- sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
-
- # .pc files contain wrong libdir path
- epatch ${FILESDIR}/${PN}-libdir.patch
- sed -i -e "s:GENTOOLIBDIR:$(get_libdir):" configure
-
- # Make it use pic always since we don't need textrels
- sed -i -e "s:LIBOBJFLAGS=\"\":LIBOBJFLAGS=\'\$\(PIC\)\':" configure
-
- # To make sure the ffserver test will work
- sed -i -e "s:-e debug=off::" tests/server-regression.sh
-
- epatch "${FILESDIR}/${PN}-shared-gcc4.1.patch"
-}
-
-src_compile() {
- replace-flags -O0 -O2
- #x86, what a wonderful arch....
- replace-flags -O1 -O2
- local myconf="${EXTRA_ECONF}"
-
- #disable mmx accelerated code if not requested, or if PIC is required
- # as the provided asm decidedly is not PIC.
- if ( gcc-specs-pie || ! use mmx ) ; then
- myconf="${myconf} --disable-mmx"
- fi
-
- # enabled by default
- use altivec || myconf="${myconf} --disable-altivec"
- use debug || myconf="${myconf} --disable-debug"
- use oss || myconf="${myconf} --disable-audio-oss"
- use v4l || myconf="${myconf} --disable-v4l --disable-v4l2"
- use ieee1394 || myconf="${myconf} --disable-dv1394"
- use network || myconf="${myconf} --disable-network"
- use zlib || myconf="${myconf} --disable-zlib"
- use sdl || myconf="${myconf} --disable-ffplay"
-
- myconf="${myconf} --disable-opts"
-
- # disabled by default
- use encode && myconf="${myconf} --enable-mp3lame"
- use a52 && myconf="${myconf} --enable-a52"
- use ieee1394 && myconf="${myconf} --enable-dc1394"
- use threads && myconf="${myconf} --enable-pthreads"
- use xvid && myconf="${myconf} --enable-xvid"
- if use vorbis
- then
- myconf="${myconf} --enable-vorbis --enable-libogg"
- else
- use ogg && myconf="${myconf} --enable-libogg"
- fi
- use x264 && myconf="${myconf} --enable-x264"
- use aac && myconf="${myconf} --enable-faad --enable-faac"
- use amr && myconf="${myconf} --enable-amr_nb --enable-amr_wb"
-
- myconf="${myconf} --enable-gpl --enable-pp --disable-strip"
-
- # Specific workarounds for too-few-registers arch...
- if [[ $(tc-arch) == "x86" ]]; then
- filter-flags -fforce-addr -momit-leaf-frame-pointer
- append-flags -fomit-frame-pointer
- is-flag -O? || append-flags -O2
- if (use debug); then
- # no need to warn about debug if not using debug flag
- ewarn ""
- ewarn "Debug information will be almost useless as the frame pointer is omitted."
- ewarn "This makes debugging harder, so crashes that has no fixed behavior are"
- ewarn "difficult to fix. Please have that in mind."
- ewarn ""
- fi
- fi
-
- cd ${S}
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --shlibdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man \
- --enable-static --enable-shared \
- "--cc=$(tc-getCC)" \
- ${myconf} || die "configure failed"
-
- emake -j1 depend || die "depend failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake -j1 LDCONFIG=true DESTDIR=${D} install || die "Install Failed"
-
- use doc && emake -j1 documentation
- dodoc Changelog README INSTALL
- dodoc doc/*
-}
-
-# Never die for now...
-src_test() {
- cd ${S}/tests
- for t in "codectest libavtest test-server" ; do
- make ${t} || ewarn "Some tests in ${t} failed"
- done
-}
-
-pkg_postinst() {
- ewarn "ffmpeg may have had ABI changes, if ffmpeg based programs"
- ewarn "like xine-lib or vlc stop working as expected please"
- ewarn "rebuild them."
-}
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20070330.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20070330.ebuild
deleted file mode 100644
index 23720683625c..000000000000
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20070330.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20070330.ebuild,v 1.13 2008/02/14 15:17:09 drac Exp $
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Complete solution to record, convert and stream audio and video.
-Includes libavcodec. SVN revision 8560"
-HOMEPAGE="http://ffmpeg.org/"
-MY_P=${P/_/-}
-S=${WORKDIR}/ffmpeg
-
-SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
- amr? ( http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/26104-510.zip
- http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/26204-510.zip )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="aac altivec amr debug doc ieee1394 a52 encode imlib mmx ogg vorbis oss
- test theora threads truetype v4l x264 xvid network zlib sdl X"
-
-RDEPEND="imlib? ( media-libs/imlib2 )
- truetype? ( >=media-libs/freetype-2 )
- sdl? ( >=media-libs/libsdl-1.2.10 )
- encode? ( media-sound/lame
- vorbis? ( media-libs/libvorbis )
- theora? ( media-libs/libtheora ) )
- ogg? ( media-libs/libogg )
- aac? ( media-libs/faad2 media-libs/faac )
- a52? ( >=media-libs/a52dec-0.7.4-r4 )
- xvid? ( >=media-libs/xvid-1.1.0 )
- zlib? ( sys-libs/zlib )
- ieee1394? ( =media-libs/libdc1394-1*
- sys-libs/libraw1394 )
- x264? ( >=media-libs/x264-svn-20061014 )
- X? ( x11-libs/libX11 x11-libs/libXext )"
-
-DEPEND="${RDEPEND}
- doc? ( app-text/texi2html )
- test? ( net-misc/wget )
- amr? ( app-arch/unzip )"
-# Make sure the mmx USE flag is unmasked
-# Remove this once default-linux/amd64/2006.1 is deprecated
-DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
-
-src_unpack() {
- unpack ${A} || die
- cd ${S}
-
- # amr (float) support
- if use amr; then
- einfo "Including amr wide and narrow band (float) support ... "
-
- # narrow band codec
- mkdir ${S}/libavcodec/amr_float
- cd ${S}/libavcodec/amr_float
- unzip -q ${WORKDIR}/26104-510_ANSI_C_source_code.zip
-
- # wide band codec
- mkdir ${S}/libavcodec/amrwb_float
- cd ${S}/libavcodec/amrwb_float
- unzip -q ${WORKDIR}/26204-510_ANSI-C_source_code.zip
-
- # Patch if we're on 64-bit
- if useq alpha || useq amd64 || useq ia64 || useq ppc64; then
- cd ${S}
- epatch "${FILESDIR}/ffmpeg-0.4.9_p20060302-amr-64bit.patch"
- fi
- fi
-
- cd ${S}
-
- #Append -fomit-frame-pointer to avoid some common issues
- use debug || append-flags "-fomit-frame-pointer"
-
- # for some reason it tries to #include <X11/Xlib.h>, but doesn't use it
- sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
-
- # .pc files contain wrong libdir path
- epatch ${FILESDIR}/${PN}-libdir-2007.patch
- sed -i -e "s:GENTOOLIBDIR:$(get_libdir):" configure
-
- # Make it use pic always since we don't need textrels
- sed -i -e "s:LIBOBJFLAGS=\"\":LIBOBJFLAGS=\'\$\(PIC\)\':" configure
-
- # To make sure the ffserver test will work
- sed -i -e "s:-e debug=off::" tests/server-regression.sh
-
- epatch "${FILESDIR}/${PN}-shared-gcc4.1.patch"
- # disable non pic safe asm, bug #172877, bug #172845 and dupes
- epatch "${FILESDIR}/${P}-asmpic.patch"
-}
-
-src_compile() {
- replace-flags -O0 -O2
- #x86, what a wonderful arch....
- replace-flags -O1 -O2
- local myconf="${EXTRA_ECONF}"
-
- #disable mmx accelerated code if not requested, or if PIC is required
- # as the provided asm decidedly is not PIC.
- if ( gcc-specs-pie || ! use mmx ) ; then
- myconf="${myconf} --disable-mmx"
- fi
-
- # enabled by default
- use altivec || myconf="${myconf} --disable-altivec"
- use debug || myconf="${myconf} --disable-debug"
- use oss || myconf="${myconf} --disable-audio-oss"
- use v4l || myconf="${myconf} --disable-v4l --disable-v4l2"
- use ieee1394 || myconf="${myconf} --disable-dv1394"
- use network || myconf="${myconf} --disable-network"
- use zlib || myconf="${myconf} --disable-zlib"
- use sdl || myconf="${myconf} --disable-ffplay"
-
- myconf="${myconf} --disable-opts"
-
- # disabled by default
- if use encode
- then
- myconf="${myconf} --enable-libmp3lame"
- use vorbis && myconf="${myconf} --enable-libvorbis --enable-libogg"
- use theora && myconf="${myconf} --enable-libtheora --enable-libogg"
- fi
- use a52 && myconf="${myconf} --enable-liba52"
- use ieee1394 && myconf="${myconf} --enable-dc1394"
- use threads && myconf="${myconf} --enable-pthreads"
- use xvid && myconf="${myconf} --enable-xvid"
- use X && myconf="${myconf} --enable-x11grab"
- use ogg && myconf="${myconf} --enable-libogg"
- use x264 && myconf="${myconf} --enable-x264"
- use aac && myconf="${myconf} --enable-libfaad --enable-libfaac"
- use amr && myconf="${myconf} --enable-amr-nb --enable-amr-wb \
- --enable-amr-if2"
-
- myconf="${myconf} --enable-gpl --enable-pp --disable-strip"
-
- tc-is-cross-compiler && myconf="${myconf} --cross-compile --arch=$(tc-arch-kernel)"
-
- # Specific workarounds for too-few-registers arch...
- if [[ $(tc-arch) == "x86" ]]; then
- filter-flags -fforce-addr -momit-leaf-frame-pointer
- append-flags -fomit-frame-pointer
- is-flag -O? || append-flags -O2
- if (use debug); then
- # no need to warn about debug if not using debug flag
- ewarn ""
- ewarn "Debug information will be almost useless as the frame pointer is omitted."
- ewarn "This makes debugging harder, so crashes that has no fixed behavior are"
- ewarn "difficult to fix. Please have that in mind."
- ewarn ""
- fi
- fi
-
- cd ${S}
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --shlibdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man \
- --enable-static --enable-shared \
- "--cc=$(tc-getCC)" \
- ${myconf} || die "configure failed"
-
- emake -j1 depend || die "depend failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake -j1 LDCONFIG=true DESTDIR=${D} install || die "Install Failed"
-
- use doc && emake -j1 documentation
- dodoc Changelog README INSTALL
- dodoc doc/*
-}
-
-# Never die for now...
-src_test() {
- cd ${S}/tests
- for t in "codectest libavtest test-server" ; do
- make ${t} || ewarn "Some tests in ${t} failed"
- done
-}
-
-pkg_postinst() {
- ewarn "ffmpeg may have had ABI changes, if ffmpeg based programs"
- ewarn "like xine-lib or vlc stop working as expected please"
- ewarn "rebuild them."
-}
diff --git a/media-video/ffmpeg/ffmpeg-0.4.9_p20070525.ebuild b/media-video/ffmpeg/ffmpeg-0.4.9_p20080326.ebuild
index d662ed419873..a4e53c0c939f 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.9_p20070525.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.9_p20080326.ebuild
@@ -1,68 +1,59 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20070525.ebuild,v 1.5 2007/10/31 11:54:03 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.9_p20080326.ebuild,v 1.1 2008/03/26 10:53:01 lu_zero Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
DESCRIPTION="Complete solution to record, convert and stream audio and video.
-Includes libavcodec. SVN revision 8560"
+Includes libavcodec. svn revision 11878"
HOMEPAGE="http://ffmpeg.org/"
MY_P=${P/_/-}
-S=${WORKDIR}/ffmpeg
-
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+S=${WORKDIR}/ffmpeg
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="aac altivec amr debug doc ieee1394 a52 encode imlib mmx ogg vorbis oss
- test theora threads truetype v4l x264 xvid network zlib sdl X"
+IUSE="aac altivec amr debug doc ieee1394 a52 encode imlib ipv6 mmx vorbis
+ test theora threads truetype x264 xvid network zlib sdl X mp3
+ hardcoded-tables bindist"
RDEPEND="imlib? ( media-libs/imlib2 )
truetype? ( >=media-libs/freetype-2 )
sdl? ( >=media-libs/libsdl-1.2.10 )
- encode? ( media-sound/lame
+ encode? (
+ aac? ( media-libs/faac )
+ mp3? ( media-sound/lame )
vorbis? ( media-libs/libvorbis )
- theora? ( media-libs/libtheora ) )
- ogg? ( media-libs/libogg )
- aac? ( media-libs/faad2 media-libs/faac )
+ theora? ( media-libs/libtheora )
+ x264? ( >=media-libs/x264-svn-20061014 )
+ xvid? ( >=media-libs/xvid-1.1.0 ) )
+ aac? ( media-libs/faad2 )
a52? ( >=media-libs/a52dec-0.7.4-r4 )
- xvid? ( >=media-libs/xvid-1.1.0 )
zlib? ( sys-libs/zlib )
ieee1394? ( =media-libs/libdc1394-1*
sys-libs/libraw1394 )
- x264? ( >=media-libs/x264-svn-20061014 )
X? ( x11-libs/libX11 x11-libs/libXext )
amr? ( media-libs/amrnb media-libs/amrwb )"
DEPEND="${RDEPEND}
doc? ( app-text/texi2html )
test? ( net-misc/wget )"
-# Make sure the mmx USE flag is unmasked
-# Remove this once default-linux/amd64/2006.1 is deprecated
-DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
src_unpack() {
- unpack ${A} || die
- cd ${S}
+ unpack ${A}
+
+ cd "${S}"
#Append -DBROKEN_RELOCATIONS to build for bug 179872.
#Pretty please fix me if you can.
append-flags "-DBROKEN_RELOCATIONS"
- #Append -fomit-frame-pointer to avoid some common issues
- use debug || append-flags "-fomit-frame-pointer"
-
- # for some reason it tries to #include <X11/Xlib.h>, but doesn't use it
- sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
-
# .pc files contain wrong libdir path
- epatch ${FILESDIR}/${PN}-libdir-2007.patch
+ epatch "${FILESDIR}/${PN}-libdir-2007.patch"
sed -i -e "s:GENTOOLIBDIR:$(get_libdir):" configure
- # Make it use pic always since we don't need textrels
- sed -i -e "s:LIBOBJFLAGS=\"\":LIBOBJFLAGS=\'\$\(PIC\)\':" configure
-
# To make sure the ffserver test will work
sed -i -e "s:-e debug=off::" tests/server-regression.sh
@@ -86,36 +77,51 @@ src_compile() {
# enabled by default
use altivec || myconf="${myconf} --disable-altivec"
use debug || myconf="${myconf} --disable-debug"
- use oss || myconf="${myconf} --disable-audio-oss"
- use v4l || myconf="${myconf} --disable-v4l --disable-v4l2"
- use ieee1394 || myconf="${myconf} --disable-dv1394"
- use network || myconf="${myconf} --disable-network"
use zlib || myconf="${myconf} --disable-zlib"
use sdl || myconf="${myconf} --disable-ffplay"
- myconf="${myconf} --disable-opts"
+ if use network; then
+ use ipv6 || myconf="${myconf} --disable-ipv6"
+ else
+ myconf="${myconf} --disable-network"
+ fi
+
+ myconf="${myconf} --disable-optimizations"
# disabled by default
if use encode
then
- myconf="${myconf} --enable-libmp3lame"
- use vorbis && myconf="${myconf} --enable-libvorbis --enable-libogg"
- use theora && myconf="${myconf} --enable-libtheora --enable-libogg"
+ use aac && myconf="${myconf} --enable-libfaac"
+ use mp3 && myconf="${myconf} --enable-libmp3lame"
+ use vorbis && myconf="${myconf} --enable-libvorbis"
+ use theora && myconf="${myconf} --enable-libtheora"
+ use x264 && myconf="${myconf} --enable-libx264"
+ use xvid && myconf="${myconf} --enable-libxvid"
+ else
+ myconf="${myconf} --disable-encoders"
fi
use a52 && myconf="${myconf} --enable-liba52"
- use ieee1394 && myconf="${myconf} --enable-dc1394"
+ use ieee1394 && myconf="${myconf} --enable-libdc1394"
use threads && myconf="${myconf} --enable-pthreads"
- use xvid && myconf="${myconf} --enable-xvid"
use X && myconf="${myconf} --enable-x11grab"
- use ogg && myconf="${myconf} --enable-libogg"
- use x264 && myconf="${myconf} --enable-x264"
- use aac && myconf="${myconf} --enable-libfaad --enable-libfaac"
- use amr && myconf="${myconf} --enable-libamr-nb --enable-libamr-wb"
+ use aac && myconf="${myconf} --enable-libfaad"
+ if use bindist
+ then
+ use amr && einfo "libamr is nonfree and cannot be distributed"
+ else
+ use amr && myconf="${myconf} --enable-libamr-nb \
+ --enable-libamr-wb \
+ --enable-nonfree"
+ fi
- myconf="${myconf} --enable-gpl --enable-pp --disable-strip"
+ myconf="${myconf} --enable-gpl --enable-postproc \
+ --enable-avfilter --enable-avfilter-lavf \
+ --enable-swscale --disable-stripping"
tc-is-cross-compiler && myconf="${myconf} --cross-compile --arch=$(tc-arch-kernel)"
+ use hardcoded-tables && myconf="${myconf} --enable-hardcoded-tables"
+
# Specific workarounds for too-few-registers arch...
if [[ $(tc-arch) == "x86" ]]; then
filter-flags -fforce-addr -momit-leaf-frame-pointer
@@ -131,7 +137,7 @@ src_compile() {
fi
fi
- cd ${S}
+ cd "${S}"
./configure \
--prefix=/usr \
--libdir=/usr/$(get_libdir) \
@@ -146,7 +152,7 @@ src_compile() {
}
src_install() {
- emake -j1 LDCONFIG=true DESTDIR=${D} install || die "Install Failed"
+ emake -j1 LDCONFIG=true DESTDIR="${D}" install || die "Install Failed"
use doc && emake -j1 documentation
dodoc Changelog README INSTALL
@@ -155,7 +161,7 @@ src_install() {
# Never die for now...
src_test() {
- cd ${S}/tests
+ cd "${S}/tests"
for t in "codectest libavtest test-server" ; do
make ${t} || ewarn "Some tests in ${t} failed"
done
diff --git a/media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch b/media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch
deleted file mode 100644
index ba733bc4f17d..000000000000
--- a/media-video/ffmpeg/files/ffmpeg-0.4.9_p20051216-asneeded-configure.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ffmpeg-0.4.9-p20051216/configure
-===================================================================
---- ffmpeg-0.4.9-p20051216.orig/configure
-+++ ffmpeg-0.4.9-p20051216/configure
-@@ -987,7 +987,7 @@ int main( void ) { return (lrintf(3.999f
- EOF
-
- have_lrintf="no"
--if $cc $CFLAGS $LDFLAGS $extralibs -o $TMPE $TMPC 2> /dev/null ; then
-+if $cc $CFLAGS $LDFLAGS -o $TMPE $TMPC $extralibs 2> /dev/null ; then
- have_lrintf="yes"
- # allanc@chickenandporn.com: cannot execute cross-compiled
- # code on the host. Only execute if not cross-compiling.