summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-09 14:05:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-09 14:05:49 +0000
commitdccd6eb1e6fc992d2912de816058c40bac8c33f2 (patch)
treefaf1b27fd21228ad89fc850e4533cde0b99bb4b1 /media-video
parentstable ppc, bug 342991 (diff)
downloadgentoo-2-dccd6eb1e6fc992d2912de816058c40bac8c33f2.tar.gz
gentoo-2-dccd6eb1e6fc992d2912de816058c40bac8c33f2.tar.bz2
gentoo-2-dccd6eb1e6fc992d2912de816058c40bac8c33f2.zip
Fix CPPFLAGS and CXXFLAGS confusion in configure.ac.
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog6
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild4
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-flags.patch25
3 files changed, 32 insertions, 3 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 63692ff3bbef..39743ee8c69b 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.110 2011/01/09 13:58:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.111 2011/01/09 14:05:49 ssuominen Exp $
+
+ 09 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+ ffmpegthumbnailer-2.0.6.ebuild, +files/ffmpegthumbnailer-2.0.6-flags.patch:
+ Fix CPPFLAGS and CXXFLAGS confusion in configure.ac.
*ffmpegthumbnailer-2.0.6 (09 Jan 2011)
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
index 8d930269ef6b..641fae116a49 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild,v 1.1 2011/01/09 13:58:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild,v 1.2 2011/01/09 14:05:49 ssuominen Exp $
EAPI=2
inherit autotools eutils
@@ -23,7 +23,7 @@ DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-{asneeded,flags}.patch
eautoreconf
}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-flags.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-flags.patch
new file mode 100644
index 000000000000..2262faedfc73
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-flags.patch
@@ -0,0 +1,25 @@
+http://code.google.com/p/ffmpegthumbnailer/issues/detail?id=76
+
+--- configure.ac
++++ configure.ac
+@@ -104,9 +104,9 @@
+ fi
+
+ ########################################################################
+-# Compiler flags
++# Preprocessor flags
+ ########################################################################
+-CXXFLAGS=-D__STDC_CONSTANT_MACROS
++CPPFLAGS="$CPPFLAGS -D__STDC_CONSTANT_MACROS"
+
+ ########################################################################
+ # Check debug mode
+@@ -118,7 +118,7 @@
+ AM_CONDITIONAL(DEBUG, test "$enable_debug" = "yes")
+ if test "$DEBUG" = "yes"; then
+ AC_DEFINE(ENABLE_DEBUG, [], "Enable debug mode")
+- CXXFLAGS+=" -g -O1 -Wall -Werror -Wfatal-errors"
++ CXXFLAGS="$CXXFLAGS -g -O1 -Wall -Werror -Wfatal-errors"
+ fi
+
+ AC_ARG_ENABLE(unittests,