summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-15 20:56:13 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-15 20:56:13 +0000
commite410bcb69f73dbc1686b047c010abfbe60c60b22 (patch)
treeba9b6d8b8fbd8ef5f834977e98404752d7c4841b /media-video
parentMinor bug fix to build process, patching configure to pass the $HOST setting (diff)
downloadgentoo-2-e410bcb69f73dbc1686b047c010abfbe60c60b22.tar.gz
gentoo-2-e410bcb69f73dbc1686b047c010abfbe60c60b22.tar.bz2
gentoo-2-e410bcb69f73dbc1686b047c010abfbe60c60b22.zip
Fixed GET_PP_QUALITY_MAX compile error.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/ChangeLog9
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.1-r11
-rw-r--r--media-video/transcode/files/transcode-0.6.1-PP_QUALITY_MAX.patch24
-rw-r--r--media-video/transcode/transcode-0.6.1-r1.ebuild111
4 files changed, 144 insertions, 1 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index 804e45f8a957..6726c9d208cb 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/transcode
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.15 2002/10/29 16:53:43 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.16 2002/11/15 20:56:13 phoenix Exp $
+
+*transcode-0.6.1-r1 (29 Oct 2002)
+
+ 29 Oct 2002; phoen][x <phoenix@gentoo.org> ChangeLog, transcode-0.6.1-r1.ebuild,
+ files/digest-transcode-0.6.1-1, transcode-0.6.1-PP_QUALITY_MAX.patch :
+ Added a workaround for the GET_PP_QUALITY_MAX compile problem. This fixes bugs
+ #9351, #10788 and #10790. Thanks for your help, guys.
*transcode-0.6.1 (29 Oct 2002)
diff --git a/media-video/transcode/files/digest-transcode-0.6.1-r1 b/media-video/transcode/files/digest-transcode-0.6.1-r1
new file mode 100644
index 000000000000..941a6d2d4bac
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.1-r1
@@ -0,0 +1 @@
+MD5 ac9a66cff7cab3e52b089723e4b77ca7 transcode-0.6.1.tgz 2272803
diff --git a/media-video/transcode/files/transcode-0.6.1-PP_QUALITY_MAX.patch b/media-video/transcode/files/transcode-0.6.1-PP_QUALITY_MAX.patch
new file mode 100644
index 000000000000..e4d3a2fae632
--- /dev/null
+++ b/media-video/transcode/files/transcode-0.6.1-PP_QUALITY_MAX.patch
@@ -0,0 +1,24 @@
+diff -ru transcode-0.6.1/filter/filter_pp.c transcode-0.6.1-r1/filter/filter_pp.c
+--- transcode-0.6.1/filter/filter_pp.c 2002-06-16 08:30:53.000000000 +0200
++++ transcode-0.6.1-r1/filter/filter_pp.c 2002-11-15 13:26:09.000000000 +0100
+@@ -154,7 +154,7 @@
+ pp_page, vob->ex_v_width,
+ vob->ex_v_width, vob->ex_v_height,
+ NULL, 0,
+- GET_PP_QUALITY_MAX);
++ PP_QUALITY_MAX);
+ }
+ }
+
+diff -ru transcode-0.6.1/filter/filter_ppcvs.c transcode-0.6.1-r1/filter/filter_ppcvs.c
+--- transcode-0.6.1/filter/filter_ppcvs.c 2002-06-16 08:30:53.000000000 +0200
++++ transcode-0.6.1-r1/filter/filter_ppcvs.c 2002-11-15 13:26:20.000000000 +0100
+@@ -160,7 +160,7 @@
+ pp_page, vob->ex_v_width,
+ vob->ex_v_width, vob->ex_v_height,
+ NULL, 0,
+- GET_PP_QUALITY_MAX);
++ PP_QUALITY_MAX);
+ }
+ }
+
diff --git a/media-video/transcode/transcode-0.6.1-r1.ebuild b/media-video/transcode/transcode-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..5a8185801e2b
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.1-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.1-r1.ebuild,v 1.1 2002/11/15 20:56:13 phoenix Exp $
+
+IUSE="sdl mmx mpeg sse dvd encode X quicktime avi"
+
+inherit libtool
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/${MY_P}.tgz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/a52dec-0.7.3
+ >=media-libs/libdv-0.9.5
+ >=media-video/mplayer-0.90_pre10
+ x86? ( dev-lang/nasm )
+ X? ( virtual/x11 )
+ avi? ( >=media-video/avifile-0.7.4 )
+ dvd? ( media-libs/libdvdread )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ sdl? ( media-libs/libsdl )
+ quicktime? ( media-libs/quicktime4linux )
+ >=media-video/avifile-0.7.4
+ media-libs/libdvdread"
+# Dont want to build without these currently
+# avi? ( >=media-video/avifile-0.7.4 )
+# dvd? ( media-libs/libdvdread )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Fix GET_PP_QUALITY_MAX error
+ cd ${S}; patch -p1 < ${FILESDIR}/${MY_P}-PP_QUALITY_MAX.patch || die
+
+}
+
+src_compile() {
+
+ # fix invalid paths in .la files of plugins
+ elibtoolize
+
+ local myconf=""
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+# use avi \
+# && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
+# || myconf="${myconf} --without-avifile-mods --disable-avifile6"
+#
+# use dvd \
+# && myconf="${myconf} --with-dvdread" \
+# || myconf="${myconf} --without-dvdread"
+#
+# Dont currently want to build without these
+ myconf="${myconf} --with-dvdread --with-avifile-mods --enable-avifile6"
+
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ # Use the MPlayer libpostproc if present
+ [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/include/postprocess.h ] && \
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+
+ econf ${myconf} || die
+
+ # Do not use emake !!
+ make all || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+}
+