summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-01 19:22:54 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-01 19:22:54 +0000
commite6f419b7a2c13adc6a80b5db7e13f5d1a77a5274 (patch)
tree63cbe17192cd58767368ee3944282451c6dd64ce /media-video
parentUse system libmpd #255771. (diff)
downloadgentoo-2-e6f419b7a2c13adc6a80b5db7e13f5d1a77a5274.tar.gz
gentoo-2-e6f419b7a2c13adc6a80b5db7e13f5d1a77a5274.tar.bz2
gentoo-2-e6f419b7a2c13adc6a80b5db7e13f5d1a77a5274.zip
Add patch from bug 266801 that actually applies, and edit ebuild to make sure the patch actually gets applied...
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/gnome-mplayer/ChangeLog8
-rw-r--r--media-video/gnome-mplayer/files/gnome-mplayer-0.9.5-nautilus-gettext.patch (renamed from media-video/gnome-mplayer/files/gnome-mplayer-0.9.5-gettext.patch)58
-rw-r--r--media-video/gnome-mplayer/gnome-mplayer-0.9.5-r1.ebuild7
3 files changed, 47 insertions, 26 deletions
diff --git a/media-video/gnome-mplayer/ChangeLog b/media-video/gnome-mplayer/ChangeLog
index a617e33b49e6..205a3027c604 100644
--- a/media-video/gnome-mplayer/ChangeLog
+++ b/media-video/gnome-mplayer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/gnome-mplayer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gnome-mplayer/ChangeLog,v 1.15 2009/06/01 01:52:23 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/gnome-mplayer/ChangeLog,v 1.16 2009/06/01 19:22:54 yngwin Exp $
+
+ 01 Jun 2009; Ben de Groot <yngwin@gentoo.org>
+ gnome-mplayer-0.9.5-r1.ebuild, -files/gnome-mplayer-0.9.5-gettext.patch,
+ +files/gnome-mplayer-0.9.5-nautilus-gettext.patch:
+ Add patch that actually applies, and edit ebuild to make sure the patch
+ actually gets applied...
*gnome-mplayer-0.9.5-r2 (01 Jun 2009)
diff --git a/media-video/gnome-mplayer/files/gnome-mplayer-0.9.5-gettext.patch b/media-video/gnome-mplayer/files/gnome-mplayer-0.9.5-nautilus-gettext.patch
index 585e9f34b6a4..1c6ccef01d56 100644
--- a/media-video/gnome-mplayer/files/gnome-mplayer-0.9.5-gettext.patch
+++ b/media-video/gnome-mplayer/files/gnome-mplayer-0.9.5-nautilus-gettext.patch
@@ -1,6 +1,19 @@
---- src/nautilus_property_page.c (revision 1243)
-+++ src/nautilus_property_page.c (working copy)
-@@ -84,9 +84,9 @@
+Index: src/nautilus_property_page.c
+===================================================================
+--- src/nautilus_property_page.c (wersja 1179)
++++ src/nautilus_property_page.c (wersja 1246)
+@@ -22,7 +22,9 @@
+ * Boston, MA 02110-1301, USA.
+ */
+
+-#include "config.h"
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
+ #include "mime_types.h"
+ #include <libnautilus-extension/nautilus-extension-types.h>
+ #include <libnautilus-extension/nautilus-property-page-provider.h>
+@@ -82,9 +84,9 @@
}
if (hour == 0) {
@@ -12,7 +25,7 @@
}
return g_strstrip(result);
}
-@@ -265,7 +265,7 @@
+@@ -263,7 +265,7 @@
data = get_metadata(filename);
@@ -21,7 +34,7 @@
gtk_label_set_use_markup(GTK_LABEL(label), TRUE);
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 0, 6);
-@@ -273,7 +273,7 @@
+@@ -271,7 +273,7 @@
i++;
if (data->title && strlen(data->title) > 0) {
@@ -30,7 +43,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -285,7 +285,7 @@
+@@ -283,7 +285,7 @@
}
if (data->artist && strlen(data->artist) > 0) {
@@ -39,7 +52,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -297,7 +297,7 @@
+@@ -295,7 +297,7 @@
}
if (data->album && strlen(data->album) > 0) {
@@ -48,7 +61,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -309,7 +309,7 @@
+@@ -307,7 +309,7 @@
}
if (data->length) {
@@ -57,7 +70,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -321,7 +321,7 @@
+@@ -319,7 +321,7 @@
}
if (data->demuxer && strlen(data->demuxer) > 0) {
@@ -66,7 +79,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -333,14 +333,14 @@
+@@ -331,14 +333,14 @@
}
if (data->video_present) {
@@ -83,7 +96,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -351,7 +351,7 @@
+@@ -349,7 +351,7 @@
g_free(buf);
i++;
@@ -92,7 +105,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -362,7 +362,7 @@
+@@ -360,7 +362,7 @@
gtk_table_attach_defaults(GTK_TABLE(page), label, 1, 2, i, i + 1);
i++;
@@ -101,7 +114,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -373,7 +373,7 @@
+@@ -371,7 +373,7 @@
gtk_table_attach_defaults(GTK_TABLE(page), label, 1, 2, i, i + 1);
i++;
@@ -110,7 +123,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -387,14 +387,14 @@
+@@ -385,14 +387,14 @@
}
if (data->audio_present) {
@@ -127,7 +140,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -405,7 +405,7 @@
+@@ -403,7 +405,7 @@
gtk_table_attach_defaults(GTK_TABLE(page), label, 1, 2, i, i + 1);
i++;
@@ -136,7 +149,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -417,7 +417,7 @@
+@@ -415,7 +417,7 @@
i++;
if (g_strtod(data->audio_nch, NULL) > 0) {
@@ -145,7 +158,7 @@
gtk_misc_set_alignment(GTK_MISC(label), 0.0, 0.0);
gtk_misc_set_padding(GTK_MISC(label), 12, 0);
gtk_table_attach_defaults(GTK_TABLE(page), label, 0, 1, i, i + 1);
-@@ -475,7 +475,7 @@
+@@ -473,7 +475,7 @@
if (found) {
uri = nautilus_file_info_get_uri(file);
@@ -154,15 +167,14 @@
page = gtk_table_new(20, 2, FALSE);
gtk_container_set_border_width(GTK_CONTAINER(page), 6);
if (get_properties(page, uri)) {
-@@ -528,8 +528,11 @@
- {
-
+@@ -528,7 +530,9 @@
#ifdef ENABLE_NLS
-+ //printf("%s\n",GETTEXT_PACKAGE);
-+ //printf("%s\n",PACKAGE_LOCALE_DIR);
bindtextdomain(GETTEXT_PACKAGE, PACKAGE_LOCALE_DIR);
bind_textdomain_codeset(GETTEXT_PACKAGE, "UTF-8");
-+ //textdomain(GETTEXT_PACKAGE);
+- textdomain(GETTEXT_PACKAGE);
++ // specify the domain in the translation calls so
++ // we don't mess up the translation of the other tabs
++ // textdomain(GETTEXT_PACKAGE);
#endif
gnome_mplayer_properties_plugin_register_type(module);
diff --git a/media-video/gnome-mplayer/gnome-mplayer-0.9.5-r1.ebuild b/media-video/gnome-mplayer/gnome-mplayer-0.9.5-r1.ebuild
index f768e1e4e276..371d8f7b25f4 100644
--- a/media-video/gnome-mplayer/gnome-mplayer-0.9.5-r1.ebuild
+++ b/media-video/gnome-mplayer/gnome-mplayer-0.9.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gnome-mplayer/gnome-mplayer-0.9.5-r1.ebuild,v 1.1 2009/05/29 21:47:21 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/gnome-mplayer/gnome-mplayer-0.9.5-r1.ebuild,v 1.2 2009/06/01 19:22:54 yngwin Exp $
EAPI="2"
GCONF_DEBUG=no
@@ -33,7 +33,10 @@ DEPEND="${RDEPEND}
DOCS="ChangeLog README DOCS/keyboard_shortcuts.txt"
-PATCHES=( "${FILESDIR}"/${P}-gettext.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nautilus-gettext.patch
+ gnome2_src_prepare
+}
src_configure() {
G2CONF="${G2CONF}