summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-01-01 22:26:16 +0000
committerBen de Groot <yngwin@gentoo.org>2009-01-01 22:26:16 +0000
commitf4c42fc3a5e08d82cc75d066b319385fc2fb2eb8 (patch)
tree8a49f389a73572ee2e8306d1963adc01880f4cef /media-video
parentwrap text at 77 chars cause ewarn add ' * ' (diff)
downloadgentoo-2-f4c42fc3a5e08d82cc75d066b319385fc2fb2eb8.tar.gz
gentoo-2-f4c42fc3a5e08d82cc75d066b319385fc2fb2eb8.tar.bz2
gentoo-2-f4c42fc3a5e08d82cc75d066b319385fc2fb2eb8.zip
Version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-hh7 i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/whaawmp/ChangeLog9
-rw-r--r--media-video/whaawmp/whaawmp-0.2.10.1.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/media-video/whaawmp/ChangeLog b/media-video/whaawmp/ChangeLog
index 74f81f3104d0..ba77b545e9e0 100644
--- a/media-video/whaawmp/ChangeLog
+++ b/media-video/whaawmp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/whaawmp
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/whaawmp/ChangeLog,v 1.1 2008/09/24 10:44:20 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/whaawmp/ChangeLog,v 1.2 2009/01/01 22:26:16 yngwin Exp $
+
+*whaawmp-0.2.10.1 (01 Jan 2009)
+
+ 01 Jan 2009; Ben de Groot <yngwin@gentoo.org> +whaawmp-0.2.10.1.ebuild:
+ Version bump
*whaawmp-0.2.10 (24 Sep 2008)
diff --git a/media-video/whaawmp/whaawmp-0.2.10.1.ebuild b/media-video/whaawmp/whaawmp-0.2.10.1.ebuild
new file mode 100644
index 000000000000..420e64a91408
--- /dev/null
+++ b/media-video/whaawmp/whaawmp-0.2.10.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/whaawmp/whaawmp-0.2.10.1.ebuild,v 1.1 2009/01/01 22:26:16 yngwin Exp $
+
+inherit distutils
+
+DESCRIPTION="Whaaw! Media Player is a lightweight audio/video player"
+HOMEPAGE="http://home.gna.org/whaawmp"
+SRC_URI="http://download.gna.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+# Upstream requires gst-plugins-good as a minimum
+# Depending on the desired video (and audio) playback support, users will need
+# to set USE flags for the -meta ebuild, as everything it supports can be used,
+# like DVD playback, especially. No support yet for audio CDs, but I'm kinda
+# working with upstream to add such features.
+RDEPEND=">=dev-lang/python-2.5
+ dev-python/gst-python
+ dev-python/pyxdg
+ media-libs/gst-plugins-good
+ media-plugins/gst-plugins-meta
+ dbus? ( dev-python/dbus-python )"
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+
+distutils_src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ln -s make.py setup.py
+}
+
+pkg_postinst() {
+ elog "Depending on the audio/video playback capabilities"
+ elog "you want, you'll need to set appropriate USE flags"
+ elog "for media-libs/gst-plugins-good and"
+ elog "media-plugins/gst-plugins-meta in /etc/portage/package.use"
+ elog ""
+}