summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-04-23 11:50:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-04-23 11:50:23 +0000
commita9530711c2e572ccca90663668692b14273c7aae (patch)
tree8082f99c829f3ca2459fb8f09ae2f7a875f01f50 /net-analyzer/2ping/2ping-2.0.ebuild
parentapp-backup/deja-dup: Version Bump (diff)
downloadgentoo-2-a9530711c2e572ccca90663668692b14273c7aae.tar.gz
gentoo-2-a9530711c2e572ccca90663668692b14273c7aae.tar.bz2
gentoo-2-a9530711c2e572ccca90663668692b14273c7aae.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/2ping/2ping-2.0.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-2.0.ebuild b/net-analyzer/2ping/2ping-2.0.ebuild
new file mode 100644
index 000000000000..f8377f64a853
--- /dev/null
+++ b/net-analyzer/2ping/2ping-2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/2ping/2ping-2.0.ebuild,v 1.1 2012/04/23 11:50:23 blueness Exp $
+
+EAPI="4"
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="http://www.finnie.org/software/2ping/"
+SRC_URI="http://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crc ipv6 md5 sha server"
+
+# The 2ping script itself checks if these optional deps are available.
+DEPEND="
+ dev-lang/perl
+ perl-core/Getopt-Long
+ perl-core/PodParser
+ perl-core/IO
+ perl-core/Time-HiRes
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ md5? ( perl-core/Digest-MD5 )
+ sha? ( perl-core/Digest-SHA )
+ crc? ( dev-perl/Digest-CRC )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc ChangeLog README
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}