summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 17:30:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 17:30:07 +0000
commit10671a3770404a59e1518924f5313b7f35ddee5e (patch)
treefbcd9d4cb59d39f1fb8f315340027a07189f2f21 /net-analyzer/aimsniff/aimsniff-0.8.ebuild
parentinitial import (diff)
downloadgentoo-2-10671a3770404a59e1518924f5313b7f35ddee5e.tar.gz
gentoo-2-10671a3770404a59e1518924f5313b7f35ddee5e.tar.bz2
gentoo-2-10671a3770404a59e1518924f5313b7f35ddee5e.zip
webapp support
Diffstat (limited to 'net-analyzer/aimsniff/aimsniff-0.8.ebuild')
-rw-r--r--net-analyzer/aimsniff/aimsniff-0.8.ebuild69
1 files changed, 33 insertions, 36 deletions
diff --git a/net-analyzer/aimsniff/aimsniff-0.8.ebuild b/net-analyzer/aimsniff/aimsniff-0.8.ebuild
index 549370b0deb4..f2ea526ab576 100644
--- a/net-analyzer/aimsniff/aimsniff-0.8.ebuild
+++ b/net-analyzer/aimsniff/aimsniff-0.8.ebuild
@@ -1,6 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# /space/gentoo/cvsroot/gentoo-x86
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/aimsniff/aimsniff-0.8.ebuild,v 1.2 2003/08/05 17:30:07 vapier Exp $
+
+inherit webapp-apache
+
+DESCRIPTION="utility for monitoring and archiving AOL Instant Messenger messages across a network"
+HOMEPAGE="http://www.aimsniff.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/was_0.1.1b.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="samba mysql apache2"
DEPEND="dev-lang/perl
dev-perl/Net-Pcap
@@ -8,47 +20,32 @@ DEPEND="dev-lang/perl
dev-perl/Unicode-String
dev-perl/FileHandle-Rollback
dev-perl/Proc-Daemon
- mysql? ( dev-perl/DBI
- dev-db/mysql )
+ mysql? ( dev-perl/DBI dev-db/mysql )
samba? ( net-fs/samba )"
-DESCRIPTION="AIM Sniff is a utility for monitoring and archiving AOL Instant Messenger messages across a network."
-HOMEPAGE="http://www.aimsniff.com"
-IUSE="samba mysql apache2"
-KEYWORDS="~x86"
-LICENSE="GPL-2"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://sourceforge/${PN}/was_0.1.1b.tar.gz"
src_install() {
- use apache2 || HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`" \
- HTTPD_USER="`grep '^User' /etc/apache/conf/commonapache.conf | cut -d \ -f2`" \
- HTTPD_GROUP="`grep '^Group' /etc/apache/conf/commonapache.conf | cut -d \ -f2`"
- use apache2 && HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache2/conf/apache2.conf | cut -d\ -f2`" \
- HTTPD_USER="`grep '^User' /etc/apache2/conf/commonapache2.conf | cut -d \ -f2`" \
- HTTPD_GROUP="`grep '^Group' /etc/apache2/conf/commonapache2.conf | cut -d \ -f2`"
-
- [ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
- [ -z "${HTTPD_USER}" ] && HTTPD_USER="apache"
- [ -z "${HTTPD_GROUP}" ] && HTTPD_GROUP="apache"
-
- dodir /etc/${PN}
- cp aimSniff.pl aimsniff
- dosbin aimsniff
- cp aimsniff.config table.struct ${D}etc/${PN}
+ newsbin aimsniff.pl aimsniff
+ insinto /etc/${PN}
+ doins aimsniff.config table.struct
dodoc README ChangeLog
- #Installing Web-Frontend
+
+ webapp-detect
dodir ${HTTPD_ROOT}
- mv ../was ${D}${HTTPD_ROOT} \
- && cd ${D}${HTTPD_ROOT} \
- && chown -R ${HTTPD_USER}.${HTTPD_GROUP} *|| ewarn "check web-frontend in ${HTTPD_ROOT}"
+ mv ../was ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
}
+
pkg_postinst() {
einfo "Go to http://${HOSTNAME}/was/ to check if everything works."
- use mysql && einfo "If you plan to use the database dump feature, you'll have to load the table.struct file into mysql." \
- && einfo "To do this run the following command 'mysql < /etc/${PN}/table.struct'." \
- && einfo "This will create a database named 'aim' with all the right tables." \
- && einfo "After that use: 'GRANT ALL ON aim.* TO username@hostname IDENTIFIED BY 'password';'" \
- && einfo "and go to http://${HOSTNAME}/was/admin.php to fill in the blanks."
- use samba && einfo "--SMB <-Turn SMB lookups 'on' to get NT domain usernames with AIM logins, Off by default."
+ if [ `use mysql` ] ; then
+ einfo "If you plan to use the database dump feature, you'll have to load the table.struct file into mysql."
+ einfo "To do this run the following command 'mysql < /etc/${PN}/table.struct'."
+ einfo "This will create a database named 'aim' with all the right tables."
+ einfo "After that use: 'GRANT ALL ON aim.* TO username@hostname IDENTIFIED BY 'password';'"
+ einfo "and go to http://${HOSTNAME}/was/admin.php to fill in the blanks."
+ fi
+ if [ `use samba` ] ; then
+ einfo "--SMB <-Turn SMB lookups 'on' to get NT domain usernames with AIM logins, Off by default."
+ fi
}
-