summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-17 04:06:28 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-17 04:06:28 +0000
commitdea61f1ba878e8d4944cb5dc2d862b6425d1bb72 (patch)
treea26750fb4a6d6cc537f0010d913b97940116730c /net-analyzer/argus-clients
parentVersion bump. (diff)
downloadgentoo-2-dea61f1ba878e8d4944cb5dc2d862b6425d1bb72.tar.gz
gentoo-2-dea61f1ba878e8d4944cb5dc2d862b6425d1bb72.tar.bz2
gentoo-2-dea61f1ba878e8d4944cb5dc2d862b6425d1bb72.zip
Version bump.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus-clients')
-rw-r--r--net-analyzer/argus-clients/ChangeLog7
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.5.14.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-analyzer/argus-clients/ChangeLog b/net-analyzer/argus-clients/ChangeLog
index 872d07817639..af0298c8db51 100644
--- a/net-analyzer/argus-clients/ChangeLog
+++ b/net-analyzer/argus-clients/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus-clients
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.22 2011/06/08 11:21:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.23 2011/06/17 04:06:28 jer Exp $
+
+*argus-clients-3.0.5.14 (17 Jun 2011)
+
+ 17 Jun 2011; Jeroen Roovers <jer@gentoo.org> +argus-clients-3.0.5.14.ebuild:
+ Version bump.
08 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
argus-clients-3.0.4.1-r1.ebuild:
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.5.14.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.5.14.ebuild
new file mode 100644
index 000000000000..770f8c1bc6da
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.5.14.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.5.14.ebuild,v 1.1 2011/06/17 04:06:28 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug geoip mysql tcpd"
+
+#sasl? ( >=dev-libs/cyrus-sasl-1.5.24 )
+MY_CDEPEND="
+ net-libs/libpcap
+ net-analyzer/rrdtool[perl]
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sys-libs/ncurses
+"
+
+# >=net-analyzer/argus-2.0.6[sasl?]"
+RDEPEND="
+ ${MY_CDEPEND}
+ >=net-analyzer/argus-3.0.2
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+src_prepare() {
+ for x in $(find . -name "Makefile.in"); do
+ sed -i "s:\$(CFLAGS):& \$(LDFLAGS) :" $x
+ done
+ epatch "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ # $(use_with sasl) \
+ econf \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra* || die "Failed to install ra*"
+ dodoc ChangeLog CREDITS README doc/{CHANGES,FAQ,HOW-TO} || die
+ doman man/man{1,5}/*
+}