summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-16 14:49:03 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-16 14:49:03 +0000
commit4600fb438fe29e8b8576e2e4fbae8bcb34e5b42d (patch)
tree96d5a36ee3fdc0043799ae40e1407c0fb2c928ef /net-analyzer/arp-sk/arp-sk-0.0.16-r1.ebuild
parentAdd a patch to allow parallel make builds, reported upstream. (diff)
downloadgentoo-2-4600fb438fe29e8b8576e2e4fbae8bcb34e5b42d.tar.gz
gentoo-2-4600fb438fe29e8b8576e2e4fbae8bcb34e5b42d.tar.bz2
gentoo-2-4600fb438fe29e8b8576e2e4fbae8bcb34e5b42d.zip
Fixed multilib issue reported by Tiago Cunha in bug #246765. Nothing else changed, no need to restabilize ppc, x86.
(Portage version: 2.2_rc14/cvs/Linux 2.6.26-openvz.git-35f41f1 i686, RepoMan options: --force)
Diffstat (limited to 'net-analyzer/arp-sk/arp-sk-0.0.16-r1.ebuild')
-rw-r--r--net-analyzer/arp-sk/arp-sk-0.0.16-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/arp-sk/arp-sk-0.0.16-r1.ebuild b/net-analyzer/arp-sk/arp-sk-0.0.16-r1.ebuild
new file mode 100644
index 000000000000..550595e143c3
--- /dev/null
+++ b/net-analyzer/arp-sk/arp-sk-0.0.16-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arp-sk/arp-sk-0.0.16-r1.ebuild,v 1.1 2008/11/16 14:49:03 pva Exp $
+
+inherit multilib
+
+DESCRIPTION="A swiss knife tool for ARP"
+HOMEPAGE="http://sid.rstack.org/arp-sk/"
+SRC_URI="http://sid.rstack.org/arp-sk/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+DEPEND=">=net-libs/libnet-1.1"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # We don't need libcompat as it has a potential to clash with other packages.
+ rm -fr "${D}"/usr/$(get_libdir)
+
+ dodoc ARP AUTHORS CONTRIB ChangeLog README TODO
+}