summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:43:08 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:43:08 +0000
commit5154f4ddcfa2d3ed51261491ee3a3fca1bbe45ed (patch)
tree870fae8b4a2bb6b9c90d52c132cfefce3d02d2bb /net-analyzer/bwmon
parentVersion bump. (diff)
downloadgentoo-2-5154f4ddcfa2d3ed51261491ee3a3fca1bbe45ed.tar.gz
gentoo-2-5154f4ddcfa2d3ed51261491ee3a3fca1bbe45ed.tar.bz2
gentoo-2-5154f4ddcfa2d3ed51261491ee3a3fca1bbe45ed.zip
Fix build by just not using the broken Makefile, instead build straight in src_compile. Also fix DEPEND/RDEPEND and die on failed install. Closes bug #247924.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/bwmon')
-rw-r--r--net-analyzer/bwmon/ChangeLog9
-rw-r--r--net-analyzer/bwmon/bwmon-1.3.ebuild31
2 files changed, 24 insertions, 16 deletions
diff --git a/net-analyzer/bwmon/ChangeLog b/net-analyzer/bwmon/ChangeLog
index c153658ee68d..9d99724a0be3 100644
--- a/net-analyzer/bwmon/ChangeLog
+++ b/net-analyzer/bwmon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/bwmon
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/ChangeLog,v 1.14 2007/07/02 14:36:59 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/ChangeLog,v 1.15 2009/06/02 11:43:08 flameeyes Exp $
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> bwmon-1.3.ebuild:
+ Fix build by just not using the broken Makefile, instead build straight in
+ src_compile. Also fix DEPEND/RDEPEND and die on failed install. Closes bug
+ #247924.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> bwmon-1.3.ebuild:
(QA) RESTRICT clean up.
diff --git a/net-analyzer/bwmon/bwmon-1.3.ebuild b/net-analyzer/bwmon/bwmon-1.3.ebuild
index 2f4eba55eddc..ed7ef47f9ac2 100644
--- a/net-analyzer/bwmon/bwmon-1.3.ebuild
+++ b/net-analyzer/bwmon/bwmon-1.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/bwmon-1.3.ebuild,v 1.17 2007/07/02 14:36:59 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/bwmon-1.3.ebuild,v 1.18 2009/06/02 11:43:08 flameeyes Exp $
+
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="Simple ncurses bandwidth monitor"
HOMEPAGE="http://bwmon.sourceforge.net/"
@@ -8,28 +10,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
RESTRICT="mirror"
DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="GPL-2 public-domain"
KEYWORDS="amd64 hppa ~ppc sparc x86"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e "s:/usr/local/bin:\$\{DESTDIR\}usr/bin:" \
- Makefile
- sed -i -e "s:CFLAGS =:CFLAGS = ${CFLAGS}:" \
- -e "s:LDFLAGS =:LDFLAGS = -L/lib:" \
- src/Makefile
+
+doecho() {
+ echo "$@"
+ "$@"
}
src_compile() {
- emake || die
+ append-flags -I "${S}"/include -D__THREADS
+
+ doecho $(tc-getCC) -o ${PN} \
+ ${CFLAGS} ${LDFLAGS} \
+ src/${PN}.c -lncurses -lpthread \
+ || die "build failed"
}
src_install () {
- dodir /usr/bin
- make DESTDIR=${D} install || die
- dodoc README
+ dobin ${PN} || die
+ dodoc README || die
}