summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-29 15:05:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-29 15:05:59 +0000
commit20358bff443d169a0d026b43822c58deff7ba196 (patch)
treee252884ea45fdd7b3692ccfe871240e8603c1b16 /net-analyzer/fe3d/fe3d-0.11.2.ebuild
parentMarked ~ppc (bug #305781). (diff)
downloadgentoo-2-20358bff443d169a0d026b43822c58deff7ba196.tar.gz
gentoo-2-20358bff443d169a0d026b43822c58deff7ba196.tar.bz2
gentoo-2-20358bff443d169a0d026b43822c58deff7ba196.zip
Fix building with -Wl,--as-needed wrt #277794 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/fe3d/fe3d-0.11.2.ebuild')
-rw-r--r--net-analyzer/fe3d/fe3d-0.11.2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-analyzer/fe3d/fe3d-0.11.2.ebuild b/net-analyzer/fe3d/fe3d-0.11.2.ebuild
index 6d6b0745f87c..536135ca505e 100644
--- a/net-analyzer/fe3d/fe3d-0.11.2.ebuild
+++ b/net-analyzer/fe3d/fe3d-0.11.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fe3d/fe3d-0.11.2.ebuild,v 1.1 2010/03/01 13:37:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fe3d/fe3d-0.11.2.ebuild,v 1.2 2010/06/29 15:05:59 ssuominen Exp $
-EAPI=1
+EAPI=2
WX_GTK_VER="2.8"
-inherit eutils wxwidgets
+inherit autotools eutils wxwidgets
if [[ "${PV}" =~ (_p)([0-9]+) ]] ; then
inherit subversion
@@ -34,8 +34,13 @@ pkg_setup() {
check_wxuse opengl
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS doc/{ChangeLog,README}.txt
}