summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-23 00:03:18 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-23 00:03:18 +0000
commit4ac31d55db3c1651cee56a0d81d3b4a14f21c58f (patch)
treebef3e5767cd9a56d539745cc15748e011b0038ec /net-analyzer/fping/fping-3.5.ebuild
parentFix Manifest. (diff)
downloadgentoo-2-4ac31d55db3c1651cee56a0d81d3b4a14f21c58f.tar.gz
gentoo-2-4ac31d55db3c1651cee56a0d81d3b4a14f21c58f.tar.bz2
gentoo-2-4ac31d55db3c1651cee56a0d81d3b4a14f21c58f.zip
Version bump.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-analyzer/fping/fping-3.5.ebuild')
-rw-r--r--net-analyzer/fping/fping-3.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/fping/fping-3.5.ebuild b/net-analyzer/fping/fping-3.5.ebuild
new file mode 100644
index 000000000000..4ad20fc271de
--- /dev/null
+++ b/net-analyzer/fping/fping-3.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/fping-3.5.ebuild,v 1.1 2013/05/23 00:03:18 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+HOMEPAGE="http://fping.org/"
+SRC_URI="http://fping.org/dist/${P}.tar.gz"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 suid"
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ if use suid ; then
+ fperms u+s /usr/sbin/fping
+ use ipv6 && fperms u+s /usr/sbin/fping6
+ fi
+}