summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-10-22 00:44:14 +0000
committerJeroen Roovers <jer@gentoo.org>2013-10-22 00:44:14 +0000
commit79827c7a0be57da8e2123846dbadae344ca82578 (patch)
tree4d91645b3ee379f68a3949c11234528b98c7baaa /net-analyzer/fping
parentUpdate all hardened musl arches to eapi 5 (diff)
downloadgentoo-2-79827c7a0be57da8e2123846dbadae344ca82578.tar.gz
gentoo-2-79827c7a0be57da8e2123846dbadae344ca82578.tar.bz2
gentoo-2-79827c7a0be57da8e2123846dbadae344ca82578.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/fping')
-rw-r--r--net-analyzer/fping/ChangeLog7
-rw-r--r--net-analyzer/fping/fping-3.6.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/net-analyzer/fping/ChangeLog b/net-analyzer/fping/ChangeLog
index 915a88fe9394..e9b041576dba 100644
--- a/net-analyzer/fping/ChangeLog
+++ b/net-analyzer/fping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/fping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.54 2013/05/23 00:03:18 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.55 2013/10/22 00:44:14 jer Exp $
+
+*fping-3.6 (22 Oct 2013)
+
+ 22 Oct 2013; Jeroen Roovers <jer@gentoo.org> +fping-3.6.ebuild:
+ Version bump.
*fping-3.5 (23 May 2013)
diff --git a/net-analyzer/fping/fping-3.6.ebuild b/net-analyzer/fping/fping-3.6.ebuild
new file mode 100644
index 000000000000..30227218a923
--- /dev/null
+++ b/net-analyzer/fping/fping-3.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/fping-3.6.ebuild,v 1.1 2013/10/22 00:44:14 jer Exp $
+
+EAPI=5
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+HOMEPAGE="http://fping.org/"
+SRC_URI="http://fping.org/dist/${P}.tar.gz"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 suid"
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ if use suid ; then
+ fperms u+s /usr/sbin/fping
+ use ipv6 && fperms u+s /usr/sbin/fping6
+ fi
+}