summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-17 22:28:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-17 22:28:54 +0000
commit630e8f1be2a35475651f2331798ffcdc1f9ce8cf (patch)
tree8164255a0f460643176de16f2e9acf5ea8a9fe5c /net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild
parentNew version for GNOME 2.26. Bug fixes and translation updates. (diff)
downloadgentoo-2-630e8f1be2a35475651f2331798ffcdc1f9ce8cf.tar.gz
gentoo-2-630e8f1be2a35475651f2331798ffcdc1f9ce8cf.tar.bz2
gentoo-2-630e8f1be2a35475651f2331798ffcdc1f9ce8cf.zip
New version for GNOME 2.26. Drop libgnome. Clean up old revisions.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild')
-rw-r--r--net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild b/net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild
new file mode 100644
index 000000000000..bd2ccc59da3d
--- /dev/null
+++ b/net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild,v 1.1 2009/05/17 22:28:54 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Network interface information applet"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.14
+ >=dev-libs/glib-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/gconf-2"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --disable-scrollkeeper"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix interface listing on all (known) arches; bug #183969
+ epatch "${FILESDIR}"/${PN}-2.12.1-fix-iflist.patch
+}