summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-11-13 23:11:41 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-11-13 23:11:41 +0000
commit391a81a9145dc643c2516e530ba55879e06a0b1c (patch)
tree3f32a4ff2ac524c35639a167844c3120198561f0 /net-analyzer/hping/hping-3_pre20051105.ebuild
parentVersion bump for trac-0.10*. (diff)
downloadgentoo-2-391a81a9145dc643c2516e530ba55879e06a0b1c.tar.gz
gentoo-2-391a81a9145dc643c2516e530ba55879e06a0b1c.tar.bz2
gentoo-2-391a81a9145dc643c2516e530ba55879e06a0b1c.zip
Version bump thanks to Robert Buchholz
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'net-analyzer/hping/hping-3_pre20051105.ebuild')
-rw-r--r--net-analyzer/hping/hping-3_pre20051105.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/hping/hping-3_pre20051105.ebuild b/net-analyzer/hping/hping-3_pre20051105.ebuild
new file mode 100644
index 000000000000..d4da27f5107c
--- /dev/null
+++ b/net-analyzer/hping/hping-3_pre20051105.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105.ebuild,v 1.1 2006/11/13 23:11:41 jokey Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}${PV//_pre/-}"
+DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer"
+HOMEPAGE="http://www.hping.org"
+SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tcl debug"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="net-libs/libpcap
+ tcl? ( dev-lang/tcl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${P}.patch
+
+ # Correct hard coded values
+ sed -i "9s:gcc:$(tc-getCC):" Makefile.in
+ sed -i "10s:/usr/bin/ar:$(tc-getAR):" Makefile.in
+ sed -i "11s:/usr/bin/ranlib:$(tc-getRANLIB):" Makefile.in
+ sed -i "12s:-O2:${CFLAGS}:" Makefile.in
+}
+
+src_compile() {
+
+ myconf=""
+ use tcltk || myconf="--no-tcl"
+ econf ${myconf} || die "configure failed"
+
+ if use debug; then
+ emake || die "make failed"
+ else
+ emake DEBUG="" || die "make failed"
+ fi
+}
+
+src_install () {
+ dosbin hping3
+ dosym /usr/sbin/hping3 /usr/sbin/hping
+ dosym /usr/sbin/hping3 /usr/sbin/hping2
+
+ doman docs/hping3.8
+
+ dodoc INSTALL NEWS README TODO AUTHORS BUGS CHANGES
+}