summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-09 16:53:31 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-09 16:53:31 +0000
commitd7a1e4dc9b39f646b99493fcc820bb260b638c41 (patch)
tree123b919e4d7c9ff3396be05b9063570c58771701 /net-analyzer/hunt
parentDrop all prefix stuff as well because the ebuild was reverted to EAPI2 (diff)
downloadgentoo-2-d7a1e4dc9b39f646b99493fcc820bb260b638c41.tar.gz
gentoo-2-d7a1e4dc9b39f646b99493fcc820bb260b638c41.tar.bz2
gentoo-2-d7a1e4dc9b39f646b99493fcc820bb260b638c41.zip
Respect LDFLAGS (bug #336094), CFLAGS, CC.
(Portage version: 2.2_rc77/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/hunt')
-rw-r--r--net-analyzer/hunt/ChangeLog9
-rw-r--r--net-analyzer/hunt/hunt-1.5-r1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/net-analyzer/hunt/ChangeLog b/net-analyzer/hunt/ChangeLog
index d2279b50ff8e..5c62f9422393 100644
--- a/net-analyzer/hunt/ChangeLog
+++ b/net-analyzer/hunt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/hunt
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hunt/ChangeLog,v 1.8 2009/09/23 18:19:17 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hunt/ChangeLog,v 1.9 2010/09/09 16:53:31 jer Exp $
+
+*hunt-1.5-r1 (09 Sep 2010)
+
+ 09 Sep 2010; Jeroen Roovers <jer@gentoo.org> +hunt-1.5-r1.ebuild:
+ Respect LDFLAGS (bug #336094), CFLAGS, CC.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> hunt-1.5.ebuild:
Remove virtual/libc
diff --git a/net-analyzer/hunt/hunt-1.5-r1.ebuild b/net-analyzer/hunt/hunt-1.5-r1.ebuild
new file mode 100644
index 000000000000..534b1967f3a2
--- /dev/null
+++ b/net-analyzer/hunt/hunt-1.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hunt/hunt-1.5-r1.ebuild,v 1.1 2010/09/09 16:53:31 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="tool for checking well known weaknesses in the TCP/IP protocol"
+HOMEPAGE="http://lin.fsid.cvut.cz/~kra/index.html"
+SRC_URI="http://lin.fsid.cvut.cz/~kra/hunt/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+cp -av Makefile{,.orig}
+ sed -i Makefile \
+ -e 's:^CFLAGS=:CFLAGS += -I.:g' \
+ -e '/^LDFLAGS=/d' \
+ -e 's:${LDFLAGS}:$(LDFLAGS):g' \
+ -e 's:-O2 -g::' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake"
+}
+
+src_install() {
+ dobin hunt
+ doman man/hunt.1
+ dodoc CHANGES README* TODO tpsetup/transproxy
+}