summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-06-24 08:28:16 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-06-24 08:28:16 +0000
commit2255e4fc311ab4bff437c1bf7e7688ebf79c4431 (patch)
tree446da1bc1a28a89330a70628a82cc1f29de90706 /net-analyzer/ike-scan/ike-scan-1.7.ebuild
parentStable on x86. (diff)
downloadgentoo-2-2255e4fc311ab4bff437c1bf7e7688ebf79c4431.tar.gz
gentoo-2-2255e4fc311ab4bff437c1bf7e7688ebf79c4431.tar.bz2
gentoo-2-2255e4fc311ab4bff437c1bf7e7688ebf79c4431.zip
Initial import as per bug #83454
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-analyzer/ike-scan/ike-scan-1.7.ebuild')
-rw-r--r--net-analyzer/ike-scan/ike-scan-1.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-analyzer/ike-scan/ike-scan-1.7.ebuild b/net-analyzer/ike-scan/ike-scan-1.7.ebuild
new file mode 100644
index 000000000000..514d416e95e7
--- /dev/null
+++ b/net-analyzer/ike-scan/ike-scan-1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ike-scan/ike-scan-1.7.ebuild,v 1.1 2005/06/24 08:28:16 dragonheart Exp $
+
+DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
+HOMEPAGE="http://www.nta-monitor.com/ike-scan/"
+SRC_URI="http://www.nta-monitor.com/ike-scan/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl"
+
+DEPEND="virtual/libc
+ ssl? dev-libs/openssl"
+
+src_compile() {
+ econf $(use_with ssl openssl) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc ChangeLog NEWS INSTALL README TODO
+ dodoc udp-backoff-fingerprinting-paper.txt
+}