summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-01-12 08:14:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-01-12 08:14:41 +0000
commit78c73008ae040b0800a5df4e309de23f6c4e8cc2 (patch)
tree6a4e6342d2daee2b66e17e87173375055d47324c /net-analyzer/metasploit
parentfix PLAIN and LOGIN with no auxprop - bug #392761 (diff)
downloadgentoo-2-78c73008ae040b0800a5df4e309de23f6c4e8cc2.tar.gz
gentoo-2-78c73008ae040b0800a5df4e309de23f6c4e8cc2.tar.bz2
gentoo-2-78c73008ae040b0800a5df4e309de23f6c4e8cc2.zip
Bump
(Portage version: 2.2.0_alpha83/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/metasploit')
-rw-r--r--net-analyzer/metasploit/ChangeLog10
-rw-r--r--net-analyzer/metasploit/files/msfrpcd-4.1-conf25
-rw-r--r--net-analyzer/metasploit/files/msfrpcd-4.1-initd22
-rw-r--r--net-analyzer/metasploit/metasploit-4.1.4.ebuild93
4 files changed, 148 insertions, 2 deletions
diff --git a/net-analyzer/metasploit/ChangeLog b/net-analyzer/metasploit/ChangeLog
index 3ab3a8e83bfb..3fc6c4e912e4 100644
--- a/net-analyzer/metasploit/ChangeLog
+++ b/net-analyzer/metasploit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/metasploit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.57 2011/08/04 22:03:37 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.58 2012/01/12 08:14:41 patrick Exp $
+
+*metasploit-4.1.4 (12 Jan 2012)
+
+ 12 Jan 2012; Patrick Lauer <patrick@gentoo.org> +files/msfrpcd-4.1-conf,
+ +files/msfrpcd-4.1-initd, +metasploit-4.1.4.ebuild:
+ Bump
*metasploit-4.0.0-r1 (04 Aug 2011)
diff --git a/net-analyzer/metasploit/files/msfrpcd-4.1-conf b/net-analyzer/metasploit/files/msfrpcd-4.1-conf
new file mode 100644
index 000000000000..dc56a9d966a6
--- /dev/null
+++ b/net-analyzer/metasploit/files/msfrpcd-4.1-conf
@@ -0,0 +1,25 @@
+# Config file for /etc/init.d/msfrpcd
+
+# msfrpcd -h for more info
+
+# Bind to the following IP instead of 0.0.0.0
+MSF_OPTS="-a 127.0.0.1"
+
+# Bind to the following TCP port instead of default 55553
+#MSF_OPTS="${MSF_OPTS} -p 55553"
+
+# Specify the username to access msfrpcd
+MSF_OPTS="${MSF_OPTS} -U msf"
+
+# Specify the password to access msfrpcd
+MSF_OPTS="${MSF_OPTS} -P secret"
+
+# Server type, [Basic|Web]
+#MSF_OPTS="${MSF_OPTS} -t Basic"
+
+# URI for Web server
+#MSF_OPTS="${MSF_OPTS} -u "
+
+# Disable SSL on the XMLRPC socket
+# JAVA GUI doesn't support SSL as of Nov 6, 2010
+MSF_OPTS="${MSF_OPTS} -S"
diff --git a/net-analyzer/metasploit/files/msfrpcd-4.1-initd b/net-analyzer/metasploit/files/msfrpcd-4.1-initd
new file mode 100644
index 000000000000..7527d9c7cf78
--- /dev/null
+++ b/net-analyzer/metasploit/files/msfrpcd-4.1-initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/files/msfrpcd-4.1-initd,v 1.1 2012/01/12 08:14:41 patrick Exp $
+
+VERSION=4.0
+PIDFILE=/var/run/msfrpcd${VERSION}.pid
+
+start() {
+ ebegin "Starting msfrpcd${VERSION}"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/lib/metasploit${VERSION}/msfrpcd \
+ --pidfile ${PIDFILE} \
+ --make-pidfile -- -f ${MSF_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping msfrpcd${VERSION}"
+ start-stop-daemon --stop --quiet -s 9 --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/net-analyzer/metasploit/metasploit-4.1.4.ebuild b/net-analyzer/metasploit/metasploit-4.1.4.ebuild
new file mode 100644
index 000000000000..906d4bf17bc9
--- /dev/null
+++ b/net-analyzer/metasploit/metasploit-4.1.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-4.1.4.ebuild,v 1.1 2012/01/12 08:14:41 patrick Exp $
+
+EAPI="3"
+inherit eutils
+
+#SRC_URI="http://updates.metasploit.com/data/releases/framework-${PV}.tar.bz2"
+# Naughty upstream ... no versioning at the moment
+SRC_URI="http://downloads.metasploit.com/data/releases/framework-latest.tar.bz2"
+
+DESCRIPTION="Advanced open-source framework for developing, testing, and using vulnerability exploit code"
+HOMEPAGE="http://www.metasploit.org/"
+
+LICENSE="BSD"
+SLOT="4.1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gui mysql postgres"
+
+# Note we use bundled gems (see data/msfweb/vendor/rails/) as upstream voted for
+# such solution, bug #247787
+RDEPEND="dev-lang/ruby
+ dev-ruby/rubygems
+ gui? ( virtual/jre )
+ mysql? ( dev-ruby/mysql-ruby
+ dev-ruby/activerecord[mysql] )
+ postgres? ( dev-ruby/ruby-postgres
+ dev-ruby/activerecord[postgres] )"
+DEPEND=""
+
+QA_PRESTRIPPED="
+ usr/lib/${PN}${SLOT}/data/msflinker_linux_x86.bin
+ usr/lib/${PN}${SLOT}/data/templates/template_armle_linux.bin
+ usr/lib/${PN}${SLOT}/data/templates/template_x86_linux.bin"
+
+QA_EXECSTACK="
+ usr/lib/${PN}${SLOT}/data/meterpreter/msflinker_linux_x86.bin"
+QA_WX_LOAD="
+ usr/lib/${PN}${SLOT}/data/templates/template_*_linux.bin"
+
+S=${WORKDIR}/msf
+
+src_configure() {
+ # upstream makes weird tarbllz
+ find "${S}" -type d -name ".svn" -print0 | xargs -0 -n1 rm -R
+
+ rm "${S}"/msfupdate
+ chmod +x "${S}"/msf*
+
+ use gui || rm msfgui
+}
+
+src_install() {
+ # should be as simple as copying everything into the target...
+ dodir /usr/lib/${PN}${SLOT}
+ cp -R "${S}"/* "${D}"/usr/lib/${PN}${SLOT}
+ chown -R root:0 "${D}"
+
+ # do not remove LICENSE, bug #238137
+ dodir /usr/share/doc/${PF}
+ cp "${S}"/{README,HACKING} "${D}"/usr/share/doc/${PF}
+ dosym /usr/lib/${PN}${SLOT}/documentation /usr/share/doc/${PF}/documentation
+
+ dodir /usr/bin/
+ for file in msf*; do
+ dosym /usr/lib/${PN}${SLOT}/${file} /usr/bin/${file}${SLOT}
+ done
+
+ newinitd "${FILESDIR}"/msfrpcd-${SLOT}-initd msfrpcd${SLOT} || die
+ newconfd "${FILESDIR}"/msfrpcd-${SLOT}-conf msfrpcd${SLOT} || die
+
+ use gui && make_desktop_entry msfgui${SLOT} \
+ "Metasploit Framework" \
+ metasploit \
+ 'GNOME;System;Network;' &&
+ doicon "${FILESDIR}"/metasploit.xpm
+
+ # Avoid useless revdep-rebuild trigger #377617
+ dodir /etc/revdep-rebuild/
+ echo "SEARCH_DIRS_MASK=\"/usr/lib*/${PN}${SLOT}/data/john\"" > \
+ ${D}/etc/revdep-rebuild/70-${PN}-${SLOT}
+}
+
+pkg_postinst() {
+ if use gui; then
+ elog "You will need to create a /usr/bin/msfrpcd symlink pointing to"
+ elog "the version of msfrpcd if you want to be able to start msfrpcd"
+ elog "from the java gui."
+ elog
+ elog "ln /usr/bin/msfrpcd${SLOT} /usr/bin/msfrpcd"
+ elog
+ fi
+}