summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-01-30 23:47:09 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-01-30 23:47:09 +0000
commit867f1d4cb0e9f3980eea14dba85bd0ba45fff971 (patch)
tree26127f01471c6db19dfc6a89754fc08571acff82 /net-analyzer/mk-livestatus
parentfix copyright (diff)
downloadgentoo-2-867f1d4cb0e9f3980eea14dba85bd0ba45fff971.tar.gz
gentoo-2-867f1d4cb0e9f3980eea14dba85bd0ba45fff971.tar.bz2
gentoo-2-867f1d4cb0e9f3980eea14dba85bd0ba45fff971.zip
Initial commit for net-analyzer/mk-livestatus
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/mk-livestatus')
-rw-r--r--net-analyzer/mk-livestatus/ChangeLog10
-rw-r--r--net-analyzer/mk-livestatus/metadata.xml9
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild107
3 files changed, 126 insertions, 0 deletions
diff --git a/net-analyzer/mk-livestatus/ChangeLog b/net-analyzer/mk-livestatus/ChangeLog
new file mode 100644
index 000000000000..7dd7131e3407
--- /dev/null
+++ b/net-analyzer/mk-livestatus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/mk-livestatus
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/ChangeLog,v 1.1 2011/01/30 23:47:09 idl0r Exp $
+
+*mk-livestatus-1.1.8 (30 Jan 2011)
+
+ 30 Jan 2011; Christian Ruppert <idl0r@gentoo.org>
+ +mk-livestatus-1.1.8.ebuild, +metadata.xml:
+ Initial commit for net-analyzer/mk-livestatus
+
diff --git a/net-analyzer/mk-livestatus/metadata.xml b/net-analyzer/mk-livestatus/metadata.xml
new file mode 100644
index 000000000000..ea6573a9fbf4
--- /dev/null
+++ b/net-analyzer/mk-livestatus/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild
new file mode 100644
index 000000000000..4bc65ccb24b8
--- /dev/null
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild,v 1.1 2011/01/30 23:47:09 idl0r Exp $
+
+EAPI=3
+
+GENTOO_DEPEND_ON_PERL=no
+PERL_EXPORT_PHASE_FUNCTIONS=no
+
+inherit perl-module python
+
+DESCRIPTION="Nagios/Icinga event broker module that allows quick/direct access to your status data"
+HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
+SRC_URI="http://mathias-kettner.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples perl python test"
+
+RDEPEND="perl? (
+ dev-lang/perl
+ virtual/perl-Digest-MD5
+ dev-perl/Thread-Queue
+ )"
+DEPEND="${RDEPEND}
+ perl? (
+ dev-perl/Module-Install
+ test? (
+ dev-perl/File-Copy-Recursive
+ dev-perl/Test-Pod
+ dev-perl/Test-Perl-Critic
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Perl-Critic
+ dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect
+ dev-perl/Perl-Critic-Deprecated
+ dev-perl/Perl-Critic-Nits
+ )
+ )"
+
+# For perl test
+SRC_TEST="parallel"
+
+src_prepare() {
+ # Use system Module::Install instead, it will be copied to $WORKDIR by
+ # Module::install itself.
+ rm -rf api/perl/inc
+
+ if use perl; then
+ perl-module_src_prepare
+ fi
+
+ sed -i -e 's:$(LDFLAGS) -s:$(LDFLAGS):' src/Makefile.in || die
+}
+
+src_configure() {
+ econf
+
+ if use perl; then
+ cd api/perl/
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ emake || die
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ if use perl; then
+ cd api/perl
+
+ export TEST_AUTHOR="Test Author"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ emake -C src/ DESTDIR="${D}" install-binPROGRAMS install-data-local || die
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_install
+ cd "${S}"
+
+ if use examples; then
+ docinto examples/
+ dodoc api/perl/examples/dump.pl || die
+ fi
+ fi
+ if use python; then
+ insinto $(python_get_sitedir)
+ doins api/python/livestatus.py || die
+
+ if use examples; then
+ newdoc api/python/README README.python || die
+
+ docinto examples/
+ dodoc api/python/{example,example_multisite,make_nagvis_map}.py || die
+ fi
+ fi
+}