summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-11-09 17:57:07 +0000
committerPeter Volkov <pva@gentoo.org>2010-11-09 17:57:07 +0000
commitcfe63e9f9ce877a1f300014e08a7ba83c4ba847a (patch)
tree48764da6e62d00ce140e41e1e99498b7a8468e2b /net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild
parentNew package: sci-mathematics/topcom, revised import from sci overlay, fixes b... (diff)
downloadgentoo-2-cfe63e9f9ce877a1f300014e08a7ba83c4ba847a.tar.gz
gentoo-2-cfe63e9f9ce877a1f300014e08a7ba83c4ba847a.tar.bz2
gentoo-2-cfe63e9f9ce877a1f300014e08a7ba83c4ba847a.zip
Fix static linkage and rpath, bug #332287, thank Diego Elio Pettenò for report.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild')
-rw-r--r--net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild b/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild
new file mode 100644
index 000000000000..5b0ffe042bb7
--- /dev/null
+++ b/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mrtg/mrtg-2.16.4-r1.ebuild,v 1.1 2010/11/09 17:57:07 pva Exp $
+
+EAPI="3"
+
+inherit eutils autotools
+
+DESCRIPTION="A tool to monitor the traffic load on network-links"
+HOMEPAGE="http://oss.oetiker.ch/mrtg/"
+SRC_URI="http://oss.oetiker.ch/mrtg/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/SNMP_Session
+ >=dev-perl/Socket6-0.20
+ >=media-libs/gd-1.8.4"
+
+src_prepare() {
+ epatch ${FILESDIR}/${P}-disable-static.patch
+ epatch ${FILESDIR}/${P}-no-rpath.patch
+ rm ./lib/mrtg2/{SNMP_{Session,util},BER}.pm || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install () {
+ keepdir /var/lib/mrtg
+
+ emake DESTDIR="${ED}" install || die "emake install failed"
+ mv "${ED}/usr/share/doc/"{mrtg2,${PF}}
+
+ newinitd "${FILESDIR}/mrtg.rc" ${PN} || die
+ newconfd "${FILESDIR}/mrtg.confd" ${PN} || die
+}
+
+pkg_postinst(){
+ elog "You must configure mrtg before being able to run it. Try cfgmaker."
+ elog "The following thread may be useful:"
+ elog "http://forums.gentoo.org/viewtopic-t-105862.html"
+}