summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Boman <mboman@gentoo.org>2004-03-21 12:51:38 +0000
committerMichael Boman <mboman@gentoo.org>2004-03-21 12:51:38 +0000
commitc66cabd404dca1284e538be7caebe1f22019e1b8 (patch)
treeff81ca0e02c937414d4fe3a5c2a6a97863fe06aa /net-analyzer/nagios-core
parentQA: IUSE variable was missing, unnecessary definition of S removed. (Manifest... (diff)
downloadgentoo-2-c66cabd404dca1284e538be7caebe1f22019e1b8.tar.gz
gentoo-2-c66cabd404dca1284e538be7caebe1f22019e1b8.tar.bz2
gentoo-2-c66cabd404dca1284e538be7caebe1f22019e1b8.zip
QA: IUSE variable was incorrect, set propper USE flags tests.
Diffstat (limited to 'net-analyzer/nagios-core')
-rw-r--r--net-analyzer/nagios-core/ChangeLog6
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild22
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild4
3 files changed, 19 insertions, 13 deletions
diff --git a/net-analyzer/nagios-core/ChangeLog b/net-analyzer/nagios-core/ChangeLog
index 3353a54c21a2..a7defc332962 100644
--- a/net-analyzer/nagios-core/ChangeLog
+++ b/net-analyzer/nagios-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nagios-core
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.21 2004/03/19 09:44:52 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.22 2004/03/21 12:51:38 mboman Exp $
+
+ 21 Mar 2004; Michael Boman <mboman@gentoo.org> nagios-core-1.1-r4.ebuild,
+ nagios-core-1.1-r5.ebuild:
+ QA: IUSE variable was incorrect, set propper USE flags tests.
*nagios-core-1.2 (27 Feb 2004)
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
index 4c883a1ed6f7..0efbe2ebace4 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.9 2004/03/10 19:10:06 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.10 2004/03/21 12:51:38 mboman Exp $
inherit eutils
@@ -13,7 +13,7 @@ RESTRICT="nomirror"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~ppc ~amd64"
-IUSE="gd apache2 perl"
+IUSE="gd apache2 perl mysql postgres debug"
DEPEND=">=net-mail/mailx-8.1
apache2? ( >=net-www/apache-2.0.43-r1 )
@@ -24,7 +24,7 @@ DEPEND=">=net-mail/mailx-8.1
)
perl? ( >=perl-5.6.1-r7 )
mysql? ( >=dev-db/mysql-3.23.56 )
- pgsql? ( >=dev-db/postgresql-7.3.2 )"
+ postgres? ( >=dev-db/postgresql-7.3.2 )"
S="${WORKDIR}/${MY_P}"
@@ -47,18 +47,20 @@ src_compile() {
--with-mysql-status --with-mysql-comments --with-mysql-extinfo \
--with-mysql-retention --with-mysql-downtime"
- use pgsql && myconf="${myconf} --with-pgsql-xdata \
+ use postgres && myconf="${myconf} --with-pgsql-xdata \
--with-pgsql-status --with-pgsql-comments --with-pgsql-extinfo \
--with-pgsql-retention --with-pgsql-downtime"
use perl && myconf="${myconf} --enable-embedded-perl --with-perlcache"
- use debug0 && myconf="${myconf} --enable-DEBUG0"
- use debug1 && myconf="${myconf} --enable-DEBUG1"
- use debug2 && myconf="${myconf} --enable-DEBUG2"
- use debug3 && myconf="${myconf} --enable-DEBUG3"
- use debug4 && myconf="${myconf} --enable-DEBUG4"
- use debug5 && myconf="${myconf} --enable-DEBUG5"
+ if [ -n "`use debug`" ]; then
+ myconf="${myconf} --enable-DEBUG0"
+ myconf="${myconf} --enable-DEBUG1"
+ myconf="${myconf} --enable-DEBUG2"
+ myconf="${myconf} --enable-DEBUG3"
+ myconf="${myconf} --enable-DEBUG4"
+ myconf="${myconf} --enable-DEBUG5"
+ fi
./configure ${myconf} \
--host=${CHOST} \
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
index 706ebb252235..98ddd5d7117a 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.3 2004/03/10 19:10:06 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.4 2004/03/21 12:51:38 mboman Exp $
inherit eutils
@@ -27,7 +27,7 @@ DEPEND=">=net-mail/mailx-8.1
perl? ( >=dev-lang/perl-5.6.1-r7 )
mysql? ( >=dev-db/mysql-3.23.56 )
- pgsql? ( >=dev-db/postgresql-7.3.2 )"
+ postgres? ( >=dev-db/postgresql-7.3.2 )"
S="${WORKDIR}/${MY_P}"