summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2002-11-02 05:55:41 +0000
committerDean Bailey <alron@gentoo.org>2002-11-02 05:55:41 +0000
commit9311de520dfdc0ab8a7f3324aa8502a3e59617ce (patch)
tree3f7fc27c65302d47c04f8c428f0a1997e61549d7 /net-analyzer/nagios-nsca
parentnew package - calcoo: a good scientific calculator, supports RPN (diff)
downloadgentoo-2-9311de520dfdc0ab8a7f3324aa8502a3e59617ce.tar.gz
gentoo-2-9311de520dfdc0ab8a7f3324aa8502a3e59617ce.tar.bz2
gentoo-2-9311de520dfdc0ab8a7f3324aa8502a3e59617ce.zip
Nagios in full.
Diffstat (limited to 'net-analyzer/nagios-nsca')
-rw-r--r--net-analyzer/nagios-nsca/ChangeLog7
-rw-r--r--net-analyzer/nagios-nsca/files/digest-nagios-nsca-2.11
-rw-r--r--net-analyzer/nagios-nsca/files/nsca27
-rw-r--r--net-analyzer/nagios-nsca/files/nsca.cfg182
-rw-r--r--net-analyzer/nagios-nsca/files/send_nsca.cfg63
-rw-r--r--net-analyzer/nagios-nsca/nagios-nsca-2.1.ebuild47
6 files changed, 327 insertions, 0 deletions
diff --git a/net-analyzer/nagios-nsca/ChangeLog b/net-analyzer/nagios-nsca/ChangeLog
new file mode 100644
index 000000000000..18cf5c28912f
--- /dev/null
+++ b/net-analyzer/nagios-nsca/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-analyzer/nagios-nsca
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-nsca/ChangeLog,v 1.1 2002/11/02 05:55:41 alron Exp $
+
+*nagios-nsca-2.1 (1 Nov 2002)
+ 1 Nov 2002; Dean Bailey <alron@gentoo.org> nagios-nsca-2.1 :
+ Initial import. Ebuild submitted by Dean Bailey <alron@gentoo.org>.
diff --git a/net-analyzer/nagios-nsca/files/digest-nagios-nsca-2.1 b/net-analyzer/nagios-nsca/files/digest-nagios-nsca-2.1
new file mode 100644
index 000000000000..604f1807665a
--- /dev/null
+++ b/net-analyzer/nagios-nsca/files/digest-nagios-nsca-2.1
@@ -0,0 +1 @@
+MD5 a7886852eb11b6a018fff6990075db1e nsca-2.1.tar.gz 51897
diff --git a/net-analyzer/nagios-nsca/files/nsca b/net-analyzer/nagios-nsca/files/nsca
new file mode 100644
index 000000000000..d81c4a1b8b2a
--- /dev/null
+++ b/net-analyzer/nagios-nsca/files/nsca
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting nsca"
+ start-stop-daemon --start --quiet --name nsca \
+ --startas /usr/nagios/bin/nsca \
+ -c nagios:nagios \
+ -- -d /etc/nagios/nsca.cfg
+ eend $? "Failed to Start nsca"
+}
+
+stop() {
+ ebegin "Stopping nsca"
+ start-stop-daemon --stop --quiet -n nsca
+ eend $? "Failed to Stop nsca"
+}
+
+restart() {
+ ebegin "Restarting nsca"
+ svc_stop
+ svc_start
+ eend $? "Failed to Restart nsca"
+}
diff --git a/net-analyzer/nagios-nsca/files/nsca.cfg b/net-analyzer/nagios-nsca/files/nsca.cfg
new file mode 100644
index 000000000000..e7e0402af2b6
--- /dev/null
+++ b/net-analyzer/nagios-nsca/files/nsca.cfg
@@ -0,0 +1,182 @@
+####################################################
+# Sample NSCA Daemon Config File
+# Written by: Ethan Galstad (nagios@nagios.org)
+#
+# Last Modified: 06-10-2002
+####################################################
+
+
+
+# PORT NUMBER
+# Port number we should wait for connections on.
+# This must be a non-priveledged port (i.e. > 1024).
+
+server_port=5667
+
+
+
+# SERVER ADDRESS
+# Address that nrpe has to bind to in case there are
+# more as one interface and we do not want nrpe to bind
+# (thus listen) on all interfaces.
+
+#server_address=192.168.1.1
+
+
+
+# ALLOWED HOST ADDRESSES
+# This is a comma-delimited list of IP address of hosts that are allowed
+# to talk to the NSCA daemon.
+#
+# Note: The daemon only does rudimentary checking of the client's IP
+# address. I would highly recommend running as a service under
+# inetd instead of as a standalone daemon and using TCP wrappers to
+# limit access.
+
+allowed_hosts=127.0.0.1
+
+
+
+# NSCA USER
+# This determines the effective user that the NSCA daemon should run as.
+# You can either supply a username or a UID.
+#
+# NOTE: This option is ignored if NSCA is running under either inetd or xinetd
+
+nsca_user=nagios
+
+
+
+# NSCA GROUP
+# This determines the effective group that the NSCA daemon should run as.
+# You can either supply a group name or a GID.
+#
+# NOTE: This option is ignored if NSCA is running under either inetd or xinetd
+
+nsca_group=nagios
+
+
+
+# DEBUGGING OPTION
+# This option determines whether or not debugging
+# messages are logged to the syslog facility.
+# Values: 0 = debugging off, 1 = debugging on
+
+debug=0
+
+
+
+# COMMAND FILE
+# This is the location of the Nagios command file that the daemon
+# should write all service check results that it receives.
+
+command_file=/var/nagios/rw/nagios.cmd
+
+
+# ALTERNATE DUMP FILE
+# This is used to specify an alternate file the daemon should
+# write service check results to in the event the command file
+# does not exist. It is important to note that the command file
+# is implemented as a named pipe and only exists when Nagios is
+# running. You may want to modify the startup script for Nagios
+# to dump the contents of this file into the command file after
+# it starts Nagios. Or you may simply choose to ignore any
+# check results received while Nagios was not running...
+
+alternate_dump_file=/var/nagios/rw/nsca.dump
+
+
+
+# AGGREGATED WRITES OPTION
+# This option determines whether or not the nsca daemon will
+# aggregate writes to the external command file for client
+# connections that contain multiple check results. If you
+# are queueing service check results on remote hosts and
+# sending them to the nsca daemon in bulk, you will probably
+# want to enable bulk writes, as this will be a bit more
+# efficient.
+# Values: 0 = do not aggregate writes, 1 = aggregate writes
+
+aggregate_writes=0
+
+
+
+# APPEND TO FILE OPTION
+# This option determines whether or not the nsca daemon will
+# will open the external command file for writing or appending.
+# This option should almost *always* be set to 0!
+# Values: 0 = open file for writing, 1 = open file for appending
+
+append_to_file=0
+
+
+
+# MAX PACKET AGE OPTION
+# This option is used by the nsca daemon to determine when client
+# data is too old to be valid. Keeping this value as small as
+# possible is recommended, as it helps prevent the possibility of
+# "replay" attacks. This value needs to be at least as long as
+# the time it takes your clients to send their data to the server.
+# Values are in seconds. The max packet age cannot exceed 15
+# minutes (900 seconds).
+
+max_packet_age=30
+
+
+
+# DECRYPTION PASSWORD
+# This is the password/passphrase that should be used to descrypt the
+# incoming packets. Note that all clients must encrypt the packets
+# they send using the same password!
+# IMPORTANT: You don't want all the users on this system to be able
+# to read the password you specify here, so make sure to set
+# restrictive permissions on this config file!
+
+#password=
+
+
+
+# DECRYPTION METHOD
+# This option determines the method by which the nsca daemon will
+# decrypt the packets it receives from the clients. The decryption
+# method you choose will be a balance between security and performance,
+# as strong encryption methods consume more processor resources.
+# You should evaluate your security needs when choosing a decryption
+# method.
+#
+# Note: The decryption method you specify here must match the
+# encryption method the nsca clients use (as specified in
+# the send_nsca.cfg file)!!
+# Values:
+#
+# 0 = None (Do NOT use this option)
+# 1 = Simple XOR (No security, just obfuscation, but very fast)
+#
+# 2 = DES
+# 3 = 3DES (Triple DES)
+# 4 = CAST-128
+# 5 = CAST-256
+# 6 = xTEA
+# 7 = 3WAY
+# 8 = BLOWFISH
+# 9 = TWOFISH
+# 10 = LOKI97
+# 11 = RC2
+# 12 = ARCFOUR
+#
+# 14 = RIJNDAEL-128
+# 15 = RIJNDAEL-192
+# 16 = RIJNDAEL-256
+#
+# 19 = WAKE
+# 20 = SERPENT
+#
+# 22 = ENIGMA (Unix crypt)
+# 23 = GOST
+# 24 = SAFER64
+# 25 = SAFER128
+# 26 = SAFER+
+#
+
+decryption_method=1
+
diff --git a/net-analyzer/nagios-nsca/files/send_nsca.cfg b/net-analyzer/nagios-nsca/files/send_nsca.cfg
new file mode 100644
index 000000000000..60196c049fd6
--- /dev/null
+++ b/net-analyzer/nagios-nsca/files/send_nsca.cfg
@@ -0,0 +1,63 @@
+####################################################
+# Sample NSCA Client Config File
+# Written by: Ethan Galstad (nagios@nagios.org)
+#
+# Last Modified: 02-21-2002
+####################################################
+
+
+# ENCRYPTION PASSWORD
+# This is the password/passphrase that should be used to encrypt the
+# outgoing packets. Note that the nsca daemon must use the same
+# password when decrypting the packet!
+# IMPORTANT: You don't want all the users on this system to be able
+# to read the password you specify here, so make sure to set
+# restrictive permissions on this config file!
+
+#password=
+
+
+
+# ENCRYPTION METHOD
+# This option determines the method by which the send_nsca client will
+# encrypt the packets it sends to the nsca daemon. The encryption
+# method you choose will be a balance between security and performance,
+# as strong encryption methods consume more processor resources.
+# You should evaluate your security needs when choosing an encryption
+# method.
+#
+# Note: The encryption method you specify here must match the
+# decryption method the nsca daemon uses (as specified in
+# the nsca.cfg file)!!
+# Values:
+# 0 = None (Do NOT use this option)
+# 1 = Simple XOR (No security, just obfuscation, but very fast)
+#
+# 2 = DES
+# 3 = 3DES (Triple DES)
+# 4 = CAST-128
+# 5 = CAST-256
+# 6 = xTEA
+# 7 = 3WAY
+# 8 = BLOWFISH
+# 9 = TWOFISH
+# 10 = LOKI97
+# 11 = RC2
+# 12 = ARCFOUR
+#
+# 14 = RIJNDAEL-128
+# 15 = RIJNDAEL-192
+# 16 = RIJNDAEL-256
+#
+# 19 = WAKE
+# 20 = SERPENT
+#
+# 22 = ENIGMA (Unix crypt)
+# 23 = GOST
+# 24 = SAFER64
+# 25 = SAFER128
+# 26 = SAFER+
+#
+
+encryption_method=1
+
diff --git a/net-analyzer/nagios-nsca/nagios-nsca-2.1.ebuild b/net-analyzer/nagios-nsca/nagios-nsca-2.1.ebuild
new file mode 100644
index 000000000000..96d95fac9e2e
--- /dev/null
+++ b/net-analyzer/nagios-nsca/nagios-nsca-2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-nsca/nagios-nsca-2.1.ebuild,v 1.1 2002/11/02 05:55:41 alron Exp $
+DESCRIPTION="Nagios $PV NSCA - Nagios Service Check Acceptor"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/nagios/nsca-2.1.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=net-analyzer/nagios-plugins-1.3_beta1
+ >=libmcrypt-2.5.1-r4"
+S="${WORKDIR}/nsca-2.1"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --with-nsca-user=nagios \
+ --with-nsca-grp=nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake all || die
+}
+
+src_install() {
+ dodoc LEGAL Changelog README SECURITY
+ insinto /etc/nagios
+ doins ${FILESDIR}/nsca.cfg
+ doins ${FILESDIR}/send_nsca.cfg
+ exeinto /usr/nagios/bin
+ doexe src/nsca
+ fowners nagios:nagios /usr/nagios/bin/nsca
+ exeinto /usr/nagios/libexec
+ doexe src/send_nsca
+ fowners nagios:nagios /usr/nagios/libexec/send_nsca
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/nsca
+}
+pkg_postinst() {
+ einfo
+ einfo "If you are using the nsca daemon, remember to edit"
+ einfo "the config file /etc/nagios/nsca.cfg"
+ einfo
+}