summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-01-04 18:30:06 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-01-04 18:30:06 +0000
commit125821f6c27874c16148652b8d1224eef02dd010 (patch)
treeeff4acac796cc4c6296705a951be6677027b6362 /net-analyzer/nagios
parentAdd ~s390 wrt #242294 (diff)
downloadgentoo-2-125821f6c27874c16148652b8d1224eef02dd010.tar.gz
gentoo-2-125821f6c27874c16148652b8d1224eef02dd010.tar.bz2
gentoo-2-125821f6c27874c16148652b8d1224eef02dd010.zip
Fix detection for incompatible upgrades
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'net-analyzer/nagios')
-rw-r--r--net-analyzer/nagios/ChangeLog7
-rw-r--r--net-analyzer/nagios/nagios-3.0.6.ebuild44
2 files changed, 26 insertions, 25 deletions
diff --git a/net-analyzer/nagios/ChangeLog b/net-analyzer/nagios/ChangeLog
index 9d7ec5101a8c..15c1e89f53a0 100644
--- a/net-analyzer/nagios/ChangeLog
+++ b/net-analyzer/nagios/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/nagios
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.75 2008/12/02 17:49:44 dertobi123 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.76 2009/01/04 18:30:06 dertobi123 Exp $
+
+ 04 Jan 2009; Tobias Scherbaum <dertobi123@gentoo.org> nagios-3.0.6.ebuild:
+ Fix detection for incompatible upgrades
*nagios-3.0.6 (02 Dec 2008)
diff --git a/net-analyzer/nagios/nagios-3.0.6.ebuild b/net-analyzer/nagios/nagios-3.0.6.ebuild
index c947150426d2..f91adfd392bd 100644
--- a/net-analyzer/nagios/nagios-3.0.6.ebuild
+++ b/net-analyzer/nagios/nagios-3.0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.6.ebuild,v 1.1 2008/12/02 17:49:44 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.6.ebuild,v 1.2 2009/01/04 18:30:06 dertobi123 Exp $
DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
nagios packages"
@@ -17,27 +17,25 @@ RDEPEND="~net-analyzer/nagios-core-${PV}
pkg_setup() {
# Avoid upgrading from Nagios <3 as the directory structure has changed
- if [[ -f /var/lib/init.d/started/nagios ]] ; then
- if has_version '<net-analyzer/nagios-3.0' ; then
- if [[ "${FORCE_UPGRADE}" ]] ; then
- echo
- ewarn "you are upgrading from an incompatible version and have"
- ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
- echo
- else
- echo
- eerror "You are upgrading from an incompatible version."
- eerror "Please be advised that installation paths have changed to a more FHS"
- eerror "compliant structure and you won't be able to easily upgrade to"
- eerror "Nagios 3 therefore. You will have to change your configuration"
- eerror "to reflect this change, for example Nagios plugins are now installed"
- eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
- echo
- eerror "If you want to upgrade now, emerge nagios with:"
- eerror " FORCE_UPGRADE=1 emerge nagios"
- die "Upgrading from an incompatible version!"
- echo
- fi
+ if has_version '<net-analyzer/nagios-3.0' ; then
+ if [[ "${FORCE_UPGRADE}" ]] ; then
+ echo
+ ewarn "you are upgrading from an incompatible version and have"
+ ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
+ echo
+ else
+ echo
+ eerror "You are upgrading from an incompatible version."
+ eerror "Please be advised that installation paths have changed to a more FHS"
+ eerror "compliant structure and you won't be able to easily upgrade to"
+ eerror "Nagios 3 therefore. You will have to change your configuration"
+ eerror "to reflect this change, for example Nagios plugins are now installed"
+ eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
+ echo
+ eerror "If you want to upgrade now, emerge nagios with:"
+ eerror " FORCE_UPGRADE=1 emerge nagios"
+ die "Upgrading from an incompatible version!"
+ echo
fi
fi
}