summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-11-26 21:37:22 +0000
committerCédric Krier <cedk@gentoo.org>2006-11-26 21:37:22 +0000
commitf00d9cfff0a3660f0a1403de1d2087e7eb02accd (patch)
treecaa702c279b9e2344677ddd9f0a4e3a5dde8dbe7 /net-analyzer/net-snmp/files
parentStable on ppc64 (diff)
downloadgentoo-2-f00d9cfff0a3660f0a1403de1d2087e7eb02accd.tar.gz
gentoo-2-f00d9cfff0a3660f0a1403de1d2087e7eb02accd.tar.bz2
gentoo-2-f00d9cfff0a3660f0a1403de1d2087e7eb02accd.zip
Version bump
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-analyzer/net-snmp/files')
-rw-r--r--net-analyzer/net-snmp/files/digest-net-snmp-5.43
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.4-makefile.patch20
-rw-r--r--net-analyzer/net-snmp/files/snmpd.conf17
-rw-r--r--net-analyzer/net-snmp/files/snmpd.rc730
-rw-r--r--net-analyzer/net-snmp/files/snmptrapd.rc722
5 files changed, 92 insertions, 0 deletions
diff --git a/net-analyzer/net-snmp/files/digest-net-snmp-5.4 b/net-analyzer/net-snmp/files/digest-net-snmp-5.4
new file mode 100644
index 000000000000..2141580dd27e
--- /dev/null
+++ b/net-analyzer/net-snmp/files/digest-net-snmp-5.4
@@ -0,0 +1,3 @@
+MD5 46d893281056ff476e597659cb91574d net-snmp-5.4.tar.gz 5031685
+RMD160 8ad1f9a3def8022eea48d9b74ae71d8efb59ca61 net-snmp-5.4.tar.gz 5031685
+SHA256 2f43cd6f3c4066f8c17fdc47931a96c1fce808c9d1dd74bcb5a79d9d29d5f947 net-snmp-5.4.tar.gz 5031685
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.4-makefile.patch b/net-analyzer/net-snmp/files/net-snmp-5.4-makefile.patch
new file mode 100644
index 000000000000..7b7ba127c110
--- /dev/null
+++ b/net-analyzer/net-snmp/files/net-snmp-5.4-makefile.patch
@@ -0,0 +1,20 @@
+diff -ru net-snmp-5.4~/agent/mibgroup/Makefile.in net-snmp-5.4/agent/mibgroup/Makefile.in
+--- net-snmp-5.4~/agent/mibgroup/Makefile.in 2006-11-26 16:43:18.000000000 +0100
++++ net-snmp-5.4/agent/mibgroup/Makefile.in 2006-11-26 16:44:49.000000000 +0100
+@@ -22,9 +22,13 @@
+ .c.o:
+ $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
+
+-OBJS = @mib_module_list_o@
+-LOBJS = @mib_module_list_lo@
+-SRCS = @mib_module_list_c@
++@mib_module_list_o@
++@mib_module_list_lo@
++@mib_module_list_c@
++
++OBJS = $(mib_module_list_o)
++LOBJS = $(mib_module_list_lo)
++SRCS = $(mib_module_list_c)
+
+ all: standardall $(LOBJS)
+
diff --git a/net-analyzer/net-snmp/files/snmpd.conf b/net-analyzer/net-snmp/files/snmpd.conf
new file mode 100644
index 000000000000..97a1d7052661
--- /dev/null
+++ b/net-analyzer/net-snmp/files/snmpd.conf
@@ -0,0 +1,17 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/files/snmpd.conf,v 1.8 2006/11/26 21:37:22 cedk Exp $
+
+# Initial (empty) options.
+SNMPD_FLAGS=""
+
+# Enable connection logging.
+#SNMPD_FLAGS="${SNMPD_FLAGS} -a"
+
+# Enable syslog and disable file log.
+#SNMPD_FLAGS="${SNMPD_FLAGS} -Lsd -Lf /dev/null"
+
+# Enable agentx socket as /var/agentx/master
+# *NOTE* Before uncommenting this, make sure
+# the /var/agentx directory exists.
+#SNMPD_FLAGS="${SNMPD_FLAGS} -x /var/agentx/master"
diff --git a/net-analyzer/net-snmp/files/snmpd.rc7 b/net-analyzer/net-snmp/files/snmpd.rc7
new file mode 100644
index 000000000000..11329bd75185
--- /dev/null
+++ b/net-analyzer/net-snmp/files/snmpd.rc7
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/files/snmpd.rc7,v 1.1 2006/11/26 21:37:22 cedk Exp $
+
+depend() {
+ use logger
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/snmp/snmpd.conf ] ; then
+ eerror "You need an /etc/snmp/snmpd.conf config file to run snmpd"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting net-snmpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/snmpd \
+ -- -p /var/run/snmpd.pid ${SNMPD_FLAGS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping net-snmpd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/snmpd.pid
+ eend $?
+}
diff --git a/net-analyzer/net-snmp/files/snmptrapd.rc7 b/net-analyzer/net-snmp/files/snmptrapd.rc7
new file mode 100644
index 000000000000..585675b4309e
--- /dev/null
+++ b/net-analyzer/net-snmp/files/snmptrapd.rc7
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/files/snmptrapd.rc7,v 1.1 2006/11/26 21:37:22 cedk Exp $
+
+depend() {
+ use logger
+ need net
+}
+
+start() {
+ ebegin "Starting snmptrapd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/snmptrapd \
+ -- -p /var/run/snmptrapd.pid ${SNMPTRAPD_FLAGS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping snmptrapd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/snmptrapd.pid
+ eend $?
+}