summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-17 21:51:14 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-17 21:51:14 +0000
commite1522dda8535531f318bae231b224d032397fe4d (patch)
tree1fe0c0e2f8d2aae669a3299653b86cc09bd67207 /net-analyzer/nethogs/nethogs-0.6.0.ebuild
parentMinor ebuild fixes (diff)
downloadgentoo-2-e1522dda8535531f318bae231b224d032397fe4d.tar.gz
gentoo-2-e1522dda8535531f318bae231b224d032397fe4d.tar.bz2
gentoo-2-e1522dda8535531f318bae231b224d032397fe4d.zip
Fix hardcoded CFLAGS and gcc
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-analyzer/nethogs/nethogs-0.6.0.ebuild')
-rw-r--r--net-analyzer/nethogs/nethogs-0.6.0.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.6.0.ebuild b/net-analyzer/nethogs/nethogs-0.6.0.ebuild
index 05c4d2426817..37f161c9c472 100644
--- a/net-analyzer/nethogs/nethogs-0.6.0.ebuild
+++ b/net-analyzer/nethogs/nethogs-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.6.0.ebuild,v 1.4 2005/08/16 19:24:33 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.6.0.ebuild,v 1.5 2005/09/17 21:51:14 vanquirius Exp $
-inherit eutils
+inherit eutils toolchain-funcs
HOMEPAGE="http://nethogs.sf.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -14,18 +14,18 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE=""
DEPEND="virtual/libpcap"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc34.diff
+ unpack ${A}; cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc34.diff"
+ # fix hardcoded CFLAGS and CC
+ sed -i -e "s:-O2:${CFLAGS}:g" Makefile || die
+ sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
+ sed -i -e "s:gcc:$(tc-getCC):g" Makefile || die
}
src_compile() {
- # There is currently no configure script within the nethogs package:
- # econf || die
-
emake || die "emake failed"
}