summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-29 01:37:23 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-29 01:37:23 +0000
commit1390cf3254447d9acfc2c2b775dd57891019b674 (patch)
tree4f033f094f29842d8d9f71814e8fa4c2be2d3305 /net-analyzer/netperf/netperf-2.2.4.ebuild
parentupdate to netperf-2.2pl4 for bug 19463 (diff)
downloadgentoo-2-1390cf3254447d9acfc2c2b775dd57891019b674.tar.gz
gentoo-2-1390cf3254447d9acfc2c2b775dd57891019b674.tar.bz2
gentoo-2-1390cf3254447d9acfc2c2b775dd57891019b674.zip
update to netperf-2.2pl4 for bug 19463
Diffstat (limited to 'net-analyzer/netperf/netperf-2.2.4.ebuild')
-rw-r--r--net-analyzer/netperf/netperf-2.2.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/netperf/netperf-2.2.4.ebuild b/net-analyzer/netperf/netperf-2.2.4.ebuild
new file mode 100644
index 000000000000..c4b49eab7247
--- /dev/null
+++ b/net-analyzer/netperf/netperf-2.2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.2.4.ebuild,v 1.1 2004/01/29 01:37:13 agriffis Exp $
+
+inherit flag-o-matic
+
+if [[ $PV == *.*.* ]]; then
+ MY_P=${P%.*}pl${PV##*.} # convert netperf-2.2.4 => netperf-2.2pl4
+ S=${WORKDIR}/${MY_P}
+else
+ MY_P=${P}
+fi
+
+DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets, ATM and more."
+SRC_URI="ftp://ftp.cup.hp.com/dist/networking/benchmarks/netperf/${MY_P}.tar.gz"
+HOMEPAGE="http://www.netperf.org/"
+LICENSE="netperf"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ia64 ~alpha"
+
+IUSE="ipv6"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ append-flags -DDO_UNIX
+ use ipv6 && append-flags -DDO_IPV6
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ # binaries
+ dosbin netserver
+ dobin netperf
+
+ # init.d / conf.d
+ exeinto /etc/init.d ; newexe ${FILESDIR}/${PN}-2.2-init netperf
+ insinto /etc/conf.d ; newins ${FILESDIR}/${PN}-2.2-conf netperf
+
+ # man pages
+ newman netserver.man netserver.1
+ newman netperf.man netperf.1
+
+ # documentation and example scripts
+ dodoc ACKNWLDGMNTS COPYRIGHT README Release_Notes netperf.ps
+ mkdir ${D}/usr/share/doc/${PF}/examples
+ cp *_script ${D}/usr/share/doc/${PF}/examples
+}