summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-11 16:32:05 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-11 16:32:05 +0000
commit6207e64471a5984999f7f530a33300859537bb62 (patch)
treef604d9554fafe769fafedc545211a1fd8756ee6a /net-analyzer/netselect/netselect-0.3.ebuild
parent See the changelog (diff)
downloadgentoo-2-6207e64471a5984999f7f530a33300859537bb62.tar.gz
gentoo-2-6207e64471a5984999f7f530a33300859537bb62.tar.bz2
gentoo-2-6207e64471a5984999f7f530a33300859537bb62.zip
New package
Diffstat (limited to 'net-analyzer/netselect/netselect-0.3.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-0.3.ebuild b/net-analyzer/netselect/netselect-0.3.ebuild
new file mode 100644
index 000000000000..906c3351e4b4
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3.ebuild,v 1.1 2002/07/11 16:32:05 stroke Exp $
+
+DESCRIPTION="Ultrafast implementation of ping."
+HOMEPAGE="http://www.worldvisions.ca/~apenwarr/netselect/"
+SRC_URI="http://www.worldvisions.ca/~apenwarr/netselect/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+
+newdepend /c
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ mv Makefile Makefile.orig
+ sed -e "s:PREFIX =.*:PREFIX = ${D}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ Makefile.orig > Makefile
+ rm Makefile.orig
+
+ make || die
+}
+
+src_install () {
+ make install || die
+
+ dodoc ChangeLog HISTORY README*
+}