summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-02-14 07:46:06 +0000
committerJeroen Roovers <jer@gentoo.org>2015-02-14 07:46:06 +0000
commitadffe38aa2d5284327ef86d6fce6f379359737b1 (patch)
tree5466cb8839d88dc99a847e6f1476094b686028eb /net-analyzer/netselect
parentAdd a note above every login.defs option that is ignored when USE=pam is acti... (diff)
downloadgentoo-2-adffe38aa2d5284327ef86d6fce6f379359737b1.tar.gz
gentoo-2-adffe38aa2d5284327ef86d6fce6f379359737b1.tar.bz2
gentoo-2-adffe38aa2d5284327ef86d6fce6f379359737b1.zip
Readd removed include by James Taylor (bug #540032).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/netselect')
-rw-r--r--net-analyzer/netselect/ChangeLog8
-rw-r--r--net-analyzer/netselect/files/netselect-0.3-bsd.patch9
-rw-r--r--net-analyzer/netselect/netselect-0.3-r4.ebuild43
3 files changed, 55 insertions, 5 deletions
diff --git a/net-analyzer/netselect/ChangeLog b/net-analyzer/netselect/ChangeLog
index aeaef4432b69..9f63e3b43815 100644
--- a/net-analyzer/netselect/ChangeLog
+++ b/net-analyzer/netselect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/netselect
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.58 2015/01/05 08:13:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.59 2015/02/14 07:46:06 jer Exp $
+
+*netselect-0.3-r4 (14 Feb 2015)
+
+ 14 Feb 2015; Jeroen Roovers <jer@gentoo.org> +netselect-0.3-r4.ebuild,
+ files/netselect-0.3-bsd.patch:
+ Readd removed include by James Taylor (bug #540032).
05 Jan 2015; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Remove short <longdescription>.
diff --git a/net-analyzer/netselect/files/netselect-0.3-bsd.patch b/net-analyzer/netselect/files/netselect-0.3-bsd.patch
index c3fc3696998e..e9624d87215a 100644
--- a/net-analyzer/netselect/files/netselect-0.3-bsd.patch
+++ b/net-analyzer/netselect/files/netselect-0.3-bsd.patch
@@ -1,6 +1,6 @@
--- a/netselect.c
+++ b/netselect.c
-@@ -39,14 +39,13 @@
+@@ -39,14 +39,14 @@
* hey, great! Let me know. -- apenwarr
*/
@@ -14,6 +14,7 @@
-# include <endian.h>
+#ifdef __linux__
+#include <endian.h>
++#include <sys/types.h>
+#elif defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__)
+#if defined(__OpenBSD__)
+#include <machine/types.h>
@@ -22,7 +23,7 @@
#endif
#include <sys/param.h>
-@@ -152,6 +151,7 @@
+@@ -152,6 +152,7 @@
extern int optind;
int hostcount, startcount, endcount = 0, sent_one, lag, min_lag = 100;
int ch, seq, ttl, max_ttl = 30, min_tries = 10, num_score = 1;
@@ -30,7 +31,7 @@
struct timeval now;
struct timezone tz;
OPacket outpacket; /* last output (udp) packet */
-@@ -234,7 +234,12 @@
+@@ -234,7 +235,12 @@
if (verbose >= 1)
fprintf(stderr, "Running netselect to choose %d out of %d address%s.\n",
num_score, numhosts, numhosts==1 ? "" : "es");
@@ -44,7 +45,7 @@
/* keep going until most of the hosts have been finished */
must_continue = numhosts;
while (must_continue && must_continue >= numhosts/2)
-@@ -712,7 +717,7 @@
+@@ -712,7 +718,7 @@
ip->ip_off = 0;
ip->ip_hl = sizeof(*ip) >> 2;
ip->ip_p = IPPROTO_UDP;
diff --git a/net-analyzer/netselect/netselect-0.3-r4.ebuild b/net-analyzer/netselect/netselect-0.3-r4.ebuild
new file mode 100644
index 000000000000..7f85c216ccdd
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r4.ebuild,v 1.1 2015/02/14 07:46:06 jer Exp $
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping"
+HOMEPAGE="http://apenwarr.ca/netselect/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-bsd.patch" \
+ "${FILESDIR}/${P}-glibc.patch"
+
+ sed -i \
+ -e "s:PREFIX =.*:PREFIX = ${ED}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. ${CFLAGS}:" \
+ -e "s:LDFLAGS =.*:LDFLAGS = ${LDFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin netselect
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+ dodoc ChangeLog HISTORY README*
+}